Author Topic: Can't compile anything or build anything with the ide.  (Read 9631 times)

Offline Amon

  • Mr. Drawsprite
  • **
  • Posts: 55
  • I code, therefore I am!
    • View Profile
    • Amon.co
Hi I updated to the latest version and I can't seem to compile or build. Even if I put a simple while loop it just doesn't want to compile or build and rung the app?

Any ideas as to what could be wrong?
- http://www.amon.co | Dev Tools - BlitzMax - Shiva Unlimited - Unity Pro - Carrara 8 Pro - Hexagon 2.2.5 - Blacksmith 3D Paint - FuturePaint Pro - Bryce 7 Pro.
I'm never wrong at all; I just discover 1000 ways that don't work!

Offline Synthetic

  • Mr. Drawsprite
  • **
  • Posts: 61
    • View Profile
    • ClanBam
Is is giving you any specific errors?
"Impossible is a word people use to make themselves feel better when they quit."

My AMXMODX plugins for Day of Defeat 1.3 can be found here.

Offline okee

  • Dr. Type
  • ****
  • Posts: 324
    • View Profile
Or did you install mingw
Android: Samsung Galaxy S2 -  ZTE Blade (Orange San Francisco) - Ainol Novo 7 Aurora 2
IOS: 2 x Ipod Touch (1G)

Offline Amon

  • Mr. Drawsprite
  • **
  • Posts: 55
  • I code, therefore I am!
    • View Profile
    • Amon.co
I have MinGW installed because it's needed by BlitzMax. As for error messages it doesn't bring up anything, no popup or console message other than Build 1 0 succeded.
- http://www.amon.co | Dev Tools - BlitzMax - Shiva Unlimited - Unity Pro - Carrara 8 Pro - Hexagon 2.2.5 - Blacksmith 3D Paint - FuturePaint Pro - Bryce 7 Pro.
I'm never wrong at all; I just discover 1000 ways that don't work!

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10726
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
please, post what's in the output text box when you compile. Please also load an example project (gbaP file).

Offline okee

  • Dr. Type
  • ****
  • Posts: 324
    • View Profile
Amon when I install Mingw and set the paths in environment it causes havoc
with GLBasic, so i just remove the paths and replace them when i need to compile
a module in Blitz.

Android: Samsung Galaxy S2 -  ZTE Blade (Orange San Francisco) - Ainol Novo 7 Aurora 2
IOS: 2 x Ipod Touch (1G)

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10726
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
what environment variables are there changed with mingw?

Offline okee

  • Dr. Type
  • ****
  • Posts: 324
    • View Profile
MingW doesn't change any environment variables. but i
need to do the following to allow Blitzmax to compile modules

Quote
ANY WINDOWS OS:
1.- Click the start button, right click on 'My Computer' on XP or 'System' on Vista and seven. Then click on 'Properties'. Select the 'Advanced Properties Tab' and at the bottom you will see the 'Environment Variables' button. Click that.
It should open up a new window with two boxes named 'User Variables for blah' and 'System Variables'.

2.- Click 'New' for User Variables and in the 'Variable Name' box type MinGW. In the 'Variable Value' Box enter the path to the MinGW installation ie C:\MinGW. Then click OK.
So environment variables look something like:



Compiling a small program in GLB gives this error
Quote
Wordcount:4 commands
compiling:

linking:
/mingw/lib/crt2.o:crt1.c:(.text+0x28): undefined reference to `___dyn_tls_init_callback'
*** FATAL ERROR - Please post this output in the forum
_______________________________________
*** Finished ***
Elapsed: 1.6 sec. Time: 15:34
Build: 0 succeeded.
*** 1 FAILED ***

I think it may be that GLB finds the c:\MinGW path first
Android: Samsung Galaxy S2 -  ZTE Blade (Orange San Francisco) - Ainol Novo 7 Aurora 2
IOS: 2 x Ipod Touch (1G)

Offline Amon

  • Mr. Drawsprite
  • **
  • Posts: 55
  • I code, therefore I am!
    • View Profile
    • Amon.co
Hi! Loading a normal file or any type of file now gives me the same error as okee. It deffo has something to do with MinGW.
- http://www.amon.co | Dev Tools - BlitzMax - Shiva Unlimited - Unity Pro - Carrara 8 Pro - Hexagon 2.2.5 - Blacksmith 3D Paint - FuturePaint Pro - Bryce 7 Pro.
I'm never wrong at all; I just discover 1000 ways that don't work!

MrTAToad

  • Guest
Thats odd - I've got MinGW installed, and, aside from the Windows CE compiling problem, it doesn't interfere with anything...

My path is :

Code: (glbasic) [Select]
C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;c:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;R:\Qt\2010.05;r:\MinGW\bin;r:\MinGW;R:\SlikSvn\bin\;C:\Program Files (x86)\Windows Live\Shared
and

Code: (glbasic) [Select]
MinGW = R:\MinGW
« Last Edit: 2010-Nov-10 by MrTAToad »

Offline Amon

  • Mr. Drawsprite
  • **
  • Posts: 55
  • I code, therefore I am!
    • View Profile
    • Amon.co
There's still no joy for me. It refuses to compile/build.

I have removed MinGW and reinstalled GLbasic but I get the same error. Sometimes the error doesn't even show in the console.

What is worng with it?
- http://www.amon.co | Dev Tools - BlitzMax - Shiva Unlimited - Unity Pro - Carrara 8 Pro - Hexagon 2.2.5 - Blacksmith 3D Paint - FuturePaint Pro - Bryce 7 Pro.
I'm never wrong at all; I just discover 1000 ways that don't work!

Offline Amon

  • Mr. Drawsprite
  • **
  • Posts: 55
  • I code, therefore I am!
    • View Profile
    • Amon.co
Ok, after a bit more messing about it now works properly. I had to completely remove any reference to MinGW i.e. Environment variables, anythign stored in "path" and a clean of the temp folder. After reboot it works fine.

Is there any way to be able to use GLbasic while MinGW is installed? It just seems a bit of a waste of time to have to keep adding MinGW to use blitzMax and removing it in order to use GLBasic.

- http://www.amon.co | Dev Tools - BlitzMax - Shiva Unlimited - Unity Pro - Carrara 8 Pro - Hexagon 2.2.5 - Blacksmith 3D Paint - FuturePaint Pro - Bryce 7 Pro.
I'm never wrong at all; I just discover 1000 ways that don't work!

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10726
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Don't use BlitzMax :P
Honestly, if you find any environment variable settings (you can start the editor from a command line to test) that allow mingw in c:, please tell me.

MrTAToad

  • Guest
What was the contents of %PATH% ?

Offline Amon

  • Mr. Drawsprite
  • **
  • Posts: 55
  • I code, therefore I am!
    • View Profile
    • Amon.co
The contents of the path file had C:\MinGW\bin in it. 

Quote
C:\Program Files (x86)\ATI Stream\bin\x86_64;C:\Program Files (x86)\ATI Stream\bin\x86;%CommonProgramFiles%\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\MinGW\bin;C:\Applications\Coding\TortoiseSVN\bin;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\;C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\QuickTime\QTSystem\;C:\MinGW\bin

I'll try what Kitty says now. :)
- http://www.amon.co | Dev Tools - BlitzMax - Shiva Unlimited - Unity Pro - Carrara 8 Pro - Hexagon 2.2.5 - Blacksmith 3D Paint - FuturePaint Pro - Bryce 7 Pro.
I'm never wrong at all; I just discover 1000 ways that don't work!