GLB crashing on startup

Previous topic - Next topic


Everything was fine yesterday, came to start coding today and getting a crash almost straight away on editor start up, the normal windows xp error "GLBasic has encountered a problem and needs to close"

Is there an ini file somewhere that stores what the last files opened were? Im wondering if that could have got corrupted. Don't want to do a clean install as I am using an old version which works fine for the project I'm working on



just as an update, I uninstalled the V10 I was running, reinstalled the same version and same thing happened, so uninstalled again and went for v14, still exactly the same thing, splash screen then a windows alert when the main editor screen launches. could the licence key be corrupt and if so where would i find that? is there anything in the registry?

Ian Price

I would expect the License key to have no bearing on start-up; tt would just give you a demo version.

There is registry info in SOFTWARE > Dream_Design > GLBasic

You could try deleting all info relating to GLB. Also ensure that there are no remnants from old installations. Make sure you have all your log-in detail before removing any info though and be aware that you could *love* up your pc playing with the registry. Back up first.

When you try to open GLB are you choosing a file or trying to create a new project? If the former, are you sure the file still exists? GLB doesn't normally crash when trying to find a non-existant file, but hey-ho.
I came. I saw. I played.


That is very strange case Gary, I have never seen it before. Which leads me to think that the crash is related to something on your OS instead of GLB.
Does GLB´s ide use something system related? Like .net framework? Could it be the culprit?


Hey Gary,

Try copying the full folder to another location and run from there - browsing to the editor.exe and not the menu in Windows > programs etc

Sometimes the menu points to a different version than we expect.

Also make sure your virus checker isnt quarantining your exe file and crashing it

So disable any startup tray apps that may be running in the background to try to see if they are the problem.

Speccy-48k, Speccy-128k, Amigas, PCs


Very strange, I have tried all the above and got the same result every time. Im not even getting to the screen to select a project to open, its bringing up the splash screen and then crashing.

The only thing I can think of is because I am running via parallels on a mac that something has updated on that which is breaking GLB. I will just set up a new VM in Parallels, stick v10 back on it and try that.

Thanks for the tips so far though, a very strange one


Hi Gary you can see the chmod of the paralells folder on is installed GLbasic... I use someyears ago Mac under paralells and all runs fine.

I have a lot of problems with Windows 7 Virtualized and the folder users, perhaps GLbasic can't write in the folder and crash...


well I have solved the problem, not found out exactly why but its working again now. I have my source stored on dropbox on the mac side and access it via parallels for the windows size direct from there. I moved the files locally to the new install of window, ran GLB and opened the files perfectly. So it seems to be an issue when you have files on a network path in recent files that are no longer there I think