Author Topic: Final compile for iphone/ipod touch question  (Read 2650 times)

Offline mykyl66

  • Mr. Polyvector
  • ***
  • Posts: 114
    • View Profile
I seem to have thought about this a bit too late but Here is my question.
I have had my app tested on an early iphone up to the latest iphone 3gs as well as on an ipod touch generation 1 up to the latest 3g but suddenly had a thought. I think that all of them are running the latest 3.x os.

I have been building for the base 3.x all this time but suddenly wondered if I have to do anything to make sure it will run on folks machines who are perhaps still on 2.x etc?

Will an app compiled using 3.x work on the earlier os machines? I am obviously not using in app purchases etc as I don't have a clue how to do that.

Can anyone help?

Hoping to show what we have been up to in the coming week.

Cheers

Mike R

MrTAToad

  • Guest
Re: Final compile for iphone/ipod touch question
« Reply #1 on: 2010-Mar-22 »
I don't think using the 3.x SDK would result in a program compatible with 2.x users - you would need to compile with the latter.

Offline mykyl66

  • Mr. Polyvector
  • ***
  • Posts: 114
    • View Profile
Re: Final compile for iphone/ipod touch question
« Reply #2 on: 2010-Mar-22 »
blast. That would be a pain. The later sdk versions wiped the older versions from my mac and I have not been able to find the 2 sdk or whatever is needed to download anywhere.

This is going to get frustrating. I know sdk2 is on my machine as I never removed it yet it doesnt show as an option to build for 2. The lowest is 3.0 base.

Cheers anyway.

Mike
« Last Edit: 2010-Mar-22 by mykyl66 »

Offline mykyl66

  • Mr. Polyvector
  • ***
  • Posts: 114
    • View Profile
Re: Final compile for iphone/ipod touch question
« Reply #3 on: 2010-Mar-22 »
Apparently I must have over written 2. However Apple dont seem to allow you to download older versions or at least hide them well so you dont have an option but to cripple your chances by cutting out all the v 2 users out there.

grrrrr.

I was right. I can see the 2.0 etc listed in my developer directory but cant get them listed in xcode to use.

Mike
« Last Edit: 2010-Mar-22 by mykyl66 »

Offline mykyl66

  • Mr. Polyvector
  • ***
  • Posts: 114
    • View Profile
Re: Final compile for iphone/ipod touch question
« Reply #4 on: 2010-Mar-22 »
Right I found the answer. Right click on the target (iphone) in xcode. Go to get info, Go to build then change the base sdk to 2.2.1. Sorted and sweaty brow wiped. :D

Cheers

Mike R

Offline Ozden79

  • Mr. Polyvector
  • ***
  • Posts: 121
    • View Profile
Re: Final compile for iphone/ipod touch question
« Reply #5 on: 2010-Mar-22 »
Hi There,

Your solution will work and there's another option where you can set your build target as 3.X but deployment target as 2.X which will allow your game to run on 2.X devices. You'll need that in some cases, for example if you want to integrate openfeint and target 2.X devices at the same time.

Özden

Offline mykyl66

  • Mr. Polyvector
  • ***
  • Posts: 114
    • View Profile
Re: Final compile for iphone/ipod touch question
« Reply #6 on: 2010-Mar-22 »
Will have to have a look for that as we do plan on adding openfeint in the near future.

Cheers

Mike R