Author Topic: GLBasic and Java 8  (Read 2197 times)

Offline Jonás Perusquía

  • Mr. Polyvector
  • ***
  • Posts: 170
    • View Profile
    • Ditrabox
GLBasic and Java 8
« on: 2014-Jul-04 »
Hello everyone!

i tried to compile with new java sdk version 8u5

however, the console shows this and hangs:
Code: (glbasic) [Select]


BUILD STAGE 1: Compile and pack RELEASE
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
El sistema no puede encontrar la ruta especificada.
Updated and renamed default.properties to project.properties
Updated local.properties
Added file C:\Users\JonasPM\DEVELOPMENT\GLBasic\DitraFall\distribute\Android\build.xml
Added file C:\Users\JonasPM\DEVELOPMENT\GLBasic\DitraFall\distribute\Android\proguard-project.txt
Picked up _JAVA_OPTIONS: -Xms256m -Xmx512m
.
BUILD STAGE 2: Build DEBUG and install on device
   [subant] No sub-builds to iterate on
    [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
    [javac] 3 warnings

Maybe GLBasic 12.243 is currently not compatible with the newest Java version?

Thanks in advance!
<HTML><BASIC><EC>
Be free and do good things

MrTAToad

  • Guest
Re: GLBasic and Java 8
« Reply #1 on: 2014-Jul-04 »
Looks like some pathing isn't correct unfortunately...

Offline Kyo

  • Dr. Type
  • ****
  • Posts: 350
    • View Profile
Re: GLBasic and Java 8
« Reply #2 on: 2014-Jul-04 »
Sorry fot the OT!

GLBasic 12.243?????

but are you sure?  I have 12.096  and Gl_b  tell me that is updated to the latest version  :S

Offline Jonás Perusquía

  • Mr. Polyvector
  • ***
  • Posts: 170
    • View Profile
    • Ditrabox
Re: GLBasic and Java 8
« Reply #3 on: 2014-Jul-28 »
Sorry fot the OT!

GLBasic 12.243?????

but are you sure?  I have 12.096  and Gl_b  tell me that is updated to the latest version  :S

Yes, i downloaded the latest version from here: http://www.glbasic.com/main.php?site=download
<HTML><BASIC><EC>
Be free and do good things

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4350
    • View Profile
    • FUED
Re: GLBasic and Java 8
« Reply #4 on: 2014-Jul-28 »
oh my... I´m running the 096 too, didn´t know there was a newer one! (did it get posted anywhere?)
Time to update stuff :good:

edit: downloaded, it is indeed a newer version :O ... can´t find the change/fix log on site, maybe within the package?

edit2: ohh my, no fix for the virtual screen on this one :( ....but I´m patient :)
« Last Edit: 2014-Jul-29 by erico »