Author Topic: Problem updating/compiling  (Read 2767 times)

Offline fuzzy70

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 828
  • Look left, Look right, LOOK OUT!!
    • View Profile
Problem updating/compiling
« on: 2013-Feb-17 »
I am having some weird problems with regards to GLBasic which only started the other day.

If I try to rebuild a program I get an error
Code: GLBasic [Select]
*** Configuration: WIN32 ***
precompiling:
GPC - GLBasic Precompiler V.10.104 SN:fed6c88c - 2D, WIN32
Wordcount:3 commands
compiling:

linking:
Access is denied.

*** ERROR - Can't overwrite program. Is it still running?
_______________________________________
*** Finished ***
Elapsed: 13.5 sec. Time: 10:06
Build: 0 succeeded.
*** 1 FAILED ***

This happens on new or old code & I can compile fine the straight after opening or starting a new project but as soon as I make a change (even minor like changing x=x+1 to x=x+2) the above error appears. I am able to rebuild after trying again around 1-2 mins later.

I have uninstalled & manually removed any references to GLBasic in the registry, done a complete virus scan (left running over night) & then re-installed. I have tried PureBasic, Blitz3D & BlitzMax along with other non programming apps & have no problems editing/modifying files with those just GLBasic ones.

Another thing I have noticed, when I do try to rebuild I look at the generated exe & the security tab says "You do not have permission to view or edit this object's permission settings" & the file deletes itself shortly after again around the 1-2min mark.

I have just managed to finally update from 10.202 to 10.283 after 20+ attempts and failing with an "Unable to update Editor_e.exe" error.

Wiping & re-installing windows is not really an option I would like to do if at all possible and seeing as I have only come across this problem with GLBasic as every other program is working fine.

As a note I did try the public beta but only compiled a few examples without doing any changes so not 100% sure when this problem appeared. I know it was within the last week or two as had no problems while messing about with the "Transparency Mask" program in the forum.

Other than the beta the only other downloads I have done was a graphics driver update, Notepad++ update as well as a couple of normal windows updates.

I honestly cannot see that the issue is with or came from GLBasic but at the moment that is the only program that seems to have been effected, I believe it is a windows problem but narrowing down what exactly is doing my head in seeing as everything else works fine.

Any suggestions would be appreciated =D

Lee

"Why don't you just make ten louder and make ten be the top number and make that a little louder?"
- "These go to eleven."

This Is Spinal Tap (1984)

Offline hardyx

  • Community Developer
  • Dr. Type
  • ******
  • Posts: 491
    • View Profile
Re: Problem updating/compiling
« Reply #1 on: 2013-Feb-17 »
I think may be a problem with your projects folder permisions or conflict with any antivirus software you have. Check the proyect folder is in your user folder and you can write files there. The error you get occurs when you have the program running, check you terminate the program you are creating before compiling again, or use Shift+F5 to stop the program.

MrTAToad

  • Guest
Re: Problem updating/compiling
« Reply #2 on: 2013-Feb-17 »
Its also possible the attributes have been set to read-only or you dont have permission to access the location.

Are you using Windows 7 or 8 ?

Would be worth checking sharing permissions for the directories and files (even if they aren't being shared).

Offline fuzzy70

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 828
  • Look left, Look right, LOOK OUT!!
    • View Profile
Re: Problem updating/compiling
« Reply #3 on: 2013-Feb-17 »
Thanks for the suggestions,

I'm running windows 7. Have checked all folder permissions & they are fine, same with the initial build it has my permissions but if I make a change within 1-2 minutes from last build & re-do it the resulting .exe has no permissions that are mine & am unable to view them. The program is 100% not running when I make any changes to the source code & have tried closing by pressing escape as well as the close gadget. This happens with ANY project, both new or existing & regardless of where the project is created.

All my projects are stored on a separate partition in a GLB sub folder, same with my Purebasic, Blitz etc projects & they are not having any issues like this (checked sharing & that's off & fine).

Just to make sure I took ownership of the folder again yet it still results in the same problem. Looks like a reformat might have to be done as waiting 1-2 minutes per build just to check tiny changes would result in my laptop being thrown at the wall in frustration  :D

Lee
"Why don't you just make ten louder and make ten be the top number and make that a little louder?"
- "These go to eleven."

This Is Spinal Tap (1984)

MrTAToad

  • Guest
Re: Problem updating/compiling
« Reply #4 on: 2013-Feb-20 »
I make sure all my programs are in the Documents directory.  Anywhere else will cause problems due to the UAC

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4152
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: Problem updating/compiling
« Reply #5 on: 2013-Feb-20 »
I was getting a similar problem as of today -

Quote
linking:
C:\Users\Ian\Desktop\GLBasic\Compiler\platform\Win32\Bin\strip.exe: unable to rename 'C:\Users\Ian\AppData\Local\Temp\glbasic\output.obj'; reason: Permission denied
The system cannot find the file specified.

*** ERROR - Can't overwrite program. Is it still running?

I wondered what could be preventing my program from running/preventing me from accessing certain files - the only things that had changed were two updates to software I use regularly -  iTunes and AVG anti-virus. I suspected the latter more than the former, despite how shit Apple software is.

After turning off AVG my program ran properly everytime. AVG is being a bit aggressive, methinks.
I came. I saw. I played.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10723
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Problem updating/compiling
« Reply #6 on: 2013-Feb-20 »
Yes. AV programs sometimes grab intermediate files and disalow the rename or deletion.

MrTAToad

  • Guest
Re: Problem updating/compiling
« Reply #7 on: 2013-Feb-20 »
I use Microsoft Security Essentials, although when I get Windows 8 in a day or so, that will change...

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4240
    • View Profile
    • Portfolio
Re: Problem updating/compiling
« Reply #8 on: 2013-Feb-21 »
Any especial reason?

MrTAToad

  • Guest
Re: Problem updating/compiling
« Reply #9 on: 2013-Feb-21 »
Mainly because it was time to re-install the operating system, and decided to go for Windows 8.  Plus I can check to see if there are any GLBasic problems with it

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3366
  • Integrated Brain
    • View Profile
Re: Problem updating/compiling
« Reply #10 on: 2013-Feb-21 »
HI I update to win 8  , and I don't have any problem all runs very fine, I use the 10 Version... about my antivirus it's the Avast...

The true thing it's always I want delete a folder contains a file GLBas , windows tell me an error about permisions,,, this was in wi n 7 too... but only when the folder contains somthing whit GLBasic code...  :zzz: Extrange...

Offline fuzzy70

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 828
  • Look left, Look right, LOOK OUT!!
    • View Profile
Re: Problem updating/compiling
« Reply #11 on: 2013-Feb-21 »
I was getting a similar problem as of today -

Quote
linking:
C:\Users\Ian\Desktop\GLBasic\Compiler\platform\Win32\Bin\strip.exe: unable to rename 'C:\Users\Ian\AppData\Local\Temp\glbasic\output.obj'; reason: Permission denied
The system cannot find the file specified.

*** ERROR - Can't overwrite program. Is it still running?

I wondered what could be preventing my program from running/preventing me from accessing certain files - the only things that had changed were two updates to software I use regularly -  iTunes and AVG anti-virus. I suspected the latter more than the former, despite how shit Apple software is.

After turning off AVG my program ran properly everytime. AVG is being a bit aggressive, methinks.

I to had AVG but thinking about it prior to that I had Microsoft security essentials, so seems a bit of a coincidence that things started playing up after changing to AVG.

Over the weekend I wiped my drive & done a re-install of windows 7 which in hind sight was due anyway as drive was getting a bit messy from program installs/uninstalls, along with new versions of programs which do not remove the previous versions i,e Cinema 4D, Cakewalk Sonar etc .

It is a pain installing them all again plus updating them but my system boots quicker & generally feels more "Snappier" now. Also helps that I keep all my generated content like documents/audio/programming etc on a separate partition (for easy back up) so when I do a wipe my data is still intact without having to rummage around for it  :D.

At the moment I am still using 10.283 which again gave me an error updating the "Editor_e.exe" file but this time it worked on the second attempt rather than the 10+ before which removes the AV program from fault on that part as none was installed at that time. Have also gone back to Microsoft security essentials for the time being as didn't have any problems with that before.

Lee
"Why don't you just make ten louder and make ten be the top number and make that a little louder?"
- "These go to eleven."

This Is Spinal Tap (1984)