Author Topic: Possible bug in the last Update (Filerequest$ Command)  (Read 2741 times)

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3372
  • Integrated Brain
    • View Profile
HI I have a strange error, or something I made wrong...

Well the fact it´s , when I use filerequest$ command, I have all the path to the filename included...

This occurs someone more?¿...

MrTAToad

  • Guest
You're lucky!

On Windows x64, in debug mode I get :


*** Unhandled exception ***
   ExceptionCode = 0xc0020043

And in release mode nothing happens :)

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3372
  • Integrated Brain
    • View Profile
Hi MRTatoad I have this error in debug mode too:
*** Unhandled exception ***
   ExceptionCode = 0xc0020043

Something wrong, not?¿

MrTAToad

  • Guest
Gernot has never been able to find the problem with it...

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10745
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
It's a bug in the Windows API. Also happens with the visual studio when the debugger is active :(

Filerequest$ always returned an absolute path.

Offline spicypixel

  • Prof. Inline
  • *****
  • Posts: 646
  • Pixel Artist
    • View Profile
    • SpicyPixel.net
Wow! Just had this exact error. I googled "ExceptionCode = 0xc0020043" and lo and behold I arrive here. Least I know its to do with Debug now and can compile accordingly.
http://www.spicypixel.net | http://www.facebook.com/SpicyPixel.NET

Comps Owned - ZX.81, ZX.48K, ZX.128K+2, Vic20, C64, Atari-ST, A500.600.1200, PC, Apple Mini-Mac.

MrTAToad

  • Guest
If you need something like that in debug mode, it might be worth looking into DDgui_FileRequest$