Author Topic: MinGW problem  (Read 2830 times)

Offline bricky91

  • Mc. Print
  • *
  • Posts: 47
    • View Profile
MinGW problem
« on: 2010-Nov-14 »
Hi guys, I have a problem. I installed minGW in order to get Netbeans work (well, and I didn't even mange to get it wrok...), but now when I try to compile I get this output:
Code: (glbasic) [Select]
/mingw/lib/crt2.o:crt1.c:(.text+0x28): undefined reference to `___dyn_tls_init_callback'Any ideas on how to fix this?  :(

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4158
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: MinGW problem
« Reply #1 on: 2010-Nov-14 »
Another user (Amon) had this problem recently too - there is a supposed solution posted here - http://www.glbasic.com/forum/index.php?topic=5325.msg41641#msg41641
I came. I saw. I played.

Offline bricky91

  • Mc. Print
  • *
  • Posts: 47
    • View Profile
Re: MinGW problem
« Reply #2 on: 2010-Nov-14 »
Oh great, thank you, I installed the previous version of minGW and now it works. Thanks!  :good:

MrTAToad

  • Guest
Re: MinGW problem
« Reply #3 on: 2010-Nov-14 »
You could also move the position of c:\MinGW within %PATH%

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10746
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: MinGW problem
« Reply #4 on: 2010-Nov-17 »
FIXED!!! I fixed it!!!

Next update will co-opperate with a mingw installation. Phew!

MrTAToad

  • Guest
Re: MinGW problem
« Reply #5 on: 2010-Nov-17 »
Good to hear!