Author Topic: Shoebox on PocketPC  (Read 2035 times)

Offline AndyH

  • Dr. Type
  • ****
  • Posts: 383
    • View Profile
    • http://www.ovine.net/
Shoebox on PocketPC
« on: 2008-Jan-25 »
Hi

having a wee problem with shoebox on the PocketPC.

I have a folder structure:

GAME.EXE
GAME_CE.EXE
DATA\IMG\  (load of PNG's in here - notice IMG is a subfolder to DATA)


I shoebox DATA to get DATA.sbx and it looks the right size.

I add the following line to my code at the top:

SETSHOEBOX "DATA.sbx", ""

And then rename my DATA folder just to make sure I know it's loading the sprites from my shoebox and not the original folder.


Run on Windows and it works, LOADSPRITE and LOADBMP get the required images from my shoebox.

Compile and run on the pocket PC and no graphics are loaded.  The game runs, (I can see my default text) but no sprites or background is displayed.  The DATA.sbx sits in the same folder as the GAME_CE.exe (on my Pocket PC's SD card in a sub-folder).

Here's an example load command:

LOADANIM "DATA/IMG/bgtile01.png", 0, 16,16

have tried LOADANIM "./DATA/IMG/bgtile01.png", 0, 16,16 and LOADANIM "\\DATA\\IMG\\bgtile01.png", 0, 16,16 as well.  All of these work on the PC but not on the Pocket PC.

If I copy my DATA folder on to the Pocket PC the game works, so it's something to do with the shoebox as this shows my code is working with out it.



Doing anything wrong or is there a bug?  BTW, what is the best method to use for folders considering the code can be compiled to PPC, PC, Linux, Mac etc?  Is it / or \ ("\\" in the string) ?

Offline AndyH

  • Dr. Type
  • ****
  • Posts: 383
    • View Profile
    • http://www.ovine.net/
Shoebox on PocketPC
« Reply #1 on: 2008-Jan-25 »
Also gave this a try:  SETSHOEBOX GETCURRENTDIR$()+"ovine.sbx", "" but no luck.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10766
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Shoebox on PocketPC
« Reply #2 on: 2008-Jan-25 »
Always use forward slashes "/".
It seems like a bug. I'll have to check (doh!).

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10766
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Shoebox on PocketPC
« Reply #3 on: 2008-Feb-03 »
Fixed. Oh dear. This was a very stupid one.

Offline AndyH

  • Dr. Type
  • ****
  • Posts: 383
    • View Profile
    • http://www.ovine.net/
Shoebox on PocketPC
« Reply #4 on: 2008-Feb-03 »
Thanks Gernot.  Is that fixed in 5.156 or the next build?  I'll get back on to test this today hopefully if fixed in this build.

LQ75

  • Guest
Re: Shoebox on PocketPC
« Reply #5 on: 2010-Feb-05 »
I've made a small game which works alright but after i put all the graphics and sound into a shoebox it became unstable... Anyone had similiar problem before? Help me please!