Author Topic: MCI Error with new update (5.149) :(  (Read 3385 times)

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4160
  • On the shoulders of giants.
    • View Profile
    • My Apps
MCI Error with new update (5.149) :(
« on: 2008-Jan-25 »
Hi Gernot

Just updated GLB to version 5.149 and went to test that MP3s now play in fullscreen only to be greeted with this message, immediately as the title tune started playing

http://www.iprice.remakes.org/stuff/GLB_Error.PNG

As you know, the music and sound ran fine in the preview versions (except for volume ;)), so something else has crept in in the update. :(
I came. I saw. I played.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10760
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
MCI Error with new update (5.149) :(
« Reply #1 on: 2008-Jan-25 »
Doh!
I hope I can reproduce that.

Hb!

  • Guest
MCI Error with new update (5.149) :(
« Reply #2 on: 2008-Jan-26 »
It happened with me as well, it seems, to be related with the "Playmusic" command, why? , because , I  removed that , and my little program worked fine again. So, I suggest you Gernot, to check out that.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10760
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
MCI Error with new update (5.149) :(
« Reply #3 on: 2008-Jan-26 »
Great I can't reproduce it. It just works for me.
I'll update a version with some debug info. When you start again, and discover this message box, don't click it.
Alt-Tab to an explorer and open the file %TEMP%\ErrorLog.txt
Please post it here.
So so sorry.

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4160
  • On the shoulders of giants.
    • View Profile
    • My Apps
MCI Error with new update (5.149) :(
« Reply #4 on: 2008-Jan-26 »
It's definitely to do with PlayMusic - the strange thing is the music does actually play, despite this error...
I came. I saw. I played.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10760
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
MCI Error with new update (5.149) :(
« Reply #5 on: 2008-Jan-26 »
get the update, post the errorlog, please.

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4160
  • On the shoulders of giants.
    • View Profile
    • My Apps
MCI Error with new update (5.149) :(
« Reply #6 on: 2008-Jan-26 »
Erm... It's not doing it today (before and after update) :S
I came. I saw. I played.