BASIC

Author Topic: Android: CREATESCREEN fails on some devices (like NEXUS 7).  (Read 4059 times)

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3606
    • View Profile
    • Space Fractal
http://www.glbasic.com/forum/index.php?topic=8677.msg73706#msg73706

The issue with Nexus 7 is that when using CREATESCREEN/USESCREEN you will get similar errors to:

         I/glbasic ( 8665): glBindRenderbufferExt failed 8cd6

which is: 

         GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

I believe this is an issue within GLB whereby it's not defining the correct z buffer component (16bits vs 32bits).

If you do NOT use createscreen/usescreen in your app/game, then it will run perfectly fine on the Nexus 7.

Note: The same also applies to the Asus Transformer.

I thinks he can been right you might use wrong settings. If its cant been fixed, its would been nice to return a gracefull error rather than a crash.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline Beginner

  • Mc. Print
  • *
  • Posts: 33
    • View Profile
I guess the problem are Nvidia processors.

We recognized the same problem on Medion Lifetab and Acer Iconia A210. Both devices also have nvidia chips inside.   

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3606
    • View Profile
    • Space Fractal
Its might not support the texture format used, but might work with different settings. But it's should not crash, better so nothing so we can catch the issue.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
I think it also occurs in Samsung Galaxy S. At least my application does not work and I had to remove it from the market.

All with GLB11

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
Correction to previous post: The problem occurs on a HTC Desire HD with GPU Adreno 205
« Last Edit: 2012-Nov-07 by msx »

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3606
    • View Profile
    • Space Fractal
strange....

CREATESCREEN works pretty nice on extracly that device here (HTC Desire HD with Android 2.3.5), also with v11 Beta. Its mightbeen different models of same phone? Howover Greedy Mouse did run too slow (but its was just a quick offbuffer test, so speed was not about it). Its use Android 2.3.5 as version number here.

I gonna thinks do you using a fixed sprite number or GENSPRITE()? I did that with GENSPRÍTE(). Mightbeen CREATESCREEN have trouble with fixed sprite number?

_____

I also tested with bigger resoulution than the screen (double resolution) and its still works nice (dispite alpha issues due wrong blendmode, not to been debated here). I so property, its a "out of memory" issue?
« Last Edit: 2012-Nov-07 by spacefractal »
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
I do not use gensprite (), but the same application works well on a ZTE Blade.

I do not have HTC Desire HD for more testing.

Offline fivesprites

  • Mr. Polyvector
  • ***
  • Posts: 101
    • View Profile
    • FiveSprites
I've not experienced any problems on the Galaxy S, S2 or even the Galaxy S3. 

Confirmed as also non-working on the Motorola Atrix (Nvidia gpu).  Unconfirmed report of it failing on Samsung Galaxy Tab too, although this uses PowerVR graphics so is a curiosity.



Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10695
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Also in V11? I think this was fixed, already.

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3606
    • View Profile
    • Space Fractal
its works here, but I do not have the NEXUS 7.  Mightbeen its have been fixed after the v11 beta release? So its might need retest here.
« Last Edit: 2012-Nov-14 by spacefractal »
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline fivesprites

  • Mr. Polyvector
  • ***
  • Posts: 101
    • View Profile
    • FiveSprites
No, not fixed. Definitely still an issue with the latest V11 beta I'm afraid.

Offline caffeinekid

  • Mr. Drawsprite
  • **
  • Posts: 51
    • View Profile
    • TCKSOFT
This is the same problem that has been haunting people for a year plus? It would be great if a fix is possible. Then I don't have to learn java to get my game working on these devices. lol

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10695
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
I found it. The depth buffer attachment was wrong, but gave no error. I'll try to create with 24,32,16 bit depth buffer and if all fails, I go without one. For 2D graphics on that off-screen that would still do better than a crash.

Offline caffeinekid

  • Mr. Drawsprite
  • **
  • Posts: 51
    • View Profile
    • TCKSOFT
That's great news. Can you let us know when it's added to the beta so I can try compile my game and get someone with a Nexus to try it for me.  :good: