GLBasic forum

Main forum => Bug Reports => Topic started by: BumbleBee on 2010-Sep-14

Title: Winzige Fehlerliste
Post by: BumbleBee on 2010-Sep-14
Hi
Ich hab hier mal paar kleiner Bugs zusammengestellt, die ich mit WPShadow gefunden habe.  :whistle:  Der erste ist auch der wichtigste für ihn.  =D

Bug 1:
Man kann keine Modelle zu einer Animation zusammen fassen  Es wird nur das erste Modell übernommen und angezeigt

Bug 2:
Types und Funktionen in externen Dateien funktionieren noch immer nicht richtig

Bug 3:
Funktionen die man zusammen klappt, funktionieren nicht, sobald man sie aufruft. Falls man sie nicht benutzt, funktionieren sie   normal  ;)

Bug 4:
 Die Beleuchtung ist irgendwie zu dunkel. Bei Ambientlight wirds plötzlich schwarz wenn man sich in der Welt bewegt ebenso bei Spotlight  -1. Dreht man ein Objekt, ist eine Seite richtig die andere falsch beleuchtet und fast schwarz. 

Bug 5:
Beim Konvertieren von .X Dateien gibts
        (http://img251.imageshack.us/img251/3651/convbug.jpg)

Bug 6:
Ab und zu tauchen "Subs" im System auf, die keine sind
         (http://img251.imageshack.us/img251/9664/bughr.jpg)
       
Bug 7:
Alle neuen Projekte beginnen am 1. Januar 1970. Ist aber eher unbedeutend  :P

So jetzt sind wir beide aber müde vom suchen. N8 :D

Cheers


Title: Re: Winzige Fehlerliste
Post by: backslider on 2010-Sep-14
zu Bug 4: Könnte das an X_CULLMODE liegen?
Title: Re: Winzige Fehlerliste
Post by: WPShadow on 2010-Oct-20
Hi!

Mir ist was bei den Animationen aufgefallen! Kann sein, daß ich es falsch interpretiere, aber falls ich richtig liege, ist der Fehler nur eine Kleinigkeit:

Wenn man bei den Animationen ein neues 3D Modell aus mehreren Animationsschritten erstellt, dann scheinen die Dateigrößen zu passen.

Was jedoch nicht mit übernommen wird ist scheinbar der Index des nächsten Animationsschrittes. Selbst wenn man den Index erhöht, bleibt dennoch immer der 1. Schritt zu sehen.

Vielleicht hilft das ja was!

LG

W.