Anyone having input issues with the latest update(14.497)?

Previous topic - Next topic


you would property have more control over it... but expanding the function is possible and still control it.
Genius.Greedy Mouse - Karma Miwa - Spot Race - CatchOut - PowerUp Elevation - The beagle Jam - Cave Heroes 2023 -

Ian Price

I personally don't need new functions though. The old glb version is perfectly fine for my adventure game. I doubt I'll ever need or use inkey afterwards. Others may, hence why I feel this bug needs to be fixed rather than worked around.
I came. I saw. I played.



Sorry for the slight necro-post   :blink:
This thread quite closely describes an issue that I'm currently having with my code - hope that's OK!

I started coding a little space invaders clone a couple of years back (the IDE was 14.001 I think) , and it went on hold 'cos of work/life etc...

Now I have some spare time, I re-installed GLBasic, updated to the latest verision (14.497) and had a play (without making any changes!)
I'm now getting some weird input lag on all key presses - the input simply isn't responding like it used to. 
I use key() for the control input.

So, based on Ian's experience, I downloaded an archive version of the IDE (12.308), tested the game, and the input is absolutely fine!
I'm on Windown 10 64 bit.

Is anyone aware of or looking at this issue?   Happy to provide more info if required!



Current GLBasic version is 15.089, You can see it at right upper corner of forum webpage, from what I remember this issue was fixed in one of ver. 15 updates.
Don't forget to use GLB_ON_LOOP if you plan to put game on mobiles.
Check my source code editor for GLBasic - link Update: 20.04.2020


Thanks dreamerman!

I actually tried a manual update from inside GLBasic 14.497 (no updates found), and I also spotted that link you mentioned - but it went to a page that described SDK version 14.   So I assumed it wasn't ready yet!

Anyways - I've downloaded the SDK from that link (15.004), and the input lag issue has gone away   =D

Many thanks - issue resolved   :)