Author Topic: "command not inside function or sub"  (Read 2521 times)

Offline monono

  • Mr. Polyvector
  • ***
  • Posts: 213
    • View Profile
    • Sockel Lernmedien
Ich habe das Gefühl, dass diese Fehlermeldung willkürlich und ohne erkennbaren Grund erscheint (obwohl ich zugegeben gar nicht weiss, wann die Fehlermeldung seine Richtigkeit hat). Am Anfang bin ich verzweifelt. Jetzt mache ich ein neues Projekt, lege alle Dateien neu an und kopiere den Code des alten Projects in das Neue. Ein Neustart von Computer, Software oder ähnlichem bringt leider nichts.
Die neue exakte Kopie des alten Projekts funktioniert lustiger Weise.
Es ist aber nicht komplett willkürlich. Bei Projekten mit einer Datei funktioniert alles. Ich versuche jetzt wieder alles in eine Datei zu stopfen wenn es möglich ist., denn bei ca 10 Dateien musste ich den oben beschriebenen Vorgang ca 1 mal pro 1/2 Stunde durchführen.
Hat jemand ähnliche Probleme und eine Lösung? :whip:
LG

Offline Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5111
  • O Rly?
    • View Profile
Re: "command not inside function or sub"
« Reply #1 on: 2010-Jun-27 »
Da gabs probleme mit irgendwas glaub es waren Kommentare...
Hast du die V8 Beta?
Wenn nicht, einfach diese versuchen.
Weil Gernot hat da mal was gefixt...
 

Siehe:
http://www.glbasic.com/forum/index.php?topic=4431.0
I <3 DGArray's :D

PC:
AMD Ryzen 7 1700 @3.9GHz, 16GB HyperX Fury 3000MHz Ram, ASUS ROG GTX 1060 STRIX 6GB, Windows 10 Pro 64Bit, MSi Tomahawk B350 Mainboard

Offline monono

  • Mr. Polyvector
  • ***
  • Posts: 213
    • View Profile
    • Sockel Lernmedien
Re: "command not inside function or sub"
« Reply #2 on: 2010-Jun-28 »
Danke. Habe jetzt ein bisschen die Beta auprobiert und das Problem ist nicht mehr aufgetreten. Wenn es erneut in Erscheinung tritt, melde ich mich noch mal. :nw:

Offline monono

  • Mr. Polyvector
  • ***
  • Posts: 213
    • View Profile
    • Sockel Lernmedien
Re: "command not inside function or sub"
« Reply #3 on: 2010-Jul-02 »
Ich wollte keinen neuen thread aufmachen, weil es eigendlich das gleiche Thema ist ("Ich und der Editor").
Warum lässt er mich nicht die Datei, die ich als Hauptdatei will, zur Hauptdatei machen? Selbst bei einem neuen Projekt, das aus 2 leeren Dateien besteht, macht er häufig Probleme. Deswegen mein Frage: Wann und unter welchen Bedingungen wird die Option im Kontextmenü ausgegraut? Wenn sie einem angezeigt wird, warum reagiert er häufig nicht darauf? Bediene ich falsch oder unerwünscht oder ist das ein Bug den auch andere haben? Habe die Probleme sowohl in Windows 7 als auch im aufm Vista-Notebook. Beides IDE Version: 8.006.
Danke im Vorraus!

Nachtrag: "Ich und der Editor Teil 3"
Habe gerade wieder etwas herausgefunden. Manchmal habe ich mich gewundert, warum eine Variable die in der zweiten Datei unter Quellen defeniert wird vom Debugger in der ersten gesucht wird. Da man die Reihenfolge der Quellenliste nicht ändern kann, dachte ich mir ganz naiv das ist egal, das regelt irgendein Precompiler. Da viel es mir wie Schuppen von den Augen: Das ist ja wie INCLUDE in Blitzbasic. Nur ist INCLUDE flexibler als der Projektmanager - zumindest was die Reihenfolge angeht.

ps: Nicht das jemand denkt, ich würde nur stänkern. Ich dokumentiere nur die Fallstricke in die ich renne. Die Sprache GLB fühlt sich ja schon fast an wie zuhause, nur mit dem Editor kämpfe ich immer wieder umso komplexer mein Projekt wird.
« Last Edit: 2010-Jul-02 by monono »