Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Hatonastick

Pages: 1 2 [3] 4 5 ... 30
31
Gernot the test he gives in that article is exactly what mine fails.  My only problem is I don't have that version of Windows 7 (mine is Home Premium) so I cant access the group policies that he uses as a fix (if I'm understanding it properly).

Interesting.  Heres an article on the Microsoft website:
http://support.microsoft.com/kb/2686260

This is my problem exactly.  Unfortunately the only "solution" they give is what I'm already doing and which is quite frankly annoying. ie. rebooting.

I'm going to add GLB directories to the anti virus checker as exceptions too as I'm using the one Gernot mentions in the other forum post.  I may actually be experiencing two very similar issues rather than one issue and one cause.  I'm definitely experiencing what is listed in that MS article I've linked to, but I don't think that is quite the same as what is happening when I compile for GLB then have to wait a while before I can compile again (so it will allow the overwrite of the previous program).  If that was a handle leak I'd have thought it wouldn't correct itself.

Edit: Bah... Adding my work directory where I compile stuff to the Windows Defender exceptions didn't help.  I assume you don't have to add every single directory under a given directory?  Surely it would stop at the top one if you give it.

Edit: Solved!  Thanks to you all for your help, and especially Kitty for setting me on the right track.  I have a vague memory from many months ago when I got it into my head to go to town on my PC and cut down overhead due to some issues I was having with a certain computer game.  Anyway it seems that during that time I must have disabled the Application Experience service completely (as in it wasn't showing up at all in the Services admin program).  I just found some instructions on how to re-enable it and tested some file actions out (including compiling and recompiling a GLB program) and it all worked perfectly.  For future reference what I did to "fix" the issue was open a Windows command prompt and type:

Code: (glbasic) [Select]
sc config "AeLookupSvc" start= delayed-auto
sc start "AeLookupSvc"

And now it seems to all work fine.

32
I suspect rather strongly that it's an issue with my HD as it has never really worked as well as it should.  I just found out theres more than a few firmware upgrades for it that I'm missing all labeled "Important".  I've just installed the latest.  Now I'm downloading the Seagate (it's a Barracuda) Seatools and attempting to install that to find out if it's functioning properly -- and that's an epic tale in itself.  For some reason their .NET is stuck in the dark ages so I'm being forced to download 3.5 (231Mb and which contains the necessary 2.0) on the off chance (according to a forum) it will allow me to install the darn thing. :)

Even once (assuming I win) get it working and there are no errors reported, there are still other things I can try.  I suspect I've possibly got a wrong setting in the BIOS.

I'm hoping to replace it with a new HD soon anyway.  Not that it's old.

Edit:  Heck could even be BIOS related.  Can tell it's been ages since I updated any of the drivers.  The BIOS version on my motherboard is A01, and the manufacturer is up to revision A06 according to the support section for this computer.  So who knows what that will add.  Once I actually manage to download it that is.

Edit:  Well... Windows 7 now knows what hard drive I have, but it's made bugger all difference to speed or the "file in use" issue.  I'm at a total loss.  Only other option is to do a complete wipe and reinstall but I don't have the stamina or the download speed to be bothered.  :(

33
Off Topic / Re: Raspberry Pi
« on: 2012-Jul-05 »
Marmor: The GLB IDE/compiler runs on RPi, or programs compiled for RPi (via Canoo) run on RPi?  I'm having trouble working out whats going on in your video, sorry.  :blink:

Edit:  Looking at that video yet again I'm guessing it's the latter.  I really want to get a RPi now.  :good:

34
This is driving me crazy.  I can't find anything via Google that seems to help either.  I've turned off a bunch of things that some people have suggested but it still hasn't solved the issue.

Basically when a program quits, it doesn't release straight away.  Seems to take time.  So if I compile and then run a program for the first time it all works fine.  However if I click on Start or Build in the editor it fails when it comes to replacing the old binary because windows hasn't released it yet -- and windows seems to take a minute each time to do so.

I never used to have this issue, but some update or other along the line it started.  It doesn't end (or start) with GLB though.  I've had many occasions where I've run a program, then gone to move or delete files in its directory and haven't been able to.  Every time I uninstall a program that has been running recently I have to reboot (even on a few occasions to Safe mode) to get rid of the darn thing.  I'm hoping someone who is more up to date on how Windows works these days than I am, can suggest something because I'm all out of ideas.  I'd rather not do a total reinstall of windows because I've got too many large programs I'd have to download/install again, but I'm starting to think that might be my only option -- assuming it wasn't an update that started this mess that is...

35
Code Snippets / Re: Isometric look code
« on: 2012-Jul-05 »
For sure!  It's absolutely brilliant!

36
Code Snippets / Re: Isometric look code
« on: 2012-Jul-04 »
The android version runs pretty well on my Toshiba tablet.  Hovers around 40fps which isn't too bad considering this is only a mid-range tablet.  Looks pretty darn good too.  Now we just need someone to use this in a game. :)

I have to ask though.  Am I the only one (on my PC as well as Android) who gets a strange almost shrink/expand effect when you spin the scene around?  It also doesn't quite look right from some angles.  Would this have anything to do with the fact that both screens in use are widescreen, or is this due to something akin to the fish-eye effect?

37
Awesome, thanks!  BTW I noticed you mentioned Voxels in that topic.  Voxels is what I was thinking of too for some reason.  I'd love to write a voxel engine one day.

Edit:  You've done some prodding of my mind today with your posts.  I'm also currently looking up/trying to research Ambient Occular shaders because of something you said in another thread.  For some procedurally generated non-textured 3D for a game I'm working on.

38
Wow.. I'm impressed.  That runs extremely smoothly and looks good as well!  I hope you are going to expand that a bit more. :)

Without giving us your source, I'd like to see a tutorial that explains how you went about this.  Haven't done my own 3D calculations since my Atari ST days.  Can't even remember how to go about it anymore...

39
Inline / 3rd party / Re: LUA 5.2 wrapper
« on: 2012-Jul-04 »
I agree.  I was looking at updating my own script language for my latest project but after having had a brief look at this I think I might go with LUA again.  Just depends on whether we can get GLB and LUA to interface properly.  What I would really want is for it to work under Windows and Android -- but not sure it could be done with Android (Hmm? http://www.badlogicgames.com/wordpress/?p=943).

Still, in my case at least, it's a lot of work for something that wont be used anywhere near its potential.  So maybe I'd be better off converting my old little script/macro language from C to GLB instead...

40
Off Topic / Re: Android Console
« on: 2012-Jul-04 »
If that ever goes to production, I'll be grabbing one.  :good:

41
Inline / 3rd party / Re: LUA 5.2 wrapper
« on: 2012-Jul-04 »
There's a long list of commercial games that use LUA for scripting.  Even a few on consoles.  I once considered using it for an old, old project of my own.

42
Quote
Mate I feel like that every morning when I get out of bed.   :S
I learn a bit more about the world each day that passes, but I remember less...
Yeah I think that's it...  Not sure, I can't remember.   =D

43
Hmm I'll only be interested if it has a mini price to match.  I currently cant justify what iProducts cost which is why I still have an aging iPod Touch II and nothing else in their range.  :blink:

44
I would have been too, I just forgot about the fact that I'm off in the long lost land of Oz while most other developers on here are in Europe -- and 3am is just a bit hard for me to handle these days. :)

45
Hmm this will come in handy for my game.  Thanks!

Pages: 1 2 [3] 4 5 ... 30