Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Uncle

Pages: [1] 2 3 4
1
GLBasic - en / Re: Autoupdater failing?
« on: 2010-Sep-18 »
Thanks.  I will give that a go.

2
GLBasic - en / Autoupdater failing?
« on: 2010-Sep-18 »
Hi,

I've tried to upgrade to v8, but when using the autoupdater it fails i.e. crashes I just get a runtime error when it tries to install.  Is there a way to fix this?

Cheers,


Unc

3
Looks like things will be sorted with v8 then :)  Thanks for the welcomes back.  Aye I've real life has taken me away from programming for a little while, but now I'm back at it and things are going well :)

4
Hello,

Incredibuild seems to a bit flakey for me.  It doesn't always seem to select the correct files to skip even after I have made big changes in the code.  It can be really frustrating because sometime you fix a bug but still don't see the results because the file was skipped during compilation. 

Is it possible to...

1) Fix it so it works 100% of the time

or (which should be easier)

2) have a tick box in the IDE to force a full recompile.


Cheers,


Unc

5
Yeah I noticed a slow down, but wasn't sure if it was version related.  Perhaps you could measure the times it takes to process one loop of your program, and then run it in both version of GLB.  That should confirm it one way or the other.  Is it possible to still download older version of GLB?

6
GLBasic - en / Re: another iPhone problem
« on: 2009-Oct-12 »
Glad you got to the bottom of that.  At least we know what to look out for in the future :)

7
GLBasic - en / Re: another iPhone problem
« on: 2009-Oct-12 »
Ok, I got the project and exactly the same happens for me.  I tried deleting and recreating but still the same problem.  When I look at the contents of the Xcode Project file, I only see the 2 files you mentioned.  I think we need Gernot or Truidcare to look deeper into this one.

8
GLBasic - en / Re: another iPhone problem
« on: 2009-Oct-12 »
Hi Gary,

I will send you a PM, and we can try and work through this today :)

Cheers,


Unc

9
GLBasic - en / Re: another iPhone problem
« on: 2009-Oct-12 »
Right Im about to hit the sack (early start in the morning).  All I can suggest is right clicking on the project file and select show package contents....  Then you will see several files contained within the package.  These can be opened in a text editor.  Perhaps you can compare this contents against the contents of a project file from the demos.  Hopefully then it will be easier to see what is different and what could be causing the problem?  Its an odd one for sure.

10
GLBasic - en / Re: another iPhone problem
« on: 2009-Oct-12 »
All the commands you mention from what I know are perfectly valid, and compile ok on the iphone.  If you like I can try and compile your project on my mac to see what I get.  As a matter of interest what is your set up i.e. are you creating your code on separate pc and then doing a file copy over, or are you using another method like using a virtual machine on your mac.  Im using parallels, and I find that sometimes the files get corrupted when reading them into the XCode, especially if I leave XCode open when Im editing and compiling using GLB. 

Also what size is your Xcode Project file?  I think its an XML file isn't it, so it might also be interesting to open it up in and editor to see what is written in it?

EDIT : You can't read the project file in an editor, but on the make you can right click and show its package contents.  Then you view the individual text files contained within it.

11
GLBasic - en / Re: another iPhone problem
« on: 2009-Oct-11 »
Very odd.  I don't think it has anything to do with the GLB code you wrote, more like the project file is unreadable to Xcode.  Can you actually load the project into XCode?  Perhaps you can post a screen shot?

12
GLBasic - en / Re: another iPhone problem
« on: 2009-Oct-11 »
Sounds like your project file has been corrupted somewhere along the lines.

I would suggest closing XCode.  Deleting the project file, and anything in the XCode -> GLBasic -> Lib folder to be sure.  Then recompile the project again in GLB.  This will make brand new files for everything except your media. 

Let me know if this works.


Cheers,


Unc

13
GLBasic - en / Re: iPhone questions
« on: 2009-Oct-04 »
While you can do all that just to test your game, it's much easier to just press F5 to run the game on your PC for testing, then when you are happy with it you do all the other steps to get it onto your iPhone for serious testing and then the app store :-)

Agree with what Moru says here for testing game logic its fine to run the game on the PC, however for performance testing compiling to the iphone is the way to go.  Also few features which work on the PC don't work on the iphone (no major show stoppers), and some have work arounds but its best to be aware these by double checking and compiling to the iphone every now and then. 

14
GLBasic - en / Re: BlendScreen - iPhone
« on: 2009-Oct-03 »
Polyvector is the way to go.  We use it in exactly the way you mention.  You will have to write your own collision stuff though but thats not too hard to do.

15
I've been using Parallels now for a while and its opengl is acceptable.  Its not as fast a real machine but certainly acceptable for dev and debugging. 

Pages: [1] 2 3 4