debugger not starting app

Previous topic - Next topic


Has anyone else had trouble with the degugger? If I enable building with the debugger and then do a compile/run the project compiles, links and then a message appears that the debug session has started but there is no application running. If I turn off the debugger and do a compile/run the application runs fine. I have tried this with various of the samples and always seems to do the same thing. Any ideas??
using the latest version 7.242, Win XP.


This always happens if you don't close the previous debugging session first. You need to press the stop button or at least run the program twice, first time it just closes the previous session, then you can start it normally.


I don't think this is what is happening. The program is not starting so the stop button does not do anything. If I run with debugging turned on the output windows just indicates start debug session but nothing happens?? I can repeat this a few times and still the same. Maybe I need to reinstall............


I've had it fairly often - for some reason a previously run program doesn't exit properly (or doesn't inform the debugger that it has done).

It happens more in Windows 7 than XP

You cant terminate the program in the Task Manager because it wont end - the only way to get around it is to close GLBasic, re-load it and then the project.

Kitty Hello

I've finally got this working, too.

If you're interested, read: and find the 2 spots where it says "CloseHandle".