Author Topic: Android compiling not working  (Read 11598 times)

Offline quangdx

  • Mr. Polyvector
  • ***
  • Posts: 233
  • work hard / play hard
    • View Profile
    • Asobi tech
Re: Android compiling not working
« Reply #15 on: 2012-May-27 »
when it's compiling for android and I type SUBST into command prompt,
I get nothing back.

So I set the SUBST file manually.
which still didn't work,
but then I finally worked out it is because I'm running under parallels, with my GLBasic projects in dropbox on the Mac side,
so they show up in windows as a network drive, and this was confusing it.
Moving the GLBasic project over to the C: drive and it now appears to be working.
Asobi tech - the science of play.
Spare time indiegame developer.

MrTAToad

  • Guest
Re: Android compiling not working
« Reply #16 on: 2012-May-27 »
Ah, so it was some weird configuration :)  Glad its working now!

Offline quangdx

  • Mr. Polyvector
  • ***
  • Posts: 233
  • work hard / play hard
    • View Profile
    • Asobi tech
Re: Android compiling not working
« Reply #17 on: 2012-May-27 »
Ah, so it was some weird configuration :)  Glad its working now!
Yeah, looks like Android SDK is very picky,
doesn't like names that start with numbers, or one with symbols or spaces in them.
And it really doesn't like networked drives.

Hopefully having it it iOS and Android will work in my favour for this Cadbury HackJam event.
Asobi tech - the science of play.
Spare time indiegame developer.

MrTAToad

  • Guest
Re: Android compiling not working
« Reply #18 on: 2012-May-27 »
Quote
Yeah, looks like Android SDK is very picky,
It is very picky!

Offline ckrum

  • Mc. Print
  • *
  • Posts: 15
    • View Profile
Re: Android compiling not working
« Reply #19 on: 2013-Sep-29 »
I have the same problem it seems.
I bought the book.. followed all the instructions..
still getting the same results..

_______________________________________
*** Configuration: ANDROID ***
precompiling:
GPC - GLBasic Precompiler V.9.829 SN:3e3491bf - 3D, NET
Wordcount:53 commands
compile+link:
running Android build-script...
BUILD STAGE 1: Compile and pack RELEASE
Exception in thread "main" java.lang.RuntimeException: Failed to create Q:\Compiler\platform\android\android-sdk-windows\add-ons.
   at com.android.sdklib.SdkManager.loadAddOns(SdkManager.java:665)
   at com.android.sdklib.SdkManager.createManager(SdkManager.java:144)
   at com.android.sdkmanager.Main.parseSdk(Main.java:221)
   at com.android.sdkmanager.Main.run(Main.java:118)
   at com.android.sdkmanager.Main.main(Main.java:102)
Buildfile: build.xml does not exist!
Build failed
.
BUILD STAGE 2: Build DEBUG and install on device
Buildfile: build.xml does not exist!
Build failed
finished Android build-script.
Android=C:\Users\krumholt\Documents\GLBasic\textlotto1\distribute\Android
success
_______________________________________
*** Finished ***
Elapsed: 3.9 sec. Time: 11:58
Build: 1 succeeded.

MrTAToad

  • Guest
Re: Android compiling not working
« Reply #20 on: 2013-Sep-30 »
Quite simple to fix : create the "add-on" directory in your "Compiler\platform\android\android-sdk-windows" directory

Offline ckrum

  • Mc. Print
  • *
  • Posts: 15
    • View Profile
Re: Android compiling not working
« Reply #21 on: 2013-Sep-30 »
I tried creating it under the SDK folder on drive C:\sdk\Compiler\platform\android\android-sdk-windows\add-ons

then I tried locating it in the root..

C:\Compiler\platform\android\android-sdk-windows\add-ons

I created drive letter Q and it just changed the error saying it cant created R:\....etc

by default add-ons was already in the path... C:\sdk\android-sdk\add-ons

The JDK SDK , AVD etc. works with other software .. this should be simple.. probably is .. but never for me. LOL
I will keep trying ..

Offline kanonet

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1137
    • View Profile
    • My GLBasic code archiv
Re: Android compiling not working
« Reply #22 on: 2013-Sep-30 »
I think he means the GLBasic\Compiler\platform\android\android-sdk-windows folder, create there add-ons folder there and it should work.
BTW you dont need Android SDK, GLBasic+JDK is enough.
Lenovo Thinkpad T430u: Intel i5-3317U, 8GB DDR3, NVidia GeForce 620M, Micron RealSSD C400 @Win7 x64

MrTAToad

  • Guest
Re: Android compiling not working
« Reply #23 on: 2013-Sep-30 »
Yes, it's in the GLBasic directory.

The latest/current beta I believe fixes this...  I had thought the latest release version did too as well...

Offline ckrum

  • Mc. Print
  • *
  • Posts: 15
    • View Profile
Re: Android compiling not working
« Reply #24 on: 2013-Sep-30 »
OMG .. finally I got it..
so the fix is ..
In the GLBASIC subfolder insure the following path exists..
C:\Program Files\GLBasic\Compiler\platform\android\android-sdk-windows\add-ons

FREAKIN AWESOME.. Now HahaHA.. 'EVIL LAUGH'

Thank you very much.