Author Topic: 123 basic - HTML5 for GLBasic  (Read 118138 times)

MrTAToad

  • Guest
Re: 123 basic - HTML5 for GLBasic
« Reply #120 on: 2013-Nov-21 »
The only extension I have in Firefox is AdBlockPlus

Offline metzzo

  • Mr. Polyvector
  • ***
  • Posts: 140
  • Coolo ist cool!
    • View Profile
    • programming with design
Re: 123 basic - HTML5 for GLBasic
« Reply #121 on: 2013-Nov-21 »
Yes, it was a bug and it has been fixed now, at least it works here.
« Last Edit: 2013-Nov-21 by coolo »
That's no Bug, that's my project!

http://programming-with-design.at/

Online erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4448
    • View Profile
    • FUED
Re: 123 basic - HTML5 for GLBasic
« Reply #122 on: 2013-Nov-21 »
Finally gave it a go!

Runs fine on Chrome and Explorer on desktop win7.
Tried one other program here and assets don´t seem to upload, program complains about load failure upon starting but works.

Really great work there! I particularly like the IDE visuals.
It works diamond perfect together with a Note II on android and chrome.

The way the IDE accommodates around is just spot on, and so when you type. I can finally put auto-complete on android on, so I can code on the go zx spectrum way. :P
It feels like a portable GLB. Super potential this has!

MrTAToad

  • Guest
Re: 123 basic - HTML5 for GLBasic
« Reply #123 on: 2013-Nov-21 »
So what did you say wasn't working/isn't available ?

I think it was :

  • INLINE stuff
  • POLYVECTORS
  • File I/O
  • 3D

Offline metzzo

  • Mr. Polyvector
  • ***
  • Posts: 140
  • Coolo ist cool!
    • View Profile
    • programming with design
Re: 123 basic - HTML5 for GLBasic
« Reply #124 on: 2013-Nov-21 »
INLINE does not work.
POLYVECTOR partly works (tinting is limited though)
File I/O is 100% supported
3D does not work.
That's no Bug, that's my project!

http://programming-with-design.at/

MrTAToad

  • Guest
Re: 123 basic - HTML5 for GLBasic
« Reply #125 on: 2013-Nov-21 »
I'm finding this code :

Code: (glbasic) [Select]
// --------------------------------- //
// Project: Test1
// Start: Tuesday, April 10, 2012
// IDE Version: 11.001

TYPE T3DStar
        xPos
        yPos
        zPos
        zVel

        FUNCTION Initialise%:
                self.xPos=RND(1000)-500.0
                self.yPos=RND(1000)-500.0
                self.zPos=RND(900)+100
                self.zVel=0.5+RND(5)
        ENDFUNCTION

ENDTYPE

TYPE T3DStarProcess
        screenWidth%;screenHeight%

        stars[] AS T3DStar

        FUNCTION Initialise%:screenWidth%,screenHeight%
        LOCAL s AS T3DStar

                self.screenWidth%=screenWidth%
                self.screenHeight%=screenHeight%

                DIM self.stars[500]

                self.Reset()

                RETURN TRUE
        ENDFUNCTION

        FUNCTION Finish%:
                DIM self.stars[0]
        ENDFUNCTION

        FUNCTION Display%:
       
        ENDFUNCTION

        FUNCTION Process%:speed
       
        ENDFUNCTION

        FUNCTION Reset%:
        ENDFUNCTION
ENDTYPE

GLOBAL stars AS T3DStarProcess

stars.Initialise(640,320)

SUB GLB_ON_LOOP:
    stars.Process(1.0)
    SHOWSCREEN
ENDSUB

Is hanging the compiler

Offline metzzo

  • Mr. Polyvector
  • ***
  • Posts: 140
  • Coolo ist cool!
    • View Profile
    • programming with design
Re: 123 basic - HTML5 for GLBasic
« Reply #126 on: 2013-Nov-21 »
weird, does not happen to me. What browser are you using?
That's no Bug, that's my project!

http://programming-with-design.at/

Online erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4448
    • View Profile
    • FUED
Re: 123 basic - HTML5 for GLBasic
« Reply #127 on: 2013-Nov-21 »
...
File I/O is 100% supported
...

Strange, I can carry stuff to the IDE, it shows there. I can´t delete them on the X.
But they don´t seem to load in code and I get a ´can´t load image 2´ error.

I´m trying to run this code here:
http://www.glbasic.com/forum/index.php?topic=8822.0

Offline kanonet

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1137
    • View Profile
    • My GLBasic code archiv
Re: 123 basic - HTML5 for GLBasic
« Reply #128 on: 2013-Nov-21 »
Yes, it was a bug and it has been fixed now, at least it works here.
It works now, thanks everyone that helped.

BTW NET_ and SOCK_ commands are not fully implemented yet, right?
Lenovo Thinkpad T430u: Intel i5-3317U, 8GB DDR3, NVidia GeForce 620M, Micron RealSSD C400 @Win7 x64

MrTAToad

  • Guest
Re: 123 basic - HTML5 for GLBasic
« Reply #129 on: 2013-Nov-21 »
weird, does not happen to me. What browser are you using?
Firefox 25...

Offline metzzo

  • Mr. Polyvector
  • ***
  • Posts: 140
  • Coolo ist cool!
    • View Profile
    • programming with design
Re: 123 basic - HTML5 for GLBasic
« Reply #130 on: 2013-Nov-21 »
MrTAToad: Strange, Everything works OK here, have you tried refreshing?
kanonet: NET_ and SOCK_ is currently unimplemented, yes.
erico: I'm trying to fix it, seems to be either a problem with DRAWANIM or GRABSPRITE. The demo does load the images when compiled with the macro, but still is buggy when executed - I'm on it.
« Last Edit: 2013-Nov-21 by coolo »
That's no Bug, that's my project!

http://programming-with-design.at/

Offline metzzo

  • Mr. Polyvector
  • ***
  • Posts: 140
  • Coolo ist cool!
    • View Profile
    • programming with design
Re: 123 basic - HTML5 for GLBasic
« Reply #131 on: 2013-Nov-21 »
Hey!

The problem is now fixed - dragging multiple file at once into the field was buggy.

Secondly, remove the SETCURRENTDIR, because all the assets are put into the / directory instead of /Media.

That's no Bug, that's my project!

http://programming-with-design.at/

Online erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4448
    • View Profile
    • FUED
Re: 123 basic - HTML5 for GLBasic
« Reply #132 on: 2013-Nov-21 »
Nice, will give it a go later today! Thanks Coolo!

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3375
  • Integrated Brain
    • View Profile
Re: 123 basic - HTML5 for GLBasic
« Reply #133 on: 2013-Nov-22 »
Hi Coolo I test the "AS" when you do a TYPE and now works fine.
A little problem now  .jpg don't works..
If in the folder you have a .jpg then compiler hangs saying only "this can take a bit of time", but if the same image convert to .png, it's practically auomatic... I think you have something buggy when compile the .jpg.

Really this it's very very faster...  :happy: :nw:

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3375
  • Integrated Brain
    • View Profile
Re: 123 basic - HTML5 for GLBasic
« Reply #134 on: 2013-Nov-22 »
HI Coolo I think I found another little problem Static variables makes the broser appears in Blanck...