Recent posts

Code Snippets / Re: A* path finder (with diago...
Last post by SnooPI - Today at 2:37
Awesome Dreamerman!  :good:
A good idea would be to use Warcraft 2 Sprites for your next demo  ;)
I really believe in the potential of RTS games in a retro 2D style.
GLBasic - de / IDE, gibts da noch mehr?
Last post by nabz32 - 2024-Jun-20
Hi, ich habe erst letztens die nützliche Tastenkombination alt + Pfeiltaste links gefunden, mit der man einfach zurückgehen kann, leider hat alt + Pfeiltaste rechts zum Vorwärtsgehen dann nicht funktioniert.

Ich lese hier auch von strg + leer, was bei mir anscheinend überhaupt nichts tut, bin ich zu dumm, oder gibt es irgendwo ein verstecktes Readme, in welcher alle Tastenkombinationen des GLBasic Editors aufgelistet sind?
Bug Reports / Re: Jpg doesn't work
Last post by Qedo - 2024-Jun-19
Perfect dreamerman as you indicated I replaced the files
and everything works fine  :enc:
thank you so much

PS it should be the case that Gernot or whoever corrected the installation of GlBasic from Steam
Bug Reports / Re: Jpg doesn't work
Last post by dreamerman - 2024-Jun-19
All included jpg files are loaded and displayed correctly. As you have fresh install of Windows can this be some OS realated thing? Like Defender rules, or SmartScreen protection, did you tried disabling those filters and running GLB Editor as admin (right mouse click, run as admin)? The last thing that comes to my mind is some OpenGL dll/drivers mismatch/issue but don't know how/which libs are used, some API debug tool would be usefully here.

Edit: Didn't specify that but, freshly compiled project on my PC loads jpgs properly, but that included *exe does not, and also it has different file size than exe compiled on my pc.. hm..

Edit 2: After reinstalling GLBasic on Steam again with proper deleting it's directory I can confirm that it contains bug that doesn't allow to load JPG files. I've use WinMerge to seek for differences in files between this version and known working version, and the only differences are in 'libGLBasicWin32.a' and 'libGLBasicWin64.a' files. Current Steam version does produce smaller *exe files like ~100kb, don't have current GLB source so can't check what's causing the issue.
For a temporary fix, use attached libs from working version, I think that they should be same version as those Steam ones, yet those are precompiled by me and contain GETNUMJOYSTICKS fix.
Bug Reports / Re: Jpg doesn't work
Last post by Qedo - 2024-Jun-19
Thanks for your help
I attach the complete project

I sent you the project but there is a writing error
DRAWSPRITE 10,0,0 must be DRAWSPRITE 0,0,0

however this is not the problem I have, I still don't see the jpgs
Bug Reports / Re: Jpg doesn't work
Last post by dreamerman - 2024-Jun-19
hm.. on my PC loading jpg's on every GLB/editor version works properly, tried different projects and jpg files, redownloaded GLBasic from Steam again and can't replicate the issue.
Can you attach any complete even basic project that can't load jpgs (maybe even with final *exe file to compare)? All jpg's are causing the problem? Did you tried resaving them with some editor like Paint.Net / GIMP?
Bug Reports / Re: Jpg doesn't work
Last post by Qedo - 2024-Jun-18
it's true dreamerman if I launch
EditorE.exe           ----> GLBasic IDE, Version: 16.927
GLBasicEditorE.exe    ----> GLBasic IDE, Version: 16.793

however in both cases jpg is not recognized
Yes I will add a time log for the functions, I think I will make it only write if a certain key is held down, this way I won´t get gigantic logs. I think it will be nice to have in the future.
In short for debbuging purpose, there are some general OpenGL debug/profiling tools (the older ones) that work with GLBasic and catch all called functions maybe even with some time statistic info, but I don't remember which ones at the moment. Narrowing issue with hand coded time checking functions in some crucial part can be usefull or disable some parts of rendering routine to check where can be the issue.
Bug Reports / Re: Jpg doesn't work
Last post by dreamerman - 2024-Jun-18
hm.. is there some mismatch in Steam version of code editors? Proper latest version should be 16.927, but when you run it from Steam it launches ver 16.793 - is that only spelling error or wrong exe included.
Try launching standalone editor - Steam - show local files - run EditorE.exe (it should show proper version number), check if loading jpg is still an issue.