Author Topic: problem with SETTRANSPARENCY  (Read 1947 times)

Offline Kyo

  • Dr. Type
  • ****
  • Posts: 350
    • View Profile
problem with SETTRANSPARENCY
« on: 2010-May-22 »
if I use SETTRANSPARENCY, inside the main loop it works fine

Work!
Code: (glbasic) [Select]
WHILE TRUE
updateMice()
SETTRANSPARENCY RGB(0,255,0)

game()

ShowFPS()
SHOWSCREEN
WEND

if I use SETTRANSPARENCY, inside the function don't works

Code: (glbasic) [Select]
FUNCTION updatesprite: spr

SETTRANSPARENCY RGB(0,255,0)
         STRETCHSPRITE img, x  , y  ,sxx  ,syy

ENDFUNCTION

Why?

Offline Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5116
  • O Rly?
    • View Profile
Re: problem with SETTRANSPARENCY
« Reply #1 on: 2010-May-22 »
Use SETTRANSPARENCY befor you load a sprite!
I <3 DGArray's :D

PC:
AMD Ryzen 7 3800X 16@4.5GHz, 16GB Corsair Vengeance LPX DDR4-3200 RAM, ASUS Dual GeForce RTX™ 3060 OC Edition 12GB GDDR6, Windows 11 Pro 64Bit, MSi Tomahawk B350 Mainboard

Offline Kyo

  • Dr. Type
  • ****
  • Posts: 350
    • View Profile
Re: problem with SETTRANSPARENCY
« Reply #2 on: 2010-May-22 »
Use SETTRANSPARENCY befor you load a sprite!

Work! Thanks!  :booze:

Offline Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5116
  • O Rly?
    • View Profile
Re: problem with SETTRANSPARENCY
« Reply #3 on: 2010-May-22 »
No problem :D
I <3 DGArray's :D

PC:
AMD Ryzen 7 3800X 16@4.5GHz, 16GB Corsair Vengeance LPX DDR4-3200 RAM, ASUS Dual GeForce RTX™ 3060 OC Edition 12GB GDDR6, Windows 11 Pro 64Bit, MSi Tomahawk B350 Mainboard