Author Topic: Question about the html5 compiler on steam  (Read 871 times)

Offline svenart

  • Mc. Print
  • *
  • Posts: 35
    • View Profile
Hey everyone,

I´m considering to buy the html5 compiler on steam in order to make my games able to be played in a browser.

https://store.steampowered.com/app/1533030/GLBasic_HTML5_Compiler/

However, in the description is written that it is only working with the glbasic version ON Steam.

 I don´t have the Steam version of Gl Basic. I bought GlBasic years ago before it was available on steam.

So my question is, does the html5 compiler works also with old glbasic versions or only with Steam Versions?





Offline dreamerman

  • Global Moderator
  • Dr. Type
  • *******
  • Posts: 443
    • View Profile
    • my personal website
Re: Question about the html5 compiler on steam
« Reply #1 on: 2022-Feb-21 »
Steam version has major compiler (GCC) differences from older GLB versions so I doubt that html5 Steam target would work on GLB v15, yet there is older html5 target somewhere on this site, or at least it was, as now I can't find it (other thing is that I had no luck with it with bigger projects), but if you would encounter issues/bugs with it they would not be resolved as Steam version is only focus. Due that and as generally older versions have some bugs, best thing you could do, would be to ask Gernot for Steam version key code (if he still can generate those for older users).
Take note that I didn't use html5 target from years, mainly due to extensive use of PolyVectors and OpenGL/C++ inline, so can't talk to much about it current state.
Check my source code editor for GLBasic - link Update: 20.04.2020