Yet more PEBCAK related android installation problems!

Previous topic - Next topic


I have messed up my install of GLB

here's what i did.

I couldn't get the SDK manager to launch so started fiddling with paths etc and broke android compilation.

I have deinstalled everything cleaned reg ,ran cc cleaner.

reinstalled  JAVA and GLB and re associated paths(i am sure they are right)

when i  attempt to compile for android

i get a log

*** Configuration: ANDROID ***
GPC - GLBasic Precompiler V.10.037 SN:f6c7483b - 3D, NET
Wordcount:3 commands
*** FATAL ERROR - Please post this output in the forum
*** Finished ***
Elapsed: 5.6 sec. Time: 14:56
Build: 0 succeeded.
*** 1 FAILED ***

and that's it,no hints at all.
what do you reckon SF?


Turns out i needed to encompass the path in quotes.

GLB is working but still cant start the  bloody SDK Manager.(looks for emoticon with gun in mouth)

I get this when running android.bat


Next day.Compile for android.

same errorless errorlog as yesterday!

as far as i know i havn't changed anything.
:'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :rant:


something might been wrong in manifest.xml. tried delete the distrubute folder?
Genius.Greedy Mouse - Karma Miwa - Spot Race - CatchOut - PowerUp Elevation - The beagle Jam - Cave Heroes 2023 -


Yeah i have tried that.
I have tried to compile some HTML5 webGL and it's complaining that JAVA_HOME isn't  set and it can't locate Java,but it definitely pointing at the SDK.

It takes me to the SDK folder when i use %JAVA_HOME%

BUT it does still produce the code.


Hmmm a reboot seems to have sorted that HTML5 error,weird

still cant compile android tho...

After deleting the distribute folder i notice android isn't creating it but HTML is


I just randomly tried compiling android and... it worked!

I have no idea why,can't see any different path etc anywhere.


Yep, android compilation is, sometimes, hard to keep track.
Glad it is back working for you, I will have to reinstall it here soon and should run through similar problems.


I get this when i run android.bat

Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widge
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Display
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 4 more