Recent posts

#21
Bug Reports / Re: Jpg doesn't work
Last post by dreamerman - 2024-Jun-19
All included jpg files are loaded and displayed correctly. As you have fresh install of Windows can this be some OS realated thing? Like Defender rules, or SmartScreen protection, did you tried disabling those filters and running GLB Editor as admin (right mouse click, run as admin)? The last thing that comes to my mind is some OpenGL dll/drivers mismatch/issue but don't know how/which libs are used, some API debug tool would be usefully here.

Edit: Didn't specify that but, freshly compiled project on my PC loads jpgs properly, but that included *exe does not, and also it has different file size than exe compiled on my pc.. hm..

Edit 2: After reinstalling GLBasic on Steam again with proper deleting it's directory I can confirm that it contains bug that doesn't allow to load JPG files. I've use WinMerge to seek for differences in files between this version and known working version, and the only differences are in 'libGLBasicWin32.a' and 'libGLBasicWin64.a' files. Current Steam version does produce smaller *exe files like ~100kb, don't have current GLB source so can't check what's causing the issue.
For a temporary fix, use attached libs from working version, I think that they should be same version as those Steam ones, yet those are precompiled by me and contain GETNUMJOYSTICKS fix.
#22
Bug Reports / Re: Jpg doesn't work
Last post by Qedo - 2024-Jun-19
dreamerman
Thanks for your help
I attach the complete project

edit:
I sent you the project but there is a writing error
DRAWSPRITE 10,0,0 must be DRAWSPRITE 0,0,0

however this is not the problem I have, I still don't see the jpgs
#23
Bug Reports / Re: Jpg doesn't work
Last post by dreamerman - 2024-Jun-19
hm.. on my PC loading jpg's on every GLB/editor version works properly, tried different projects and jpg files, redownloaded GLBasic from Steam again and can't replicate the issue.
Can you attach any complete even basic project that can't load jpgs (maybe even with final *exe file to compare)? All jpg's are causing the problem? Did you tried resaving them with some editor like Paint.Net / GIMP?
#24
Bug Reports / Re: Jpg doesn't work
Last post by Qedo - 2024-Jun-18
it's true dreamerman if I launch
EditorE.exe           ----> GLBasic IDE, Version: 16.927
GLBasicEditorE.exe    ----> GLBasic IDE, Version: 16.793

however in both cases jpg is not recognized
#25
Yes I will add a time log for the functions, I think I will make it only write if a certain key is held down, this way I won´t get gigantic logs. I think it will be nice to have in the future.
#26
In short for debbuging purpose, there are some general OpenGL debug/profiling tools (the older ones) that work with GLBasic and catch all called functions maybe even with some time statistic info, but I don't remember which ones at the moment. Narrowing issue with hand coded time checking functions in some crucial part can be usefull or disable some parts of rendering routine to check where can be the issue.
#27
Bug Reports / Re: Jpg doesn't work
Last post by dreamerman - 2024-Jun-18
hm.. is there some mismatch in Steam version of code editors? Proper latest version should be 16.927, but when you run it from Steam it launches ver 16.793 - is that only spelling error or wrong exe included.
Try launching standalone editor - Steam - show local files - run EditorE.exe (it should show proper version number), check if loading jpg is still an issue.
#28
Quote from: dreamerman on 2020-Apr-27ps. any one knows some nice free sprites (not rip-offs) that could be used in next benchmark/showcase project?
Bump cause of the above reason, needed some side project to take a breath from a 'proper' game project so I played with this a little and made a showcase video in popular 'Shorts' format:
#29
Hi Gernot, the Problem is rather finding the polygons for the triangulation dynamically.
I have run into two problems while developing further:

I noticed that I can´t make faces transparent using alphamode when I colored them, I wanted to make different shades for the lawn tiles based on their angles, so I created 16 plains with vertex colors ranged from rgb(0,0,0) to rgb(255,255,255), it looks really nice, but the faces that have not rgb(255,255,255) won´t render transparency (ghosting) correctly, they just stay solid (transparent texture color is not displayed, as it should be).
Is this a known bug, is there a workaround for this?

Also I noticed some performance decrease where I just can´t find the reason, when the player is above a hole the performance drops for some reason, are there some performance analysis tools in the GLBasic IDE? Otherwise I need to log each function call and its duration manually to find the culpit.

I also made up my mind of the new direction of the actual game I want to build of this and made some gameplay drafts ( in Notepad++ ). Basically it will be focused on melee combat with enemies, the jump and run aspect will still be there but not as dominant like in the previous formula. And of course it will have a (hopefully ) nice story. Graphics wise I will polish it a bit, but I will still go for this N64 retro look.
#30
Bug Reports / Jpg doesn't work
Last post by Qedo - 2024-Jun-18
Hello everyone
I have a problem with GLB steam version 16793 win 10 which didn't exist until 15 days ago and therefore shouldn't be a bug.
It happened that win10 got corrupted and I had to reinstall the OS and also Glbasic by downloading correctly from Steam.
From that moment on, any glbasic program no longer recognizes jpg files, only png and bmp.
   name_jpg$="D:/greg66.jpg"
   IF DOESFILEEXIST(name_jpg$)
      LOADSPRITE name_jpg,10
      DRAWSPRITE 10,0,0
      GETSPRITESIZE 10,ssx,ssy // result ssx=0 and ssy=0
      SHOWSCREEN
      MOUSEWAIT
   endif
With this example program nothing is displayed
Anyone have any ideas?
PS with Glbasic15 no problem everything works