Author Topic: New iPhone 5 and resolution  (Read 8415 times)

Offline Dark Schneider

  • Mr. Polyvector
  • ***
  • Posts: 128
    • View Profile
New iPhone 5 and resolution
« on: 2012-Sep-13 »
The new iPhone 5 has a resolution of 640x1136  :blink:

We know that each new SDK ALWAYS shows the screen at its native resolution (no auto-zoom), so what is going to happen? How can Retina graphics be used for that reslution? We know if we don't use integer zooms (x2, x3) we have bad stretching  :blink:

It seems Apple likes to tease developers  :rant:
« Last Edit: 2012-Sep-13 by Dark Schneider »

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4020
    • View Profile
    • Space Fractal
Re: New iPhone 5 and resolution
« Reply #1 on: 2012-Sep-13 »
You dont tried android and it's 117 different resolutions? If designed property, then there a no issues.

Also there should been letterboxed if running in old retina resolutions, elsewise you could just add a nice border art. So it's not really a big issue, its a small one this time. You knew its was happens.

In your game, rapids rider, nothing problem with black border me thinks (just like iPad version).

My own game... It's happy to detect and use that resoulution.
« Last Edit: 2012-Sep-13 by spacefractal »
Genius.Greedy Mouse - Karma Miwa - Spot Race - CatchOut - PowerUp Elevation and The beagle Jam.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10839
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
New iPhone 5 and resolution
« Reply #2 on: 2012-Sep-13 »
Yes it should work. A value to get the dpi might be usefull, now.

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4020
    • View Profile
    • Space Fractal
Re: New iPhone 5 and resolution
« Reply #3 on: 2012-Sep-22 »
I just discovered the new resoulution require xCode 4.5 to been used. If you do that, then you cant use arm6 anymore (which howover have wrong default settings from glbasic), and hence its would not support iPhone 3g and below devices at all.

In my game I dedicated to require iOS 4.3 and supporting the new iPhone 5. If I which I could add a another app with lecacy support, but its would not been the first version.

So you need to dedicate you want to fully support iPhone 5 or the app will been letterboxed auto.
Genius.Greedy Mouse - Karma Miwa - Spot Race - CatchOut - PowerUp Elevation and The beagle Jam.

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4175
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: New iPhone 5 and resolution
« Reply #4 on: 2012-Sep-22 »
Apple are silently removing possibility to develop for legacy devices with the updates to iOS and XCode. I can't say I blame them, as there are now too many different variants for devs to support. However, if they continue down this route they will alienate users and devs and the prices of apps will rise as apps take more and more resources and time to develop for.
I came. I saw. I played.

Offline hardyx

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 504
    • View Profile
Re: New iPhone 5 and resolution
« Reply #5 on: 2012-Sep-23 »
In XCode 4.2 you can make and debug apps from 4.3.3 to 5.0. (from 3.2 to 4.33 installing a legacy module) Why make the life harder to developers with new XCode versions dropping support? There are many people using 4.3.3 or 5.0/5.1 in their devices.

And the versions question: Why change iOS version to 6.0 if last version is 5.1.1? Moving faster to drop support of old devices? They wiped Google Maps and added twitter. Very useful :zzz:. iPad 1 is not eligible for 6.0, if I remember correctly.
« Last Edit: 2012-Sep-23 by hardyx »

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4020
    • View Profile
    • Space Fractal
Re: New iPhone 5 and resolution
« Reply #6 on: 2012-Sep-23 »
Lowest support is ios 4.3 in xcode 4.5. Is just the devices Appls no longer sold on long time, that got removed support (those that using arm6).

I have still not updated to iOS 6, but compiled fine to my current devices.

For my game it's more important to support iPhone 5 resoulution than doing legacy support.
Genius.Greedy Mouse - Karma Miwa - Spot Race - CatchOut - PowerUp Elevation and The beagle Jam.

Offline Moru

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1793
    • View Profile
    • Homepage
Re: New iPhone 5 and resolution
« Reply #7 on: 2012-Sep-23 »
Apple is about making money just like all other companies. Ofcourse they need to remove the old hardware so people buy the new ones. How else to keep the treadmill going? :-)

Offline Hark0

  • Prof. Inline
  • *****
  • Posts: 1020
  • Geek Developer
    • View Profile
    • LitioPixel - Desarrollo de videojuegos con GLBasic | Videogame development with GLBasic
Re: New iPhone 5 and resolution
« Reply #8 on: 2012-Sep-23 »
My iPad1 are NOW OBSOLETED.... new resolution EVERY new screen... :blink:

Thanks Apple!!!!  :rant:

Maybe my next device are MORE FREE! like Android Tablet....  :whistle:


WE ARE LIVING DAYS OF MUNDIAL CRISIS, NOT ALL PEOPLE CAN CHANGE/REPLACE/BUY A NEW IDEVICE EVERY 10 MONTHS!!!!!  :rant:


PS Sorry for my OT comment... the policies of Apple not are for me....
« Last Edit: 2012-Sep-23 by Hark0 »
http://litiopixel.blogspot.com
litiopixel.blogspot.com - Desarrollo videojuegos Indie · Pixel-Art · Retroinformática · Electrónica Development Indie Videogames · Pixel-Art · Retrocomputing · Electronic

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4448
    • View Profile
    • FUED
Re: New iPhone 5 and resolution
« Reply #9 on: 2012-Sep-23 »
Agree with Moru. People get pissed of by apple´s acts but, it is expected.

One thing though, is the speed they unsupport older hardwares.
Such usually forces developers to always buy the latest hardware (very expensive) as buying a second or third generation may not give you enough time before its dropped.

Of course it is my own opinion, I never owned anything apple.
Couple years ago I thought to buy a cheap second/third gen mini mac for developing (cheaper then first gen I mean, couse even that is expensive). The one I had in mind was kind of dropped on the last update, the update that got Crivens pissed of last year.

Also, brazil has the highest price on apple wordwide, whatever apple thing here costs 3x what it costs in the US. So my second hand mini mac third gen would have come to my hand on the price of a first gen one. You can imagine how I would feel if in an year such was dropped.

I then realized that I can´t actually afford iphone/pad development while pushing game coding on a side project/hobby.
If ever I come up with a game that sells enough on other platforms then I will try i-things (understand that is my solo pocket condition).

I don´t know much of the apple store, but it seems to me not only the hardware goes unsupported but whatever app you developed for that becomes old too, in a way apple requires you to, every now and then, update your game should you want to have it selling on their store. I guess not paying the dev 100$ also leads to not having your app for sale too (overall is not that bad, as it cuts off a bit of the flood?).

I take a game has a maximum 2 years of potential sales (a bit reduced these days though) so I agree with spacefractal, should you want to go i-thing way, always target the latest hardware as that will give a chance for your game to live and earn longer.

edit: Sorry to hear that Hark0, but I think other ipads will have even a shorter life then ipad1. Parts of the world are sure going through crisis and so are the companies too, so I guess Apple has to push money-money instead of laying of but I tend to think they would do it anyways(the money money part :)).

« Last Edit: 2012-Sep-23 by erico »

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10839
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
New iPhone 5 and resolution
« Reply #10 on: 2012-Sep-23 »
I wanted to update my rpn calculator app. I had iOS 6 on. So I needed the new xcode. And that disabled support to upload an app to my 1st gen ipod.
Where is the dislike button?
In the end, the update will be iOS4.3 only :(

jestermon

  • Guest
Re: New iPhone 5 and resolution
« Reply #11 on: 2012-Sep-24 »
OT, but there is a trend underway.
I've stopped bothering with IOS, since about half of my clients have thrown out or literally given away their iPads and switched to Android tablets for their business; due to Apple's constraints placed on software distribution - Which is just great for me. Now my Unity and GLB projects have one less headache to worry about. 

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4448
    • View Profile
    • FUED
Re: New iPhone 5 and resolution
« Reply #12 on: 2012-Sep-24 »
Well, last ios update got some apple machines off the game, people got pissed.
I´d like to state that I never mean the i-phone/pad support is not important or brings problems only.

There are people here that worked hard to make this happen, and I praise their marvelous work and the extra platform we can benefit.
There are people making money on that, benefiting from such.
There are people updating the ios support on a constant measure.

I mean no bad for those and the work they did to make it happen.
The opposite, It is a most important feat into GLB to support such.

My only problem is a self problem, I can´t afford.

I do intend to jump into i-things as soon as it is possible walletwise.
Huge thanks to those that made it happen and continue to make it happen, IOS support, IMHO,  is hugely important for GLB. :good:

Offline Crivens

  • Prof. Inline
  • *****
  • Posts: 913
    • View Profile
Re: New iPhone 5 and resolution
« Reply #13 on: 2012-Sep-24 »
Out of interest does anyone else's app store in iOS6 really suck? I have my 3GS jailbroken so it's still on iOS5 (because I moved to Cyprus, and even though I'd been out of contract for like a year I couldn't get it sorted in time to be properly unlocked). No problem there.

But my iPod 4G has now been updated to iOS6 and it totally sucks in the app store. The search option is a massive pain and is slow as hell to scroll (one app per page? seriously?), and will then fully crash after a while. Nice.

It's interesting as my sales are up since the 5 came out (for what it's worth), but I can't see why with the app store in the way it is (even if perfect the one app per page on search is seriously naff)...

Cheers
Current fave quote: Cause you like musicians and I like people with boobs.

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4020
    • View Profile
    • Space Fractal
Re: New iPhone 5 and resolution
« Reply #14 on: 2012-Sep-25 »
Android is no different. glBasic does not support 2.1 and below, which is around same area with the old generation iPhones (if not newer). So there is really no reason to support them, only if you do a SD version of the game with xCode 4.2. Howover some might choice to sell both as a SD version (xCode 4.2) and a HD version (xCode 4.5). In that way all devices could been supported. Howover its require you have xCode 4.2, which still can been downloaded (dont use Internet Explorer in the Apple dev console). Its a little bit of mess, but its a way to doing that.

I have not tested iOS6 yet.

Genius.Greedy Mouse - Karma Miwa - Spot Race - CatchOut - PowerUp Elevation and The beagle Jam.