GLBasic forum

Main forum => Bug Reports => Topic started by: Moru on 2008-Jul-28

Title: Problem with opening the helpfile
Post by: Moru on 2008-Jul-28
I'm having troubles opening the helpfile from GL-Basic, nothing happens. So I tried opening it from the explorer shell and then I get the errormessage:

Quote
hh.exe - Entrypoint not found
The procedure entry point _except_handler4_common could not be located in the dynamic link library msvcrt.dll

And an OK button. I get this message twice before it gives up.

Windows says I have this version of the file:
7.0.2600.5512 (xpsp.080413-2111)

Anyone have any ideas what's going wrong? This is after reinstalling Windows XP and SP3 but I haven't used the help for a while so don't know when it started.
Title: Re: Problem with opening the helpfile
Post by: Moru on 2008-Jul-28
I found a page that said what files are belonging to the helpsystem and copied them from the old installation. These are the files you need to copy if you have the same trouble:

Just look for where they are on your system and replace them.

Code: (glbasic) [Select]
hhctrl.ocx
itss.dll
itircl.dll
hh.exe
hhctrlui.dll
Title: Re: Problem with opening the helpfile
Post by: Kitty Hello on 2008-Jul-28
Thanks. Maybe one should upload them to somewhere?
Title: Re: Problem with opening the helpfile
Post by: Moru on 2008-Jul-28
Not sure how legal that is but I can upload them if you want.
Title: Re: Problem with opening the helpfile
Post by: Hemlos on 2008-Aug-03
I had this same problem a long time ago.
hh.exe is what fixed it.
Im having the same problem again.

Where did you upload these files to?
Can you put a link to them here in this topic please?

I get an error with msvcrt.dll when i click the help file. window title is hh.exe

-Hemlos
Here is a screenshot im attaching to this message:
(http://www.glbasic.com/forum/index.php?action=dlattach;topic=2145.0;attach=180;image)

[attachment deleted by admin]
Title: Re: Problem with opening the helpfile
Post by: Hemlos on 2008-Aug-05
The problem is windows xp sp3...i went back to sp2 and its fine now.
Title: Re: Problem with opening the helpfile
Post by: Moru on 2008-Aug-05
I'm running SP3 without problems after copying those files from my old SP2 install
Title: Re: Problem with opening the helpfile
Post by: Hemlos on 2008-Aug-07
I'm running SP3 without problems after copying those files from my old SP2 install

Doesnt matter how you fixed it for sp3, the help file system is simply enough not compatible with sp3.

Maybe microsoft will make yet another update...who knows. Very unprofessional imo
Title: Re: Problem with opening the helpfile
Post by: Moru on 2008-Aug-07
I would love HTML-help instead of this, more futureproof you can't get it. But it has to be offline, I don't want to be dependant on internet for getting help on a command.
Title: Re: Problem with opening the helpfile
Post by: Kitty Hello on 2008-Aug-07
uhm!? You want the help file to be different?
Title: Re: Problem with opening the helpfile
Post by: Moru on 2008-Aug-07
I preffer HTML help since it's more future proof, not dependant on what OS i'm running at the moment. Sure, the F1 function is usefull but since I need to press enter to get the article after that it's not that much you loose.
Title: Re: Problem with opening the helpfile
Post by: Hemlos on 2008-Aug-07
I preffer HTML help since it's more future proof, not dependant on what OS i'm running at the moment. Sure, the F1 function is usefull but since I need to press enter to get the article after that it's not that much you loose.

I agree, it is a better standard in programming technology imo....html
Maybe you can put the html, for offline use with the SDK install?  =D
Title: Re: Problem with opening the helpfile
Post by: MrTAToad on 2008-Sep-14
What happens is that a program uses the Vista version of MSVCRT and replaces the one in SYSTEM32 - which, whilst fine on Vista machines, doesn't exactly work well with XP.

I've recently had this (its knocked out CHM viewer and my sound manager).  I do suspect that GLBasic was the cause unfortunately - so it might be worth checking to make sure that uses the correct version of MSVCRT.  However, saying that, it can be caused by a wide variety of other programs too.

Fortunately, trying a SFC /scannow seems to have fixed it.
Title: Re: Problem with opening the helpfile
Post by: Kitty Hello on 2008-Sep-14
No, I'm not overwriting msvcrt.dll it a newer version is installed - and I install a quite old one (IIRC).
Will have to see again, though.
Title: Re: Problem with opening the helpfile
Post by: MrTAToad on 2008-Sep-14
Fair enough :)

Title: Re: Problem with opening the helpfile
Post by: Kosta on 2008-Oct-31
hhctrl.ocx
itss.dll
itircl.dll
hh.exe
hhctrlui.dll

I'm running SP3 without problems after copying those files from my old SP2 install

Hi Moru,

which Files have you replaced (all of them above)?

and with which version you have replaced them?

i have the same problem (i got the _except_handler4_ error also on other programs (RealtekSoundDriver and on Spybot))
following versions are installed on my system:

htctrl.ocx    (from april (i think from sp3)) ...then i have found an older version of january on system (sp2 or 1)
itss.dll (.4186) ... found also an older version (2453)
hh.exe (.2453) .... found also an older version (1159)
hhctrlui.dll (4.74.9273.0) ... found only one version (in the dllcache folder)
Title: Re: Problem with opening the helpfile
Post by: Moru on 2008-Oct-31
These are the files I replace after installing GLBasic 6 beta:

"system32\"
 itss.dll     5.2.3790.2453
 itircl.dll   5.2.3790.2453
 hhctrl.ocx   5.2.3790.1194
 hh.exe       5.2.3790.2453

"system32\mui\001D"
 hhctrlui.dll 4.74.9273.0

I just overwrite them all since I know that works, not interested in testing out what is causing it :-)
Title: Re: Problem with opening the helpfile
Post by: S.O.P.M. on 2008-Nov-04
Ok, here I want to call attention to a "cosmetic defect" that GLB has from the beginning. By opening the helpfile it always says that the page cannot be displayed until I double click anything from the index list. I would suggest to display the introducing page first.
Title: Re: Problem with opening the helpfile
Post by: Hemlos on 2008-Nov-05
Definetly not sp3, sp2 here causes the same problem.
Title: Re: Problem with opening the helpfile
Post by: Kitty Hello on 2008-Nov-05
am I installing an older version? Or one that's too new?
Title: Re: Problem with opening the helpfile
Post by: FutureCow on 2009-Jan-05
I may have found the cause of the initial "Page Cannot Be Displayed" help file problem.

The initial page it tries to open when you hit F1 appears to be
mk:@MSITStore:C:\Documents%20and%20Settings\username\Desktop\GLBasic\GLBasic_e.chm::/01%20General.html

Instead should it be looking for this?
mk:@MSITStore:C:\Documents%20and%20Settings\username\Desktop\GLBasic\GLBasic_e.chm::/1%20Tutorials/01%20General.html

Assuming the start page is supposed to be the first tutorials page that is.
Title: Re: Problem with opening the helpfile
Post by: Moru on 2009-Jan-05
when you press F1 with the cursor on a command in your program you are supposed to get the help for that command directly. If you press enter after F1 it shows up since it gets selected in the list. It just won't show up directly. Any clues to why?
Title: Re: Problem with opening the helpfile
Post by: FutureCow on 2009-Jan-05
F1 (regardless of whether you have a command selected or not) appears to default to opening the following page.
mk:@MSITStore:C:\Program%20Files\GLBasic\GLBasic_e.chm::/01%20General.html

I can't suggest anything without knowing how GLBasic is calling the help file.
Title: Re: Problem with opening the helpfile
Post by: Kitty Hello on 2009-Jan-05
It uses the HtmlHelp API. When you double-click the help file it shows up good.
Title: Re: Problem with opening the helpfile
Post by: FutureCow on 2009-Jan-05
I did some searching of Google but without the actual system calls etc I couldn't get very far. Sorry I can't be of much help.
Title: Re: Problem with opening the helpfile
Post by: Cliff3D on 2010-Aug-31
Ok, here I want to call attention to a "cosmetic defect" that GLB has from the beginning. By opening the helpfile it always says that the page cannot be displayed until I double click anything from the index list. I would suggest to display the introducing page first.

I am getting this too, using Windows XP Pro on a netbook and/or a virtual PC on my desktop, it always does this whether I open the help from F1 or from the help menu.
Title: Re: Problem with opening the helpfile
Post by: Ian Price on 2010-Aug-31
The solution might have worked on XP (never tried) but it definitely doesn't work on Win7. :(
Title: Re: Problem with opening the helpfile
Post by: Slydog on 2010-Aug-31
Local HTML still sounds like a good option, to avoid these problems.
Have each command in its own file, sharing a common CSS file.
I think this would also be an acceptable instance where frames would be useful! (to list all the commands on the left)
You should be able to link directly to the selected command in the editor, and still use frames.
Then an online help system would use the same files, and can always be kept up-to-date.
(How about the MAC port?  Does it have its own help system?)
But, not a big deal, I'm used to the current system.
Title: Re: Problem with opening the helpfile
Post by: MrTAToad on 2010-Aug-31
You can get the CHM system working on Windows 7 - there is a download available on the Microsoft website.
Title: Re: Problem with opening the helpfile
Post by: Ian Price on 2010-Aug-31
You can get the CHM system working on Windows 7 - there is a download available on the Microsoft website.

There is, but that doesn't work and their advice is incorrect too about allowing .CHM files to run (Right click on .CHM file, then click Properties and then click the Unblock box - there isn't one!).

It's not a big deal - I've lived with it for a couple of years.
Title: Re: Problem with opening the helpfile
Post by: MrTAToad on 2010-Aug-31
After installing it, I just double-click on a CHM file to run it :)
Title: Re: Problem with opening the helpfile
Post by: Ian Price on 2010-Aug-31
I can run .CHM files normally by themselves from outside of GLB, but when clicking F1 from GLB to read the helpfile I have to double click the actual command I want to read, as it brings up "This program cannot display the webpage" error.

Is this not what others have been talking about?
Title: Re: Problem with opening the helpfile
Post by: MrTAToad on 2010-Sep-01
Originally, no :)
Title: Re: Problem with opening the helpfile
Post by: Ian Price on 2010-Sep-01
OK. As you were... :P
Title: Re: Problem with opening the helpfile
Post by: MrTAToad on 2010-Sep-01
I've included my GLBasic Command List as a PDF file.  For some reason the exporting to PDF stopped at the 436 page, so there is a bit missing...

[attachment deleted by admin]
Title: Re: Problem with opening the helpfile
Post by: Kitty Hello on 2010-Sep-02
I should put a wget job on that downloads the online help to a local form and distribute that. Would save me lots of work.
Title: Re: Problem with opening the helpfile
Post by: Cliff3D on 2010-Sep-02
I can run .CHM files normally by themselves from outside of GLB, but when clicking F1 from GLB to read the helpfile I have to double click the actual command I want to read, as it brings up "This program cannot display the webpage" error.

Is this not what others have been talking about?

Not in the first post, no, but several of us have reported this issue here.

(http://i52.tinypic.com/ifoap4.gif)
Title: Re: Problem with opening the helpfile
Post by: Ian Price on 2010-Sep-02
Quote
Not in the first post, no, but several of us have reported this issue here.
Didn't think I was going mad! :P
Title: Re: Problem with opening the helpfile
Post by: MrTAToad on 2010-Sep-03
It would be nice if the help files went all HTML-like :)
Title: Re: Problem with opening the helpfile
Post by: Cliff3D on 2010-Sep-03
Quote
Not in the first post, no, but several of us have reported this issue here.
Didn't think I was going mad! :P

You're lucky I don't know you well enough to say something cute like "you can't go to where you already are!". Very lucky. I'm probably even luckier.

It would be nice if the help files went all HTML-like :)

Seconded. We could also probably find it easier to submit updates/corrections then too.
Title: Re: Problem with opening the helpfile
Post by: hardyx on 2012-Mar-13
CHM are compressed HTML files. Even there are programs for decompressing the HTML files.
Title: Re: Problem with opening the helpfile
Post by: spicypixel on 2012-Nov-23
Much prefer the HTML style help system. Not wanting to mention other packages but in Blitz2D or was it Plus there was a frame used for commands on the left and the info on the right :) Also an A-Z list could be shown instead and then subnav shown with commands starting with that letter. No Javascript even I dont think all HTML. Was very Nice.