Author Topic: Build for Win32 or Win64 not working  (Read 908 times)

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1810
    • View Profile
Build for Win32 or Win64 not working
« on: 2022-May-25 »
Keeps popping up message to setup build for Win32.
Build option is greyed out in proj settings section.
?
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1810
    • View Profile
Re: Build for Win32 or Win64 not working
« Reply #1 on: 2022-May-25 »
Okay, can ignore for now - it started working on next build but for a while build was not working...strange.
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline dreamerman

  • Global Moderator
  • Dr. Type
  • *******
  • Posts: 443
    • View Profile
    • my personal website
Re: Build for Win32 or Win64 not working
« Reply #2 on: 2022-Jun-02 »
Little late but, that's most likely related to the way how GLB IDE handles project compiling - all projects are compiled in same directory "%Temp%\glbasic", each time it should be cleared but if you will open second editor window/instance and run/compile project then some files may left or some mismatch may happen. (this is the way how I encountered such issue many times while working in my editor)
Other possible reason for this could be saving project files with different encoding (like with utf8 BOM or something, not sure how does it look atm) by editing it in for example notepad++, if such issue would appear only after changing target platform or some project setting it can be called a bug.
If you encounter it again, I advise to clear temp dir manually, and restart editor then compile project again.
Check my source code editor for GLBasic - link Update: 20.04.2020

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10832
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Build for Win32 or Win64 not working
« Reply #3 on: 2022-Jun-03 »
Or togle the debug button twice. That clears tge cache, too.