Main forum > GLBasic - en

Android Build Issues

(1/3) > >>

MrPlow:
Hi

Just tried a new build for android for an older app that built before on the older setups...

Got this error among others for the gzwrite commands?

C:\Users\Lenovo\Documents\GL_PROJECTS\GLBasic\Space2D\distribute\android_studio\app\jni\zlib\gzwrite.c:89:20: warning: implicit declaration of function 'write' is invalid in C99 [-Wimplicit-function-declaration]

Any idea if an update caused this?

SnooPI:
Probably a problem with #include <unistd.h>

Add it with the INLINE function at the start of your code.

But there will surely be another problem because the ZLIB has an API C.

Qedo:
I can not help you. Since compiling with android studio i have never been able to build. By the way, if anyone of good will wanted to write a mini tutrial, he would be welcome.  :giveup:

MrPlow:
So previously I was able to build fine etc.
But some new update must have changes items in the jni/src and jni/zlib
and probably others...

Also, the app gradle file was missing a top reference...

def buildAsLibrary = project.hasProperty('BUILD_AS_LIBRARY');

SF,Gernot was there an update to the android build or c++ sources recently (few months or so)
its been a awhile since i built a new project.

MrPlow:

--- Quote from: Qedo on 2021-Sep-16 ---I can not help you. Since compiling with android studio i have never been able to build. By the way, if anyone of good will wanted to write a mini tutrial, he would be welcome.  :giveup:

--- End quote ---

I did a few posts and SF did some others ...
Heres mine
https://www.glbasic.com/forum/index.php?topic=11356.0

Navigation

[0] Message Index

[#] Next page

Go to full version