GLBasic forum

Other languages => GLBasic - de => Topic started by: LukasOK on 2015-Mar-22

Title: Alle Sprites werden schwarz umrandet?
Post by: LukasOK on 2015-Mar-22
Hallo,

Ich habe mich jetzt nochmal neu Versucht und was dabei raus gekommen ist, finde ich gar nicht so schlecht.
Jetzt habe ich folgendes Problem:
Ich habe einen mir einen Gegner-Type gemacht, aber jetzt wir alle paar Sekunden hinter den Sprites ein schwarzes Bild eingeblendet kann mir jemand da helfen?
Schönen Sonntag!
Title: Re: Alle Sprites werden schwarz umrandet?
Post by: Ian Price on 2015-Mar-22
Use
Code: (glbasic) [Select]
ALPHAMODE -1.0 before drawing your sprites.
Title: Re: Alle Sprites werden schwarz umrandet?
Post by: D2O on 2015-Mar-22
Oder
Code: (glbasic) [Select]
SETTRANSPARENCY RGB(0,0,0)oder
dein Bild als png mit transparens speichern.
Title: Re: Alle Sprites werden schwarz umrandet?
Post by: Schranz0r on 2015-Mar-23
dein Bild als png mit transparens speichern.

thats the way it is :)
Title: Re: Alle Sprites werden schwarz umrandet?
Post by: LukasOK on 2015-Mar-23
Nein, Nein,

1.
Die Sprites sind Transparent.
Es taucht auch nicht bei einem sondern bei allem auf.
[Vorher tauchte es nie auf]


2.
Kann es am Alphamode liegen?
Weiß jemand die Lösung?
Title: Re: Alle Sprites werden schwarz umrandet?
Post by: Fabbio on 2015-Mar-23
Machmal ein codebeispiel und
Lade ein bild dazu hoch wo das problem besteht.

Gesendet von meinem GT-I9300 mit Tapatalk

Title: Re: Alle Sprites werden schwarz umrandet?
Post by: Schranz0r on 2015-Mar-25
Welche Bittiefe hast du eingestellt bei deinen PNG's ?
Ich fahr immer mit 32bit, wenn du 8 Bit hast musst du im Grafikprogramm Imdextransparenz mit angeben...