Author Topic: Linux problem  (Read 2247 times)


  • Guest
Linux problem
« on: 2009-Mar-21 »
Looking at the shader problem in the main forum, I compiled the Linux shader programs with no problem.  However, running is another matter, because for both programs I get :

/home/nicholas/Desktop/Shaders/Multitexture.linux: error while loading shared libraries: cannot open shared object file: No such file or directory

The problem is : mikmod (development and run-time libraries) are installed. In addition, all the usual SDL, and OpenGL libraries are installed.  I'm using a 32-bit version of Ubuntu 8.10

Tried it with other Linux samples too - and they dont work either.

Not wanting to switch back to Windows, I wanted to use GLBasic in Linux (using Wine) - whilst it does run and compile for most things, it does seem to know that its being run in Wine and wont let me compile for Linux - I get : Removed depreciated platform : Linux

Update : Thanks to Gregory I've managed to get the required libraries installed - still not sure that Linux should be needing these files though.

« Last Edit: 2009-Mar-21 by MrTAToad »