Author Topic: Some Tips about GLBasic and Linux to make games work  (Read 3433 times)

Offline CrystalNoir

  • Mc. Print
  • *
  • Posts: 33
    • View Profile
Hi there :)

I'm new and I just take a look to GLBasic. I tried to make some samples work on Linux. I saw this topic in the FAQ :

http://www.glbasic.com/forum/index.php?topic=2525.0

That works but, this work with distros witch use deb style packages. For other distros like Fedora 15 it's a little more tricky. How the FAQ said you could use getlibs for Ubuntu style distros but I'm going to show you an other way to find files you need to make games work on it :)

I would like first to apologize for my poor english. because I am french ^^

Let's do a recap, we need these :

-libSDL_mixer-1.2
-libstdc++.so.5

And theses lib :

-libmikmod.so.2
-libvorbisfile.so.3
-libsmpeg-0.4.so.0
-libvorbis.so.0

If you work with a 64 bit Os, be sure to install these libs in a 32 bit version too :)

Ubuntu / Linux Mint

For the libSDL and libstdc++ package juste make :

sudo apt-cache search -n <name>

example :

Code: (glbasic) [Select]
sudo apt-cache search -n libSDL
You will find what you need and then do apt-get install <name>

example :

Code: (glbasic) [Select]
sudo apt-get install libsdl-mixer1.2*
For the libs you could use getlibs but there is a tool that work perfectly for them and available directly. Just install apt-file

Code: (glbasic) [Select]
sudo apt-get install apt-file
Then to find the package that contain the libs do :

sudo apt-file search <name>

For example , to find libmikmod.so.2 :

Code: (glbasic) [Select]
sudo apt-file search libmikmod.so.2 
Linux will return the packages that contain the lib you need, after just install the package with apt-get install


Fedora / Distros with Yum tool

It's more easy I think.

For libSDL and libstdc++ juste do

yum list "*<name>*"

example :

Code: (glbasic) [Select]
yum list "*libSDL*"
or

Code: (glbasic) [Select]
yum search SDL
You will find package you need. If not, try to change the name like SDL instead of libSDL. Sometimes packages haven't the same name.

For the lib it's very very simple. Just do :

yum install <name>

Example :

Code: (glbasic) [Select]
yum install libvorbisfile.so.3
Yum will find automatically the right package to install for you :)

Hope this helps :)

Happy GLB !

« Last Edit: 2011-Aug-29 by CrystalNoir »