Author Topic: No default font in v7.301  (Read 3139 times)

Offline Wampus

  • Prof. Inline
  • *****
  • Posts: 1004
    • View Profile
No default font in v7.301
« on: 2010-Mar-24 »
Hi

In version 7.301 there doesn't appear to be a default font loaded into index 0 anymore.

For now the workarounds I've found for old routines:-

  • Include a smalfont.bmp file in the .app directory as this will still be automatically loaded into font index 0
  • Explicitly load a font first of all into index 1

MrTAToad

  • Guest
Re: No default font in v7.301
« Reply #1 on: 2010-Mar-25 »
If you just do :

Code: (glbasic) [Select]
PRINT "HELLO WORLD",64,64
SHOWSCREEN
KEYWAIT

You should see small letters (the default font)

Offline Wampus

  • Prof. Inline
  • *****
  • Posts: 1004
    • View Profile
Re: No default font in v7.301
« Reply #2 on: 2010-Mar-25 »
I should but I don't. If you do I wonder if there is something wrong with my installation.

Offline Moru

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1793
    • View Profile
    • Homepage
Re: No default font in v7.301
« Reply #3 on: 2010-Mar-25 »
My default font is gone too, I never noticed since I almost always create my own font anyway, the default font is just there for telling you that you forgot to make your own :-)

MrTAToad

  • Guest
Re: No default font in v7.301
« Reply #4 on: 2010-Mar-25 »
Yes, I get nothing too... Well, well :)

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10851
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: No default font in v7.301
« Reply #5 on: 2010-Mar-25 »
Neither do I. I report a bug.
The stupid thing is - I have to fix it myself then :S

Offline Wampus

  • Prof. Inline
  • *****
  • Posts: 1004
    • View Profile
Re: No default font in v7.301
« Reply #6 on: 2010-Mar-26 »
BTW I've discovered that LOADFONT "smallfont.png", 1 in the beginning of code is an easy workaround for the problem with code that simply needs a basic PRINT output for testing, etc.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10851
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: No default font in v7.301
« Reply #7 on: 2010-Apr-06 »
I'm loding "Smalfont.png" - one "L"