Main forum > GLBasic - en

Mac Crossover

<< < (3/3)

Anyone tried to install Android SDK into Crossover? I cannot startup the SDK Manager.


--- Quote from: Qube on 2011-Feb-23 ---I have GLBasic v9.x (the latest version) successfully working in CrossOver Professional 10  :good:
How did I get it to work? (to this stage). Something around these lines (might not need all of them though).... Create an empty XP Bottle, install (all into the one bottle, not new ones) - core fonts, MS C++ redistributable 2005 and 2008 & IE 7 (all available from the software list). Then lastly I installed GLBasic. I did have to choose the location of where it stores it's documents pretty quickly as for some reason that window kept shutting off (the choosing of a folder on the first run of GLB).

I then made a couple of adjustments to GLB and the Bottle to get rid of the damn ugly fonts it (CrossOver / Wine) uses by default. All in all, quite impressed with CrossOver 10 and GLBasic for what I need at the moment as it means I don't always need the extra OS layer via parallels.

--- End quote ---

Using GLB14 in combination with CrossOver 13.0.1 worked fine with compiling the example projects. I added Core Fonts too.
The MS C++ 2010 install detected a newer version, so I canceled it.

Installed WinRAR in the bottle, and used it to install the Mac platform from

 I can compile my level editor and game for Win32, Crossover is pretty good!  :good:

When I had my macmini (RIP  :D) I bought Paralel-Desktops, I think is the best Virtualization for Mac... Is exactly the same like Windows.
Now In Linux I use VMware Player is free, and runs fine GLBasic in 3D too, the problem the machine sometimes is freeze (I think is I'm using a 12 years old CPU).

I can't get Mac compile to work. It throws an error immediately, saying "Create process failed". Anyone have an idea what that's about? I'm thinking something about the bottle not being allowed to create processes or something.  :doubt:

It's not a big deal, I can still compile for Windows, but it would be nice.  :P

I wish debug mode would work though. If I try to compile debug mode I get this:

--- Code: (glbasic) ---compiling:
*** FATAL ERROR - Please post this output in the forum
*** Finished ***
Elapsed: 62.5 sec. Time: 14:35
Build: 0 succeeded.

--- End code ---

So it's really difficult for me right now to fix array OOB errors and so on.  :doubt:

I don't understand what the problem is. Anyone have an idea?


[0] Message Index

[*] Previous page

Go to full version