GLBasic forum

Other languages => GLBasic - de => Topic started by: D2O on 2022-Apr-03

Title: Was brauche ich um Multiplattform zu nutzen??
Post by: D2O on 2022-Apr-03
GLB aktuelle Steam Vesion.
Hallo zusammen, seit langen möchte ich mich wieder mit GLB beschäfigen und leider bin ich total frustriert :(

Was muss ich noch zusätzlich installieren?
Das mit dem Emscripten, da habe ich die Main_Emscripten herunter geladen und den inhalt in C:\Program Files\Emscripten gepackt.
Nada, geht nicht, bzw. dann jammert GLB wegen einem fehlenden Phyton.
Das auch instaliert, und geht immer noch nicht :(
Alles wieder deinstalliert.

Zu Html5 / WebGL:
Hier drehe ich fast am Rad.

Folgende fehlermeldung:
Quote
_______________________________________
*** Configuration: HTML5 ***
precompiling:
GPC - GLBasic Precompiler V.17.312 SN:3eb36880 - 3D, NET
Wordcount:3 commands
compile+link:
-----------------------------------------
%EMSDK% is set, or SDK is not installed or can't be found at:
C:\Program Files\Emscripten
Get and install the (prebuilt) SDK from: https://kripken.github.io/emscripten-site/docs/getting_started/downloads.html-----------------------------------------

Der Befehl "emsdk_env.bat" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.
Der Befehl "em++.bat" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.
distribute HTML5 to: D:/Projekte/GLBasic/GLBasic/first_app/distribute/HTML5
exit
success
_______________________________________
*** Finished ***
Elapsed: 2.3 sec. Time: 15:35
Build: 5 succeeded.

Was braucht es da noch und wohin damit??



Zu Andoid, Android Studio installiert:
Quote
_______________________________________
*** Configuration: ANDROID ***
precompiling:
GPC - GLBasic Precompiler V.17.312 SN:3eb36880 - 3D, NET
Wordcount:3 commands
compile+link:
copy templates...
   Q://Compiler/platform/android_studio
   D:/Projekte/GLBasic/GLBasic/first_app/distribute/android_studio
Update main program sources
Replace media files
Patch app ID
Patch app title
Making icons...
Starting Android Studio. Build your app now.
exit
success
_______________________________________
*** Finished ***
Elapsed: 6.0 sec. Time: 16:01
Build: 5 succeeded.

 

Android Studio öffnet sich.

Und nun??

Adroid Studio schmeist dieseMeldung raus:
Quote
> Configure project :app
NDK is missing a "platforms" directory.
If you are using NDK, verify the ndk.dir is set to a valid NDK directory.  It is currently set to C:\Users\fabbi\AppData\Local\Android\Sdk\ndk-bundle.
If you are not using NDK, unset the NDK variable from ANDROID_NDK_HOME or local.properties to remove this warning.

Warning: Mapping new ns http://schemas.android.com/repository/android/common/02 to old ns http://schemas.android.com/repository/android/common/01
Warning: Mapping new ns http://schemas.android.com/repository/android/generic/02 to old ns http://schemas.android.com/repository/android/generic/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/addon2/02 to old ns http://schemas.android.com/sdk/android/repo/addon2/01
...
...
...)
   at org.gradle.internal.event.BroadcastDispatch$ActionInvocationHandler.dispatch(BroadcastDispatch.java:91)
   at org.gradle.internal.event.BroadcastDispatch$ActionInvocationHandler.dispatch(BroadcastDispatch.java:80)
   at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:42)
   at org.gradle.internal.event.BroadcastDispatch$SingletonDispatch.dispatch(BroadcastDispatch.java:230)
   at org.gradle.internal.event.BroadcastDispatch$SingletonDispatch.dispatch(BroadcastDispatch.java:149)
   at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:58)
   at org.gradle.internal.event.BroadcastDispatch$CompositeDispatch.dispatch(BroadcastDispatch.java:324)
   at org.gradle.internal.event.BroadcastDispatch$CompositeDispatch.dispatch(BroadcastDispatch.java:234)
   at org.gradle.internal.event.ListenerBroadcast.dispatch(ListenerBroadcast.java:140)
   at org.gradle.internal.event.ListenerBroadcast.dispatch(ListenerBroadcast.java:37)
   at org.gradle.internal.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
   at com.sun.proxy.$Proxy41.afterEvaluate(Unknown Source)
   at org.gradle.configuration.project.LifecycleProjectEvaluator$NotifyAfterEvaluate$1.execute(LifecycleProjectEvaluator.java:190)
   at org.gradle.configuration.project.LifecycleProjectEvaluator$NotifyAfterEvaluate$1.execute(LifecycleProjectEvaluator.java:187)
   at org.gradle.api.internal.project.DefaultProject.stepEvaluationListener(DefaultProject.java:1419)
   at org.gradle.configuration.project.LifecycleProjectEvaluator$NotifyAfterEvaluate.run(LifecycleProjectEvaluator.java:196)
   ... 105 more


* Get more help at https://help.gradle.org

BUILD FAILED in 1s


Brauch ich nun doc wieder das Java JDK?
Welche Version??


Zu Mac OS:
Hier bekomme ich das hier
Quote
_______________________________________
*** Configuration: OS-X_X86 ***
precompiling:
GPC - GLBasic Precompiler V.17.312 SN:3eb36880 - 3D, NET
Wordcount:3 commands
compile+link:
i686-apple-darwin8-g++: installation problem, cannot exec '/cygdrive/q/Compiler/platform/Mac/Bin/i686-apple-darwin8-g++-4.0.1': No such file or directory
*** FATAL ERROR - Please post this output in the forum
_______________________________________
*** Finished ***
Elapsed: 2.3 sec. Time: 16:15
Build: 5 succeeded.
*** 16 FAILED ***


Raspberry Pi scheint zu funktionieren.


So für heute habe ich die Schn... voll. Bin recht frusriert.
Sollte es irgend wo einen vernünftige anleitung geben, was man für das Multi Compilieren braucht,
bitte gerne einen Link oder download.

Danke.


Title: Re: Was brauche ich um Multiplattform zu nutzen??
Post by: Marmor on 2022-Apr-04
chefe ?
Title: Re: Was brauche ich um Multiplattform zu nutzen??
Post by: D2O on 2022-Apr-11
Naja, das interess scheint immer mehr abzunehmen.

Zum Thema Android:
Ich habe herausgefunden das hier das JRE vom Android Studio genuzt werden muss, also habe ich den
JAVA_Home pfad angepasst.

Jetzt komme ich zu einem alten Problem, was schon einmal hatte.
Da ich ungerne alles auf die C Platte Installiere, habe ich das AS auf die D Platte installiert.
Aber GLB sucht das AS immer auf der C Platte.

Aber es scheint hier keine möglichkeit zu geben, GLB beizubringen, das hier AS nicht auf der C Platte ist.  :rant:

Title: Re: Was brauche ich um Multiplattform zu nutzen??
Post by: Qedo on 2022-Apr-11
https://www.glbasic.com/forum/index.php?topic=11352.msg100702#msg100702

spacefractal:
"Java 1.6.0-25 and any other sun java is not required at all as Android Studio uses OpenSDK version of Java instead, which is included with Android Studio and installed by default. So you dont need to use any of the official java version at all!"
Title: Re: Was brauche ich um Multiplattform zu nutzen??
Post by: Marmor on 2022-Apr-12
schade Gernot .  man hört und sieht dich ja eigendlich garnicht mehr.

 :(
Title: Re: Was brauche ich um Multiplattform zu nutzen??
Post by: svenart on 2022-Apr-27
Compilieren für android bin ich auch grade wieder am versuchen (allerdings mit der alten version, nicht steam). Habs schonmal geschafft aber Jahre her mit altem rechner.
Title: Re: Was brauche ich um Multiplattform zu nutzen??
Post by: D2O on 2022-Apr-28
Tja, mit der "alten" Version hatte es damals auch funktioniert.
@Qedo,  Danke.

Habe den Pfad zum A-Studio nun angepasst.
AS startet,
Info gradle Build wird angezeigt
und nun stehe ich hier.
Bekomme nun hier diesen Fehler :(
Title: Re: Was brauche ich um Multiplattform zu nutzen??
Post by: Kitty Hello on 2022-May-05
Puh. AS macht hauptsächlich space_fractal. Schreib mal auf englisch.