GLBasic V12 (was formerly V11 beta)

Previous topic - Next topic


I notice that the file is 0 bytes - could that be the cause ?


For me not Mrt I have a couple of files and them are about 25kb, but I think this files don't works for nothing... really all the code it's into the Html file, isn'it?¿... :x

Sorry no?¿, if you delete the .data don't runs the Html file...


If your file isn't 0 bytes, then could you make it available here and I'll see if that makes a difference


Ok, I attatched to this post...

I take a look only a waith of this file, I think it's something referenced to the media folder... in this case this project it's a 3D geometry textured... this it's part of my game, in this case the output data it's about 160Kb... in the standard test 2D whit snow flocks only has 29 Kb...

I leave the 2 files into the Zip...


So far those files just say "Preparing" too (Windows 8 ).

I'll try in XP now.  No, that doesn't work either.


For me works whit out problems, I'm using Windows 8, but really I have to execute in firefox in Mac...
I think this problems it's something in the Browser, or perhaps some plugin or add  on installed...

But really works and fine,.. the second example it's 3D textured, the texture it's a bit blurred, but I think it's for the res... but works quick and very very fine.

It's true under safari don't works too... always appears the loading bar and don't shows nothing...


The odd thing is Gernot's original example worked fine...

It does look as though some plug-in is needed.  Unfortunately the emscripten IRC are rather quiet so I don't know what is needed at the moment.


The IRC char people suggested looking at the developer console, and this what is being reported :

WARNING: using emscripten GL emulation. This is a collection of limited workarounds, do not expect it to work TestHTML5.html:48
XMLHttpRequest cannot load file:///C:/Users/Nicholas/Documents/GLBasic/TestHTML5/ Cross origin requests are only supported for HTTP. TestHTML5.html:96050
Uncaught Error: NETWORK_ERR: XMLHttpRequest Exception 101 TestHTML5.html:96050
still waiting on run dependencies: TestHTML5.html:48
dependency: TestHTML5.html:48
(end of list) TestHTML5.html:48
still waiting on run dependencies: TestHTML5.html:48
dependency: TestHTML5.html:48
(end of list)

Apparently Chrome wont do XMLHTTPREQUEST unless the -allow-access-from-files flag is used during compiling...


Yes, I'm using Gernot's test routine.

I notice the full path is required for output data :

Code (glbasic) Select
dataFile.onprogress = function(event) {

      var url = 'C:\Users\Nicholas\AppData\Local\Temp\glbasic\';

which may cause it...  However, I do think should have a size > 0...


MrT I comment how I have my installation... it's something extrange... but perhaps works.
I put the 11 in the C:/ root, and I execute like Admin, perhaps if you don't execute GLbasic whit Admin provileges this file it's 0 Bytes... I think if this file don't contains data , the Html page don't shows nothing... I try to put the data file out of the same folder and then the Html File don't makes nothing...

About the problem under paralell desktops , for me don't works, I think it's something whit the deep of colors, something whit the resolution and behaviour of virtual graphics card.


GLBasic is running in Admin mode already (as it's needed to run properly in Windows 8 ).  However, I have been doing all the testing XP...

I'll try it in the root directory now...

Its only a slight improvement (this is in XP and Firefox) :)

Code (glbasic) Select
rbow init
SDL_init video
SDL_GetVideoInfo = 320x200 @ 2 bpp. Screen 640x480
Requested SDL_OPENGL = 67108864
Requested double buffer
set up SDL for OpenGL mode
Setting video mode: 640x480x32 fl=4000000
Could not create canvas - [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMHTMLCanvasElement.getContext]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/test2/distribute/HTML5/test_.html :: Browser.createContext :: line 87865"  data: no]
SDL_SetVideoMode seems to be 1
Screen BPP: 32

I tried changing the temp directory to the root directory, but still get the usual Chrome problem (in XP) :

Code (glbasic) Select
till waiting on run dependencies: test_.html:48
dependency: test_.html:48
(end of list)


Can someone confirm, that X_DRAWAXES is messed up in 11.322? (compiling for win)

BTW for me Gernots example code works with Firefox 19.0 on Win7 x64. My is 0byte but it works.
Lenovo Thinkpad T430u: Intel i5-3317U, 8GB DDR3, NVidia GeForce 620M, Micron RealSSD C400 @Win7 x64


Yes, DRAWAXES is a bit... weird...


Tried the HTML 5 on a completely different computer, and whilst it doesn't work on Chrome, it does with Firefox...

Yes, FF works the others don't.

Been chatting to the emscripten IRC, and apparently the cause is the --pre-load file option.  Apparently it's something to do with cross origin loading rules (whatever that is) - for it to work with Chrome it MUST be launched from a website.


The compatibility results are quite interesting.

Only one mobile browser could cope with it (after trying Chrome, Dolphin, Firefox and Ninesky), and that is Firefox...  It was a bit slow, but when you are trying to animate 500 sprites, you cant expect miracles...

For desktop machines :

Anything in VirtualBox wont work (can't create a canvas) - tried with XP and Ubuntu.

Windows XP :

Firefox (V19) : OK Full Screen : OK
Chrome (V20) : No
Chrome (V22) : OK Full Screen : OK

Windows 7 :

Chrome (V22) : OK Full Screen : OK
IE 9 : No (no surprise there)

Windows 8 :

Firefox (V19) : OK Full Screen : OK
Chrome (V25) : OK Full Screen : OK
IE 10 : No (duh)

Ubuntu 12.04

Firefox (V12) : No

Ubuntu 12.10

Firefox (V16.0.1) : Somewhat.  First time was a crash; next it ran for a short time and then crashed

Other notes :

DRAWLINE is NOT available (currently) in HTML 5 - need to use DRAWRECT instead
X_SPRITE currently not implemented
PLAYMUSIC isn't implemented