Author Topic: GLBasic v10.118 NOT working on iOS  (Read 2604 times)

Offline Dark Schneider

  • Mr. Polyvector
  • ***
  • Posts: 128
    • View Profile
GLBasic v10.118 NOT working on iOS
« on: 2011-Oct-19 »
I always have an error result 'EXC_BAD_ACCESS' and it doesn't launch, I thought it could be because the complexity of the project I was compiling, but I tested using a basic test project (attached) and the same result. Using the same project compiled with an older GLBasic version and runs fine.

here is the console output:
Code: (glbasic) [Select]
[Session started at 2011-10-19 17:59:34 +0200.]
GNU gdb 6.3.50-20050815 (Apple version gdb-1516) (Fri Feb 11 06:19:43 UTC 2011)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "--host=i386-apple-darwin --target=arm-apple-darwin".tty /dev/ttys000
Loading program into debuggerÉ
Program loaded.
target remote-mobile /tmp/.XcodeGDBRemote-2629-32
Switching to remote-macosx protocol
mem 0x1000 0x3fffffff cache
mem 0x40000000 0xffffffff none
mem 0x00000000 0x0fff none
run
Running:
[Switching to thread 11779]
[Switching to thread 11779]
sharedlibrary apply-load-rules all
continue
Program received signal:  'EXC_BAD_ACCESS'.
(gdb)

[attachment deleted by admin]
« Last Edit: 2011-Oct-19 by Dark Schneider »

MrTAToad

  • Guest
Re: GLBasic v10.118 NOT working on iOS
« Reply #1 on: 2011-Oct-19 »
What XCode version are you using ?

Offline Qube

  • Mr. Polyvector
  • ***
  • Posts: 157
    • View Profile
Re: GLBasic v10.118 NOT working on iOS
« Reply #2 on: 2011-Oct-20 »
GLB v10.118 and the latest Xcode for Lion - Compiles > installs on the iPad 1 & 2 perfectly with iOS SDK 4.3 and iOS SDK 5.


Offline Crivens

  • Prof. Inline
  • *****
  • Posts: 913
    • View Profile
Re: GLBasic v10.118 NOT working on iOS
« Reply #3 on: 2011-Oct-20 »
I'm using GLB 10.118 and XCode 3.2 (XCode 4 is also installed along with the latest SDK). It works fine on my iOS4 2nd Gen Touch, iOS5 4th Gen Touch, and iOS5 3GS.

Cheers
Current fave quote: Cause you like musicians and I like people with boobs.

Offline Dark Schneider

  • Mr. Polyvector
  • ***
  • Posts: 128
    • View Profile
Re: GLBasic v10.118 NOT working on iOS
« Reply #4 on: 2011-Oct-20 »
I am using XCode 3.2.6 + iOS SDK 4.3 in Snow Leopard, iPod Touch 1G with iOS 3.1.3 NO jailbreak.

The same project compiled with GLBasic 10.057 and runs fine.

Maybe a problem with iOS previous to iOS4, or can be because architecture and doesn't work on armv6?.
« Last Edit: 2011-Oct-20 by Dark Schneider »

Offline hardyx

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 500
    • View Profile
Re: GLBasic v10.118 NOT working on iOS
« Reply #5 on: 2011-Oct-20 »
My projects works in iPhone 2G iOS 3.1.3 and iPhone 3GS iOS 4.02. Check you have the developer provisioning profile in your phone and it's not expired. And check you are signing the project with the correct profile.
« Last Edit: 2011-Oct-20 by hardyx »

Offline Dark Schneider

  • Mr. Polyvector
  • ***
  • Posts: 128
    • View Profile
Re: GLBasic v10.118 NOT working on iOS
« Reply #6 on: 2011-Oct-20 »
OK, I am waiting for an update approval, once is OK I will try again.