Main forum > Beta Tests

GLBasic code editor - BR GLB IDE, with VB .Net source... Update: 21.10.2021

<< < (17/18) > >>


just downloaded and tested your Editor, very nice! But i got some errors at compiling

--- Code: (glbasic) ---/mingw/lib/crt2.o:(.text+0x1a5): undefined reference to `___dyn_tls_init_callback'
/mingw/lib/crt2.o:(.text+0x1e3): undefined reference to `__setargv'
Some error occured durring compiling... code:  1

--- End code ---

I've tried an existing project, wich compiles fine under GLB14 and a new created one with your IDE. Both the same result. is copied. IDE runs with admin rights. Is there anything that i've overlooked?


Some time ago I tried to use more advanced auto-complete menu (look into 'images' dir to find icons), but some issues occurred, that I wasn't able to resolve, so I sticked to standard simple auto-complete. In meantime AutoCompleteMenu along with ScintillaNet got updated, but I didn't looked into this. Good that you reminded me about that. After some changes to my code, better auto-complete is working quite ok, there are some things to fix, but it's first public release with this feature.

That problem with compilation may be depended (from what I found here on forum) on some sys variable PATH settings, standard GLB ide had similar issues some time ago, maybe some 'hack' is needed to bypass this. Check your PATH variable, maybe has some duplicate definitions or something like this, never had such problem so this will need some time to check, but in some way it can be fixed.

Edit: Yet another update fixing some new issues with loading project, parts of code were changed so they are under testing.

Yesterday I uploaded new version. Switched to more advanced AutoComplete menu, as I figured out how to use it properly with multiple Scintilla objects and GLB style of coding. After few weeks of testing it's looking good, also few tweaks to code analyzing were added.
Some other issues were also fixes: if you used source not from project directory but with absolute path like 'd:/my_glb_libs/gui.gbas' it wasn't passed properly to compiler, projects with more than 10 source files are compiled now (temp source name is based on hex), and so on..
Wasn't able to identify problem with 'undefined reference to `___dyn_tls_init_callback'' as it didn't appear during my tests.

Keep up the good work.

Ohhhhhh... i'll try it later!

OK first Start with no Project in it -> get some errors (you know that one's) :)
I create one then restart, all is fine. :good:
Can't find any other big errors now, the only thing i find:

- ENDINLINE is not in the Autocompletion
- created CONSTANT's are not in the completion

So no big deals for now ^^

In the attachments my Colortheme and Screenshot.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version