BASIC

Author Topic: Problems with Any Program example to run after deploy in Macosx Universal...  (Read 5058 times)

Offline fasasoftware

  • Mc. Print
  • *
  • Posts: 20
    • View Profile
Problems with Any Program examples to run after deploy in Macosx Universal..

I have tryed some example.. but in my old apple g4 2,2ghz 1,5 gbram macosx10.4.11 don't work.....when i  open the app example .... give me an error after start...and then the app quit...

I know i have an old computer...i have also an intel i5 and works a little fine...but sometimes the ide quit...

can somebody help me please???

Best regards

Lestroso :'(

www.fasasoftware.com
« Last Edit: 2013-Aug-29 by fasasoftware »

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3366
  • Integrated Brain
    • View Profile
Yes I'm not sure about this error, but I rebenber the problem was , when you unzipp the compiled program...

make this, we look if works.

When you compile for Mac osx or Mac Universal, you get a compressed file?¿
Then copy to your mac desktop and unzip... Seems a lazy thing, but I rebenmber something whit the unzip step was the problem.. don't care works fine Mac osx and Uni

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4234
    • View Profile
    • Portfolio
Yep, there was something related to flags when moving the app form pc to mac.
Try as Mentalthink suggested, zip it on pc and unzip on mac.

Welcome Fasa!

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3366
  • Integrated Brain
    • View Profile
Thanks Erico I always forget this Step, I think this have to write in Capital letters in someplace of the forum, it's really a simple thing but really complex to find the solution...  :good: :good:

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4234
    • View Profile
    • Portfolio
Yep, I had that very same problem few years ago.
But there is a good side on it, people come over to the forum for a chat over the subject! :good:

Offline fasasoftware

  • Mc. Print
  • *
  • Posts: 20
    • View Profile
I have tryed to zip on pc and unzip the file but the problem still remain.....The app start and then quit unexpectly

I have also tryed to rar that but is too bad again...

I don't know...

any other ideas??

best regards,

Lestroso

www.fasasoftware.com

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4234
    • View Profile
    • Portfolio
For the old mac, it should work fine, try to do a simple ´hello world´ app and port it over to check it out.
For the IDE quiting... that is really hardcore, it never ever happened on my end.

Please, release more information and code on both subjects so we can try help it out.

Offline Neurox

  • Mr. Polyvector
  • ***
  • Posts: 184
    • View Profile
    • http://www.borzini.it
I have tryed to zip on pc and unzip the file but the problem still remain.....The app start and then quit unexpectly

Have you set the parameters for read / write?
Have you seen the activities logo with Console.app ?
Paolo Borzini | paolo@borzini.it
The WhiteFly Software | www.thewhitefly.it
Service on line for screen printers | www.4pellicole.it

Offline fasasoftware

  • Mc. Print
  • *
  • Posts: 20
    • View Profile
I TRied everything.... i was thinking is my fault because i trying to compile the game 3d in macosx universal...but i'm using the demo glbasic....  and i can compile only for 2d.....ok then i have compiled an simple hello world... but nothing the app (hello world) quit unexpectly...

i don't know what i have to do.....

best regards,

lestroso,

www.fasasoftware.com


MrTAToad

  • Guest
Run it from Terminal and paste the error message returned.

It could be the fact that you need to set the program part to "executable".

Offline fasasoftware

  • Mc. Print
  • *
  • Posts: 20
    • View Profile
Here it is....here the code...from terminal...bho.. i don't understand...
Code: GLBasic [Select]
 
best regards,

Lestroso :'(

www.fasasoftware.com

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3366
  • Integrated Brain
    • View Profile
HI friend try whit this post--- I used and I think my app working.. I read a bit and says something about the privileges of the files... take a look , I think here it's all explained... the bug problem it's when you extract, if fact if you use only one tool for extract try whit another, perhaps the tools make something extrange into the file...

http://www.glbasic.com/forum/index.php?topic=5437.msg42569#msg42569

Don't worry always the first steps are bit confusing, but all works fine...

Offline fasasoftware

  • Mc. Print
  • *
  • Posts: 20
    • View Profile
I'm sorry but nothing works here.....I have tryed the zip  unzip...i have tryed the "chmod +x Macosx" but nothing works... or better  the app start ... but close unexpected...

Here below.. i show you the error that give me my apple mac g4...but i have 10.4.11 system...and a biprocessor upgraded by Maxpower..


Code: GLBasic [Select]
 

I thank you a lot in advance....

Best regards

Lestroso

www.fasasoftware.com

MrTAToad

  • Guest
What version of GLBasic are you using ?

Offline fasasoftware

  • Mc. Print
  • *
  • Posts: 20
    • View Profile
Hi MrTAToad,

i'm using the latest version downloaded few days ago the 10......i don't remeber exactly


i don't know what is the problem....

can you help me???

best regards,,

Lestroso