Author Topic: Raspberry Pi App-Store  (Read 4838 times)

Offline Asmodean

  • Mc. Print
  • *
  • Posts: 29
    • View Profile
Raspberry Pi App-Store
« on: 2012-Dec-18 »
There is a now an App-Store for the Raspberry Pi: The Pi Store.
http://www.raspberrypi.org/archives/2768

After GLBasic is now able to compile for the Raspberry Pi,  maybe it is interesting for someone.

MrTAToad

  • Guest
Re: Raspberry Pi App-Store
« Reply #1 on: 2012-Dec-18 »
Very nice - just hope its easier to submit to than the Ubuntu one!

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4185
    • View Profile
    • Portfolio
Re: Raspberry Pi App-Store
« Reply #2 on: 2012-Dec-18 »
Good! One more store to help up that month sales. :good:

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3366
  • Integrated Brain
    • View Profile
Re: Raspberry Pi App-Store
« Reply #3 on: 2012-Dec-18 »
The problem it's buy a raspberry, I think you buy and you don't know when arrives... I don't know if they have more in stock... but the interesting it's if they make a maket I think the cause it's they sold a lot of raspberry, and then can be a little market but efficiently economically

Offline Asmodean

  • Mc. Print
  • *
  • Posts: 29
    • View Profile
Re: Raspberry Pi App-Store
« Reply #4 on: 2012-Dec-18 »
The problem it's buy a raspberry, I think you buy and you don't know when arrives... I don't know if they have more in stock... but the interesting it's if they make a maket I think the cause it's they sold a lot of raspberry, and then can be a little market but efficiently economically

In Germany it's no problem to get one.  There are Online-Shops who have it in stock. 

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4144
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: Raspberry Pi App-Store
« Reply #5 on: 2012-Dec-18 »
In the UK you can purchase them in Maplins.

http://www.maplin.co.uk/raspberry-piandreg-board-and-starter-kit-652805

My local store has nine available in stock right now.
I came. I saw. I played.

Offline veketor

  • Mc. Print
  • *
  • Posts: 21
    • View Profile
Re: Raspberry Pi App-Store
« Reply #6 on: 2012-Dec-18 »
Has anyone tried to run something compiled with GLBasic v11 in a raspberry?
All that  I've tried does not show anything on the screen (black screen in full screen mode).
Console output displays problems with sdl 1.2 and vsync.
I have used raspbian, could be a dependency problem?
Note: the user that run the app belongs to video group.

MrTAToad

  • Guest
Re: Raspberry Pi App-Store
« Reply #7 on: 2012-Dec-19 »
Dont know what VSYNC is, but, assuming its like normal Linux, you need to install the SDL package.

Are you also using the latest GLBasic beta ?

Offline veketor

  • Mc. Print
  • *
  • Posts: 21
    • View Profile
Re: Raspberry Pi App-Store
« Reply #8 on: 2012-Dec-19 »
Hello Mr.Tatoad and thanks to try to help me. I have installed SDL (I had compiled some c code using this lib on this raspberry), but I´m unable to run glbasic compiled software  :'(.
The output log is:
Code: GLBasic [Select]
timer
rbow
rbow init
VSync unsupported on old SDL versions (before 1.2.10).sdl init video RaspberryPi
pi goes fullscreen 1920x1080
NativeEGLInfo = 1920x1080
800x480 sdl
get accurate timer - 1st call
flip - 1st call
BGRA ext supported
Texture size limit: 2048
init fbo
2D VP
OGRB init [OK]
Cptn
Network
Input
Window mode
Create DXin
sdl_grab
reptr
getexe
cd
exepath=curdir= /home/pi/Desktop/0000/atan.app
shoeboxing...
init gettimer
clear screen
flip
glGetError 0x501
...
 

The last line make me suspect that the error is related to opengl es.

The goog things: sound and network comands seems to work.

Thanks again

MrTAToad

  • Guest
Re: Raspberry Pi App-Store
« Reply #9 on: 2012-Dec-19 »
Yes, does look like it - its looks like some GL value is being passed incorrectly.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10697
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Raspberry Pi App-Store
« Reply #10 on: 2012-Dec-20 »
0x501 is gl_invalid_enum. Maybe I tried to glEnable something not available. Is Pi running?

Offline veketor

  • Mc. Print
  • *
  • Posts: 21
    • View Profile
Re: Raspberry Pi App-Store
« Reply #11 on: 2012-Dec-20 »
Kitty Hello thanks for your interest. I dont understand what you mean with "Is Pi Running?" (sorry, for my bad english).
I´m using raspbian hard-float, maybe i have to use a soft-float version???

Thanks again.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10697
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Raspberry Pi App-Store
« Reply #12 on: 2012-Dec-22 »
the glError 0x501 does not mean that the program will not run. Do you not see anything?
Does the program run on windows?

Offline veketor

  • Mc. Print
  • *
  • Posts: 21
    • View Profile
Re: Raspberry Pi App-Store
« Reply #13 on: 2012-Dec-22 »
I dont see anything, only a black screen. I have only try simple examples (GLBASIC/Samples folder) to test the speed of the raspberry with glbasic, some files that I have try are:

- Samples\Basics\atan.gbap --> no media conten, only uses drawline and screen test output.
- Samples\Media\SprColl.gbap --> uses media contents.
- Samples\Network\NetGetWeb\NetGetWeb.gbap --> like the others, do not show nothing on screen, but the network work, because download an html file.  :booze:
- Samples\Media\Playmusic.gbap --> black screen, but music sound  works great :good:
- Samples\3D\ObjectCreation\ObjectCreation.gbap --> goes to black screen, but automaticly close and output an error: GLB Error: 9 in console.

I have try to run all compiled files with and without x from LXTerminal without succes.
Maybe I do something wrong???

All the files work great in windows, and in the raspberry seems to work ok mouse and keyboard input, network and sound. The raspberry os is raspbian, updated to the last version.

When I compile in glbasic, is indiferent the output resolution and the fullscreen flag (Project Options in Raspberry_Pi mode), the compiled code always run in fullscreen. Maybe I have something wrong with my raspberry-os?? My raspberry is a old model-b (256 mb).

Thanks in advance and a happy christmas to all the forum members.

Offline matchy

  • Prof. Inline
  • *****
  • Posts: 1540
    • View Profile
Re: Raspberry Pi App-Store
« Reply #14 on: 2013-May-24 »
 :rtfm: Update note; GLB version 11.414 now only brings the error "VSync unsupported on old SDL versions (before 1.2.10).sdl init video RaspberryPi" for the GLB command RGB().