Author Topic: webOS Program test  (Read 4653 times)

MrTAToad

  • Guest
webOS Program test
« on: 2011-Apr-30 »
Could someone test this webOS program - its my UsefulCodeViewer program, and for some reason it crashes when a tab is pressed - for some unknown reason...

[attachment deleted by admin]

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: webOS Program test
« Reply #1 on: 2011-May-01 »
Silly question - how do I transfer the .IPK file to my Pre? Most of the instructions I've seen are for Linux and/or Mac.
I came. I saw. I played.

MrTAToad

  • Guest
Re: webOS Program test
« Reply #2 on: 2011-May-01 »
You can use either webOS Quick Install, or you could stick the IPK in a GLBasic directory and let the usual palm_install batch file (with the filename)...

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: webOS Program test
« Reply #3 on: 2011-May-01 »
Have you tried the WebOS Quick Install software yourself? Which version?
I came. I saw. I played.

MrTAToad

  • Guest
Re: webOS Program test
« Reply #4 on: 2011-May-01 »
No, I haven't tried it that - all the programs have been installed using the glb_pack_and_install routine :)

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: webOS Program test
« Reply #5 on: 2011-May-01 »
You're using the new beta aren't you? The batch file macro is different for that isn't it?

I use -
Code: GLBasic [Select]
CALL "%GLB_MAIN_PATH%\compiler\platform\webos\tool\bin\glb_pack_and_install.bat" "%GLB_PROJ_PATH%\glbwebos"
 

Are you using -
Code: GLBasic [Select]
CALL "%GLB_MAIN_PATH%\compiler\platform\webos\tool\bin\glb_pack_and_install.bat" "%GLB_PROJ_PATH%\%GLB_PROJ_NAME%.app"
 

the .IPK file obviously isn't an .app file, do you just change this to ".....PATH%\XXX.IPK"?
I came. I saw. I played.

MrTAToad

  • Guest
Re: webOS Program test
« Reply #6 on: 2011-May-01 »
You would need to comment out the packing bit :

Code: GLBasic [Select]
rem @ECHO OFF
rem CD /D "%~dp1"

rem ECHO Making .ipk Package from "%1"
rem call "%~dp0palm-package" "%1"

FOR %%i IN ("%~dp1*.ipk") DO (
        ECHO found package: "%%i"
        call "%~dp0palm-install" "%%i"
        break
)

PAUSE

to leave the installation routine.

The batch file I'm using calls it with :

Code: GLBasic [Select]
CALL "%GLB_MAIN_PATH%\compiler\platform\webos\tool\bin\glb_pack_and_install.bat" "%GLB_PROJ_PATH%\%GLB_PROJ_NAME%.app"

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: webOS Program test
« Reply #7 on: 2011-May-01 »
Cheers. I'll try and have a play  tomorrow (or later as it is now!).
I came. I saw. I played.

Offline Millerszone

  • Dr. Type
  • ****
  • Posts: 307
  • www.smashedfly.com
    • View Profile
    • Smashed Fly
Re: webOS Program test
« Reply #8 on: 2011-May-01 »
Yes, it crashes when you hit a tab button. Everything else seems to work o.k.
Tested with 1.4.5 and 2.2.1

I used WebOSQuick Install version 4.04 to Install ipk. can get here:
http://forums.precentral.net/canuck-coding/274461-webos-quick-install-v4-04-a.html
« Last Edit: 2011-May-01 by MillersZone »
Hardware: iMac 27", MacBook Air, PC 3.5Ghz Quad
Developing Tools: GLBasic SDK, Gideros Studio, PureBasic
Developing for: iOS, Android, Windows, OS X, webOS, HTML5

MrTAToad

  • Guest
Re: webOS Program test
« Reply #9 on: 2011-May-01 »

I dont know why its crashing - Spots with the beta & DDgui is okay.

I've included the code in case anyone can see the problem :)


[attachment deleted by admin]

MrTAToad

  • Guest
Re: webOS Program test
« Reply #10 on: 2011-May-01 »
Found the problem - I was adding a tab when it shouldn't have been...

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: webOS Program test
« Reply #11 on: 2011-May-01 »
Glad you found the problem. :)

I successfully installed the original .IPK, and can confirm that it crashes.
I came. I saw. I played.

MrTAToad

  • Guest
Re: webOS Program test
« Reply #12 on: 2011-May-01 »
Heh - The problem was easy to fix once I found it :)

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: webOS Program test
« Reply #13 on: 2011-May-01 »
Heh - The problem was easy to fix once I found it :)
Aren't they always! :D :P
I came. I saw. I played.

MrTAToad

  • Guest
Re: webOS Program test
« Reply #14 on: 2011-May-01 »
Very much so :)