BASIC

Author Topic: Ubuntu 10.04 LTS Lucid Lynx und AVM-USB Installieren..-nur wie?  (Read 1716 times)

Offline D2O

  • Prof. Inline
  • *****
  • Posts: 1062
    • View Profile
    • http://www.deuteriumoxid.com
Hallo alle,
bei mir sind nun 2x 1TB Platten für windows drin, und nun hatte ich eine 500er übrig.
Auf der habe ich nun Ubuntu Linux installiert.

Was recht einfach war :)

Aber, nun wollte ich die Netzwerkverbindung (WLan) einrichten, und hier haperts :(

Am Rechner ist ein AVM-Fritz USB-Stick drann, von AVM habe ich einen Linux Treiber (sagt man hier Treiber? ) heruntergeladen.
Der sollte mit SUSE und Ubuntu funktionieren.

Das ganze habe ich entpackt und sitzt nun im Linux System auf:
home/fabbio/Downloads/fritz

Laut anleitung soll ich in der Console (Terminal) in das verzeichnis wechseln und dort "./install " ausführen.
Das klapt soweit auch, nur bekomme ich dort Error meldungen  :rant:
und der Stick wird nicht installiert.

Da ich nun ein Absoluter Linux Idiot bin  =D weis ich nicht mal richtig unter was ich bei Ubuntu als Hilfe suche sollte  :-[

Aber vieleicht kann hier hier jemand weiter helfen.

Hier unten mal die Ausgabe vom Terminal:
Quote
fabbio@fabbio:~$ cd /home/fabbio/Downloads/fritz
fabbio@fabbio:~/Downloads/fritz$ ./install
make: Gehe in Verzeichnis '/home/fabbio/Downloads/fritz/src'
rm -f main.o driver.o tools.o lib.o buffers.o wext.o
rm -f fwlanusb.o fwlanusb.ko
make: Verlasse Verzeichnis '/home/fabbio/Downloads/fritz/src'
make: Gehe in Verzeichnis '/home/fabbio/Downloads/fritz/src'
make -C /lib/modules/2.6.32-21-generic/build SUBDIRS=/home/fabbio/Downloads/fritz/src modules
make[1]: Betrete Verzeichnis '/usr/src/linux-headers-2.6.32-21-generic'
  CC [M]  /home/fabbio/Downloads/fritz/src/main.o
In file included from /home/fabbio/Downloads/fritz/src/tools.h:30,
                 from /home/fabbio/Downloads/fritz/src/main.c:31:
/home/fabbio/Downloads/fritz/src/defs.h:63: error: redefinition of typedef ‘uintptr_t’
include/linux/types.h:41: note: previous declaration of ‘uintptr_t’ was here
make[2]: *** [/home/fabbio/Downloads/fritz/src/main.o] Fehler 1
make[1]: *** [_module_/home/fabbio/Downloads/fritz/src] Fehler 2
make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-2.6.32-21-generic'
make: *** [fwlanusb.o] Fehler 2
make: Verlasse Verzeichnis '/home/fabbio/Downloads/fritz/src'
make: Gehe in Verzeichnis '/home/fabbio/Downloads/fritz/src'
cp: Aufruf von stat für „fwlanusb.ko“ nicht möglich: No such file or directory
make: *** [install] Fehler 1
make: Verlasse Verzeichnis '/home/fabbio/Downloads/fritz/src'
fabbio@fabbio:~/Downloads/fritz$
I7 2600K; 8 GB RAM ; Win10 Pro x64 | NVidia GTX 750 TI 2048MB ; Realtec OnBoard Sound;
Lenovo ThinkPad T400: XP Pro
GLB Premium-immer Aktuell

Offline backslider

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 892
    • View Profile
Ui. Avm hat generell Probleme mit Linux...
zumindest war das mal so  :x

Offline Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5014
  • O Rly?
    • View Profile
Hast du schreibrechte gesetzt?

chmod oder chown...


Schau dir mal die Befehle an, ich kenn das halt nur vom Linuxserver :/

Sonst einfach Trucidare anschreiben, das ist'n alter Linuxjunkie :P
I <3 DGArray's :D

PC:
AMD RYzen 7 1700 @3.9Ghz, 16GB HyperX Fury 2666Mhz Ram, ASUS ROG GTX 1060 STRIX 6GB, Windows 10 Pro 64Bit, MSi Tomahawk B350 Mainboard

Offline trucidare

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1377
  • Bachelor of Fail
    • View Profile
ihr seid mir vielleicht ein paar programmierer :D
geh in die defs datei und kommentier das typedef aus speichern und gut is.
MacBook Pro 2,2 GHz Core 2 Duo, 4 GB RAM, 160 GB HDD, 8600M GT
Core i3 - 3,07 GHz, 8 GB Ram, 2.5 TB HDD, Geforce GTX 260+ OC

Offline D2O

  • Prof. Inline
  • *****
  • Posts: 1062
    • View Profile
    • http://www.deuteriumoxid.com
Hi alle, erstmal vielen Dank  :booze:

Jo, ich habe das mal auskommentiert.

Jetzt hagelts andere Fehler in die richtung "Kann fwlanusb.o nich finden"

Hier steigt bei mir der Frust Pur auf  :rant:

Sorry liebes Linux, hier wird es einsteigern nicht leicht gemacht.
Auch wenn ich extra Ubuntu genommen habe, das eigendlich Einsteiger freundlich sein sollte.
Wenn ich hier aber schon Problemme bekomme ein Wlan einzurichten damit ich zugriff auf die anderen Resourcen bekomme
damit ich auch den Rest an Treibern in das OS bekommen, dann bricht mir hier der Angstschweis aus.

Ich werde es am WE nochmals in Ruhe Probieren,
klapt es dann wieder nicht.... ist Linux für mich mal wieder in den nächsten Jahren gestorben.

Um es nicht ganz auf zu geben, versuche ich es mal in MS VirtualPC zu installieren.
I7 2600K; 8 GB RAM ; Win10 Pro x64 | NVidia GTX 750 TI 2048MB ; Realtec OnBoard Sound;
Lenovo ThinkPad T400: XP Pro
GLB Premium-immer Aktuell

Offline trucidare

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1377
  • Bachelor of Fail
    • View Profile
wenn er .o nich finden kann wurde .o nicht erstellt, .o wird erstellt wenn .c / .cpp erfolgreich kompiliert wurden.
also such nach den fehlern davor, können ja nicht so viele sein, denn nur 1 typedef error versaut dir nich die ganze lib.
MacBook Pro 2,2 GHz Core 2 Duo, 4 GB RAM, 160 GB HDD, 8600M GT
Core i3 - 3,07 GHz, 8 GB Ram, 2.5 TB HDD, Geforce GTX 260+ OC

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10697
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Auf VirtualPC hast mit Ubuntu keinen Spaß. Da musst evtl. manuell die xorg.conf anpassen und auf 16 bit Farbtiefe stellen. Aber probier's mal.