BASIC

Author Topic: Can not start GlBasic  (Read 2555 times)

Offline Stu_C

  • Mc. Print
  • *
  • Posts: 34
    • View Profile
    • OvineByDesign
Can not start GlBasic
« on: 2009-Nov-18 »
hmmmm glbasic has stopped loading with the

"application has failed to start because the application configuration is incorrect...."

last time I saw that was todo with the "vcredist_x86.exe" having to be updated.

ive uninstalled, installed, cleaned the registry - still not working...

Any ideas ?


Offline Quentin

  • Prof. Inline
  • *****
  • Posts: 915
    • View Profile
Re: Can not start GlBasic
« Reply #1 on: 2009-Nov-18 »
with which version you're working?
perhaps its worth to download the newest version and install again.

MrTAToad

  • Guest
Re: Can not start GlBasic
« Reply #2 on: 2009-Nov-18 »
The latest download has the redist in it, or the redist mentioned in the bugs report will do

Offline Stu_C

  • Mc. Print
  • *
  • Posts: 34
    • View Profile
    • OvineByDesign
Re: Can not start GlBasic
« Reply #3 on: 2009-Nov-19 »

Ive downloaded the most recent - Ive even deleted all the registry keys ( so should be running as the demo version )

The redist has been installed (several times)


MrTAToad

  • Guest
Re: Can not start GlBasic
« Reply #4 on: 2009-Nov-19 »

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10697
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Can not start GlBasic
« Reply #5 on: 2009-Nov-19 »
oh dear. What OS is that? Did you do some windos update from MS that broke it?
 :rant:

Offline Stu_C

  • Mc. Print
  • *
  • Posts: 34
    • View Profile
    • OvineByDesign
Re: Can not start GlBasic
« Reply #6 on: 2009-Nov-20 »

Windows XP, - no I have my updates turned off.......


Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10697
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Can not start GlBasic
« Reply #7 on: 2009-Nov-20 »
Very weird. Does this help:
http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5FC2&displaylang=en

It's strange, because the current setup works on XP SP3.

Offline Stu_C

  • Mc. Print
  • *
  • Posts: 34
    • View Profile
    • OvineByDesign
Re: Can not start GlBasic
« Reply #8 on: 2009-Nov-24 »

Still the same error. Dammm stupid computers....


Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10697
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Can not start GlBasic
« Reply #9 on: 2009-Nov-24 »
http://www.dependencywalker.com/
Can you try this on the Editor_e.exe, please?

Offline yoxola

  • Community Developer
  • Mr. Drawsprite
  • ******
  • Posts: 55
    • View Profile
Re: Can not start GlBasic
« Reply #10 on: 2009-Nov-24 »
Hi, Gernot

How about statically linking MSVCRT with the EXE to prevent similar issues?
Only a few changes required in compiler setting...

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10697
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Can not start GlBasic
« Reply #11 on: 2009-Nov-25 »
That gives problems with multilang common dialogs then. It's a true shame that MS changed the MFC dlls to a SxS version. Total shit.

Offline yoxola

  • Community Developer
  • Mr. Drawsprite
  • ******
  • Posts: 55
    • View Profile
Re: Can not start GlBasic
« Reply #12 on: 2009-Nov-27 »
Anyway to make it use private assemblies?

Info:
http://www.codeproject.com/KB/cpp/PrivateAssemblyProjects.aspx?display=Print

However I can't make it work, I think I might miss some steps etc.

MrTAToad

  • Guest
Re: Can not start GlBasic
« Reply #13 on: 2009-Nov-27 »
Are you using the 64-bit version of XP ?