BASIC

Author Topic: API targetsdk  (Read 538 times)

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1347
    • View Profile
API targetsdk
« on: 2018-Jun-01 »
Hi Guys

Gernot advised me to just change the target api value from 22 to 26 in line with new playstore requirements...
I Googled around and lots of other frameworks are using the same approach until they can get proper fixes in place.

On change for one app I immediately got lots of unsatified link errors...perhaps one of you had issues with this before and know a fix...

  at java.lang.Runtime.loadLibrary0 (Runtime.java:977)
  at java.lang.System.loadLibrary (System.java:1530)
  at org.libsdl.app.SDLActivity.<clinit> (SDLActivity.java:235)
  at java.lang.Class.newInstance (Native Method)
  at android.app.Instrumentation.newActivity (Instrumentation.java:1079)
  at android.app.ActivityThread.performLaunchActivity (ActivityThread.java:2616)
  at android.app.ActivityThread.handleLaunchActivity (ActivityThread.java:2785)
  at android.app.ActivityThread.-wrap12 (ActivityThread.java)
  at android.app.ActivityThread$H.handleMessage (ActivityThread.java:1532)
  at android.os.Handler.dispatchMessage (Handler.java:102)
  at android.os.Looper.loop (Looper.java:163)
  at android.app.ActivityThread.main (ActivityThread.java:6342)
  at java.lang.reflect.Method.invoke (Native Method)
  at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run (ZygoteInit.java:880)
  at com.android.internal.os.ZygoteInit.main (ZygoteInit.java:770)


Offending line in SDLacitivty seems to be....

        System.loadLibrary("main");

« Last Edit: 2018-Jun-01 by MrPlow »
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3493
    • View Profile
    • Space Fractal
Re: API targetsdk
« Reply #1 on: 2018-Jun-01 »
you need to have the api installed as well. otherwise its wont do that.

Android Extras only have API-22 SDK installed, which can been one of the reason.

Alternative, try to clean all files from the distribte folder and let glbasic recreate it again (dont forget to backup the xml file trought).

Im do pretty sure, soon its possible to get the newest SDK installed in its normal place, then its would not been a issue at all.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1347
    • View Profile
Re: API targetsdk
« Reply #2 on: 2018-Jun-01 »
If I install api -23 SDK will it work with GLB?

I will try your suggestion of the cleanout. thanks!
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3493
    • View Profile
    • Space Fractal
Re: API targetsdk
« Reply #3 on: 2018-Jun-02 »
but property you might not will get admob working. Im could not get it to working with newer api. The SDK Manager is also no longer working here at all. So im cannot testing at all currectly.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1347
    • View Profile
Re: API targetsdk
« Reply #4 on: 2018-Jun-05 »
No, my Admob is working perfectly for all my apps....and even for apps I updated to api-23 :)

I am using play services version 7895000 (7.8 )

Perhaps you have not tried with that one...I did get crashing on older 4.x versions but not on 7.8
(I simply dropped it in over the 4.x version and updated the manifest android:value="7895000" ... worked like a charm!)

:)

Also my crash stats have "improved!" greatly after making some recent small changes - :)

So for GLB is working fine and perfect on Android and my Admob is working perfect and earning money for API-22 compiles and even api-23 compiles (only recently).


Also, the api-26 crashes disappeared after I reduced back down to api-23 - but I also removed the lcutils parameter from compiling.




« Last Edit: 2018-Jun-05 by MrPlow »
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs