BASIC

Author Topic: Soundplaying  (Read 2447 times)

Offline Vampire

  • Mr. Polyvector
  • ***
  • Posts: 193
    • View Profile
Soundplaying
« on: 2015-Mar-28 »
Hallo Leute :)
Nach einigen Jahren melde ich mich mal wieder  :)
Okay,
Ich möchte 2 Sounds nacheinander abspielen, war früher auch nie ein Problem.
Jetzt klappt gar nichts mehr.
Weil das so ist, habe ich mir Gernots Beispiel aus der Hilfe kopiert, aber das läuft auch nicht^^
Was ist zutun?
Hier der Code mit Fehlermeldung:

Code: GLBasic [Select]
SETCURRENTDIR("Media") // go to media files
SETSCREEN 1366,785,0
LOADSOUND "Storm coming.wav",0,1

ch = PLAYSOUND(0, 1,0)
WHILE SOUNDPLAYING(ch)
   PRINT "Playing...", 100,100
    SHOWSCREEN
WEND
PRINT "Stop!", 100, 100
SHOWSCREEN
MOUSEWAIT
 

Code: GLBasic [Select]
----------------------------------------------------------------------------------------------
*** Configuration: WIN32 ***
precompiling:
GPC - GLBasic Precompiler V.9.829 SN:4ef5cdbf - 2D, WIN32
"VideoAnfang.gbas"(17) error : variable is not explicitly defined : ch
 

« Last Edit: 2015-Mar-29 by Schranz0r »

Offline Worebu

  • Mr. Polyvector
  • ***
  • Posts: 169
  • Moin, Moin
    • View Profile
Re: Soundplaying
« Reply #1 on: 2015-Mar-28 »
Hi, hast du unter Projektoptionen die EXPLIZITE DEKLARATIONEN abgeschaltet?, oder die VAR ch deklarieren.
« Last Edit: 2015-Mar-28 by Worebu »
PC: Intel I7 3770K, 32GB DDR3, GTX1060 6GB,  480GB SSD, 1x2TB, 1x1TB, 2x ext. 1TB USB3.0, 1x ext. 2TB USB3.0, W10 x64 Pro, WaKü

Offline Vampire

  • Mr. Polyvector
  • ***
  • Posts: 193
    • View Profile
Re: Soundplaying
« Reply #2 on: 2015-Mar-28 »
aaah, das wirds wohl sein. :)
Nee, hab nix abgeschaltet und auch nix deklariert.
Bin jetzt sicher, dass ich es hinkriege, wenn nicht, komm ich wieder^^

Danke für deine Antwort :)

Offline BumbleBee

  • Global Moderator
  • Prof. Inline
  • *******
  • Posts: 891
    • View Profile
Re: Soundplaying
« Reply #3 on: 2015-Mar-28 »
 :offtopic:
Hallo Vampire
Schön mal wieder was von dir zu hören. Wo warst du solange? Hast du das Forum nicht mehr gefunden? :D Arbeitest du gerade an einem Projekt und das Wichtigste: Zockst du eigentlich noch WoW?  =D Ja, das waren noch Zeiten, gelle   =D
 
Cheers
The day will come...

CPU Intel(R) Core(TM) i5-3570k, 3.4GHz, AMD Radeon 7800 , 8 GB RAM, Windows 10 Home 64Bit

Offline Vampire

  • Mr. Polyvector
  • ***
  • Posts: 193
    • View Profile
Re: Soundplaying
« Reply #4 on: 2015-Mar-29 »
Hallo BumbleBee  =D
Ja, ich arbeite an einem Projekt, aber an einem Video.
Ich habe geplant, ein paar coole Grafiktricks da einzubauen und Glbasic bietet sich da an^^
Ist aber alles viel schwerer als ich mir das vorgestellt habe, mal schauen was daraus wird  :)

Nee, zur Zeit spiele ich nicht mehr WoW, WoD gefällt mir gar nicht. Ich frage mich wirklich, was sich
Blizzard bei dem Scheiss gedacht hat  ;/
Das Game ist ruiniert...so sehe ich das jedenfalls.
Ist aber durchaus möglich, dass ich wieder anfange, wenn sich was ändert.

Ich arbeite an 2 Homepages... wieder mal^^. Auf einer meiner Seiten und auf Youtube wird das Video zu sehen sein. das muss supergeil werden!
Okay, das wars in aller Kürze.
Freu mich, dass du dich gemeldet hast  =D

Offline Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5006
  • O Rly?
    • View Profile
Re: Soundplaying
« Reply #5 on: 2015-Mar-29 »
YouTube-link bitte :)
I <3 DGArray's :D

PC:
AMD RYzen 7 1700 @3.9Ghz, 16GB HyperX Fury 2666Mhz Ram, ASUS ROG GTX 1060 STRIX 6GB, Windows 10 Pro 64Bit, MSi Tomahawk B350 Mainboard

Offline Vampire

  • Mr. Polyvector
  • ***
  • Posts: 193
    • View Profile
Re: Soundplaying
« Reply #6 on: 2015-Mar-29 »
Hallo :)
Der Link zum Video kommt bestimmt, aber dafür muss das Video ja erstmal fertig werden^^