Author Topic: Ein Absturz, den man im debug modus nicht reproduzieren kann  (Read 1816 times)

Offline nabz32

  • Community Developer
  • Dr. Type
  • ******
  • Posts: 307
    • View Profile
hallo,

bei Abstürzen aller Art habe ich bis jetzt immer mit dem Debugger die entsprechende Stelle eingrenzen können,
diesmal habe ich einen schwer zu findenden Absturz, der aber mysteriöser Weise nicht im
debug Modus auftritt.

Hat jemand von euch schon einen crash gehabt der im debug modus nicht auftrat?

Online Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5020
  • O Rly?
    • View Profile
I <3 DGArray's :D

PC:
AMD RYzen 7 1700 @3.9Ghz, 16GB HyperX Fury 2666Mhz Ram, ASUS ROG GTX 1060 STRIX 6GB, Windows 10 Pro 64Bit, MSi Tomahawk B350 Mainboard

Offline nabz32

  • Community Developer
  • Dr. Type
  • ******
  • Posts: 307
    • View Profile
Habe etwas den code modifiziert, ein paar letzte feinheiten einer frischen Implementierung verbessert
und damit scheinbar auch die Quelle des Absturzes mit behoben.

Glück gehabt, konnte mir nämlich nichts auf den Absturz zusammenreimen.

Offline nabz32

  • Community Developer
  • Dr. Type
  • ******
  • Posts: 307
    • View Profile
schon wieder diesen crash gehabt.
Habe es nun auf eine objekt picking routine eingegrenzt.
Scheinbar hat irgendetwas mit screen2world / x_collisionray nicht funktioniert.

Online Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5020
  • O Rly?
    • View Profile
 :puke:
Wow, evtl. kann dir Gernot was dazu sagen?
Tief in meinen Erinnerungen, meine ich doch mal irgendwie zumindest mal kurz sowas gehabt zu haben.....
I <3 DGArray's :D

PC:
AMD RYzen 7 1700 @3.9Ghz, 16GB HyperX Fury 2666Mhz Ram, ASUS ROG GTX 1060 STRIX 6GB, Windows 10 Pro 64Bit, MSi Tomahawk B350 Mainboard