BASIC

Author Topic: Update  (Read 45181 times)

Offline caffeinekid

  • Mr. Drawsprite
  • **
  • Posts: 51
    • View Profile
    • TCKSOFT
Re: Update
« Reply #45 on: 2011-Oct-31 »
I try to update and it says I'm already using the latest version. Is today's update not live yet?

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
Re: Update
« Reply #46 on: 2011-Oct-31 »
Is another update online? Now I've tried to update and GLBasic Update Manager crashes just after downloading part. :\

Same here.

Same here too

Offline Ruidesco

  • Mr. Polyvector
  • ***
  • Posts: 236
    • View Profile
Re: Update
« Reply #47 on: 2011-Oct-31 »
I try to update and it says I'm already using the latest version. Is today's update not live yet?
+1

Offline Crivens

  • Prof. Inline
  • *****
  • Posts: 913
    • View Profile
Re: Update
« Reply #48 on: 2011-Oct-31 »
On a side note since the last update using build-multiplatform it no longers remembers the last device for compile. I thought it was just a highlight thing but compiling doesn't work correctly.

Cheers
Current fave quote: Cause you like musicians and I like people with boobs.

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10683
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Update
« Reply #49 on: 2011-Oct-31 »
My fault. 10.158 online now.

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
Re: Update
« Reply #50 on: 2011-Oct-31 »
all right, now  :good:

Offline Hatonastick

  • Dr. Type
  • ****
  • Posts: 474
  • Amstrad CPC 6128
    • View Profile
Re: Update
« Reply #51 on: 2011-Nov-01 »
Wow...  Mate it works brilliantly.  Just ran the 3D Shadows demo on it and I swear it's up around 30FPS and displays every bit (well close enough) as well as it does on my desktop.  Thanks!

What was the issue with GRABSPRITE btw?
Mat. 5: 14 - 16

Android: Toshiba Thrive Tablet (3.2), Samsung Galaxy Tab 2 (4.1.2).
Netbook: Samsung N150+ Netbook (Win 7 32-bit + Ubuntu 11.10).
Desktop: Intel i5 Desktop with NVIDIA GeForce GTX 460 (Win 8.1 64-bit).

Offline Mikele

  • Mc. Print
  • *
  • Posts: 28
    • View Profile
Re: Update
« Reply #52 on: 2011-Nov-01 »
Great! Now my all programs work on Android again! Thank you!

M.

Offline Qube

  • Mr. Polyvector
  • ***
  • Posts: 157
    • View Profile
Re: Update - Oh No!
« Reply #53 on: 2011-Nov-01 »
Gernot, since updates after 10.118 alpha is a tad broken using polyvector (2D on top of 3D) :S - It leaves funky coloured edges. If needed I can post example images of this issue but it may be a couple of days. Just wanted to bring that to your attention :)

Offline Qube

  • Mr. Polyvector
  • ***
  • Posts: 157
    • View Profile
Re: Update
« Reply #54 on: 2011-Nov-01 »
Quote
Qube, on what platform did you observe this?  On Windows I do exactly that with one of my apps.  I noticed nothing of what you describe.

Windows & iOS.

To replicate the issue (will post example when I have time) :

1.. Draw a dark yellow (or blue, red etc) circle in your favourite image editor (must be antialiased and 50% opacity)
2.. In GLB have a simple 3D skybox (darker the better)
3.. switch to 2D and using POLYVECTOR draw that circle on the screen at different random location. You'll notice that it's not perfect as pre 10.118 versions were.

LOL, having read that back it seems a little overkill to show something broken so I'll whip up an example with screen shots later :)   

MrTAToad

  • Guest
Re: Update
« Reply #55 on: 2011-Nov-01 »
Are you using SMOOTHSHADING ?

Offline Qube

  • Mr. Polyvector
  • ***
  • Posts: 157
    • View Profile
Re: Update
« Reply #56 on: 2011-Nov-01 »
Are you using SMOOTHSHADING ?

Yes :)

I'll have to whip up a simple example and post on here with screenshots of older version vs latest version of GLB. It's hard to explain and may not be easy to spot unless you've been staring at the same images for months on end which is the only reason I spotted it.

Offline Qube

  • Mr. Polyvector
  • ***
  • Posts: 157
    • View Profile
Re: Update - Weird stuff going on.
« Reply #57 on: 2011-Nov-01 »
No example code yet as I'm not posting the source for Galaxix, lol. Have a nosy at the image below taken with GLB 10.118 and the latest 10.159 (10.156 also did the same).

You have to look carefully and this is probably why it would be easily missed if it wasn't for the fact I've seen seen nothing but these images, every day for months now :S - One last buggette of 10.159 is that saveBMP appears to freak out my Windows 7 and 90% of the time crashes  :noggin:

Look closely now  =D


Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10683
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
Re: Update
« Reply #58 on: 2011-Nov-02 »
totally strange. As if the coordinated were off by 1 pixel or so?

Offline Qube

  • Mr. Polyvector
  • ***
  • Posts: 157
    • View Profile
Re: Update
« Reply #59 on: 2011-Nov-02 »
Quote
totally strange. As if the coordinated were off by 1 pixel or so?

It is a strange one. Luckily no major show stopper or anything you'd really notice if you weren't familiar down to the pixel level, lol.

My first thought when coming across it was reading in the changelog that some changes were made to the z-buffer / RGBA? - It says for Android but?

Obviously I can't ever code in GLB again until this show stopping issue has been fixed and I shall have to post daily complaints and all that  :nana: