Author Topic: Android - V10 release candidate  (Read 83611 times)

Offline ampos

  • Prof. Inline
  • *****
  • Posts: 1594
    • View Profile
    • AMpostata Website
Re: Android - Beta SDK
« Reply #60 on: 2011-Apr-26 »
Be afraid my friends, of the day I got an Android...  >:D
check my web and/or my blog :D
http://diniplay.blogspot.com (devblog)
http://www.ampostata.org
http://ampostata.blogspot.com
I own PC-Win, MacBook 13", iPhone 3G/3GS/4G and iPAC-WinCE

Offline matty47

  • Mr. Drawsprite
  • **
  • Posts: 69
    • View Profile
    • Matt and Marg's Homesite
Re: Android - Beta SDK
« Reply #61 on: 2011-Apr-26 »
OK tried with the ANDROID_SWT variable set however same error. Message says something about not being able to start the java VM and dex failing (same as quoted previously)
Thanks
Matthew

MrTAToad

  • Guest
Re: Android - Beta SDK
« Reply #62 on: 2011-Apr-26 »
Have a look at this : http://ycsoftware.net/error-occurred-during-initialization-of-vm-windows-7-windows-xp/

They seem to be saying that the Java Virtual Machine is corrupt...

This one http://geekycoder.wordpress.com/2009/07/08/java-tips-adventure-in-resolving-the-java-error-error-occurred-during-initialization-of-vm/ states that are there duplicate java.exe files, with the wrong one being found (and used).

Would also be worth checking JAVA_HOME and PATH too...

Quote
Be afraid my friends, of the day I got an Android...
We'll be on holiday when you do!
« Last Edit: 2011-Apr-26 by MrTAToad »

Offline BigAnd

  • Mc. Print
  • *
  • Posts: 44
    • View Profile
Re: Android - Beta SDK
« Reply #63 on: 2011-Apr-26 »
I get:

BUILDSRIPT
Buildfile: build.xml does not exist!
Build failed

The build.xml is where it should be and there are no spaces or funny characters to that directory.

Does it matter that GLBasic_beta is in my "Program Files (x86)" directory?

I know my Android SDK works as I have used it from Eclipse and another basic.

MrTAToad

  • Guest
Re: Android - Beta SDK
« Reply #64 on: 2011-Apr-26 »
That should be fine.

My installations are at :

C:\Program Files (x86)\GLBasic
C:\Android
C:\Program Files (x86)\Java\jdk1.6.0_25

Perhaps there are spaces in your GLBasic project directory ?

Offline BigAnd

  • Mc. Print
  • *
  • Posts: 44
    • View Profile
Re: Android - Beta SDK
« Reply #65 on: 2011-Apr-26 »
No, no spaces to the project file but thanks for asking.

Will try moving the other bits around and see if it helps.

MrTAToad

  • Guest
Re: Android - Beta SDK
« Reply #66 on: 2011-Apr-26 »
Are you using a new or current project ?

Offline doimus

  • Dr. Type
  • ****
  • Posts: 284
    • View Profile
Re: Android - Beta SDK
« Reply #67 on: 2011-Apr-26 »
I can't yet compile for Android... but in the meantime, I've got one very strange issue with this beta.

Compiled Windows executables crash immediately after starting!  :blink:

I'm using WinXP in VirtualBox.
Those exes run fine in non-virtual Windows and in OSX.
Executables from non-beta GLB in VirtualBox are OK too.
« Last Edit: 2011-Apr-26 by doimus »

MrTAToad

  • Guest
Re: Android - Beta SDK
« Reply #68 on: 2011-Apr-26 »
Could it be a driver issue?

Offline mentalthink

  • Prof. Inline
  • *****
  • Posts: 3365
  • Integrated Brain
    • View Profile
Re: Android - Beta SDK
« Reply #69 on: 2011-Apr-26 »
Well for my works all OK, on windows 7 x64.
Well the emulator works, but it´s very very slow, running the android OS under virtual Box, is very fast the S.O, but I don´t know how send the .apk file into android under Virtual BOX.
Any link, or suggestion for made this?¿. Seems in Virtual Machine the OS, runs very very fast.

Kinds Regards
Iván J.

MrTAToad

  • Guest
Re: Android - Beta SDK
« Reply #70 on: 2011-Apr-26 »
My Windows executable crashed straight away in VM 4 :

*** Unhandled exception ***
   EXCEPTION_ACCESS_VIOLATION
 :S


Offline BigAnd

  • Mc. Print
  • *
  • Posts: 44
    • View Profile
Re: Android - Beta SDK
« Reply #71 on: 2011-Apr-27 »
@MrTAToad

Yeah, its a new project. I have tried moving things around also but still no joy. Will keep messing though.

Got it working by moving my source to the C drive from D.

Things I have noticed:
The accelerometer works in reverse for left, right and up, down from the iPhone.
The multi-touch doesn't work. It only sees the first touch.
MP3 music didn't play but WAV sound fx are fine (as noted above I believe).

Amazed that it worked as well as it did with zero code changes.
« Last Edit: 2011-Apr-27 by BigAnd »

MrTAToad

  • Guest
Re: Android - Beta SDK
« Reply #72 on: 2011-Apr-27 »
Indeed - what's left to do isn't that much really.

The compiler can't handle TRY/CATCH/THROW unfortunately - hopefully that will be sorted, otherwise I'll be needing to change a bit of code :)

Offline Dabz

  • Mr. Polyvector
  • ***
  • Posts: 104
    • View Profile
    • BambooCoder
Re: Android - Beta SDK
« Reply #73 on: 2011-Apr-27 »
Quote
MP3 music didn't play but WAV sound fx are fine (as noted above I believe).

I've had a report back from my test build of Nags that I've distributed that sound (PlaySound) doesnt work on LG Optimus One phones.... Their probably the best reasonably priced half decent ones you can get I think, which, I think will make them popular.

Also, is there a chance the two media volume control keys at the edge of devices can be mapped, or if they are, what do they fall under?

Dabz
« Last Edit: 2011-Apr-27 by Dabz »

MrTAToad

  • Guest
Re: Android - Beta SDK
« Reply #74 on: 2011-Apr-28 »
One thing I have found is that the keyboard has been completely disabled after exiting a Windows debug program.  Had to log off and then back on again to get it working...