Author Topic: MinGW GLBasic, gehen beide zusammen nicht :(  (Read 1705 times)

Offline D2O

  • Prof. Inline
  • *****
  • Posts: 1063
    • View Profile
    • http://www.deuteriumoxid.com
Hi, ich dachte das das behoben ist.
Nun, ich habe mir zusätzlich minigw installiert, damit das ander programm es auch findet
habe ich auch die umgebungsvariablen eingegeben.

GLB macht aber jetzt mucken, es lässt sich nichts mehr kompilieren.
Alleine das löschen der umgebungsvariablen hat nichts geholfen, musste minigw komplett wieder deinstallieren,
erst jetzt funktioniert GLB wieder tadellos.

Wie kann ich das problem umgehen?
I7 2600K; 8 GB RAM ; Win10 Pro x64 | NVidia GTX 750 TI 2048MB ; Realtec OnBoard Sound;
Lenovo ThinkPad T400: XP Pro
GLB Premium-immer Aktuell

Offline AndyH

  • Dr. Type
  • ****
  • Posts: 383
    • View Profile
    • http://www.ovine.net/
MinGW GLBasic, gehen beide zusammen nicht :(
« Reply #1 on: 2008-Jan-26 »
Das Update für MinGW bei mir nicht funktioniert. Ich habe den Namen des MinGW-Ordner während der Arbeit mit der GLB.

Offline Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5021
  • O Rly?
    • View Profile
MinGW GLBasic, gehen beide zusammen nicht :(
« Reply #2 on: 2008-Jan-26 »
Ohhh... Google Translate?
I <3 DGArray's :D

PC:
AMD Ryzen 7 1700 @3.9GHz, 16GB HyperX Fury 3000MHz Ram, ASUS ROG GTX 1060 STRIX 6GB, Windows 10 Pro 64Bit, MSi Tomahawk B350 Mainboard

Offline D2O

  • Prof. Inline
  • *****
  • Posts: 1063
    • View Profile
    • http://www.deuteriumoxid.com
MinGW GLBasic, gehen beide zusammen nicht :(
« Reply #3 on: 2008-Jan-26 »
Jepp, aber mein English wird auch nicht besser sein ;)

Aber ich denke er meint, das wen ich GLB nutze, denn Ordner "MinGW" der weil umbenennen soll.
I7 2600K; 8 GB RAM ; Win10 Pro x64 | NVidia GTX 750 TI 2048MB ; Realtec OnBoard Sound;
Lenovo ThinkPad T400: XP Pro
GLB Premium-immer Aktuell

Offline Schranz0r

  • Premium User :)
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 5021
  • O Rly?
    • View Profile
MinGW GLBasic, gehen beide zusammen nicht :(
« Reply #4 on: 2008-Jan-26 »
japp hatter im Englischen Forum schon geschrieben :D
I <3 DGArray's :D

PC:
AMD Ryzen 7 1700 @3.9GHz, 16GB HyperX Fury 3000MHz Ram, ASUS ROG GTX 1060 STRIX 6GB, Windows 10 Pro 64Bit, MSi Tomahawk B350 Mainboard

Offline Kitty Hello

  • code monkey
  • Administrator
  • Prof. Inline
  • *******
  • Posts: 10713
  • here on my island the sea says 'hello'
    • View Profile
    • http://www.glbasic.com
MinGW GLBasic, gehen beide zusammen nicht :(
« Reply #5 on: 2008-Jan-27 »
mann, was ist denn bei mingw noch alles. Wo bekomme ich so ein MingW Paket?

Offline D2O

  • Prof. Inline
  • *****
  • Posts: 1063
    • View Profile
    • http://www.deuteriumoxid.com
MinGW GLBasic, gehen beide zusammen nicht :(
« Reply #6 on: 2008-Jan-27 »
Hi Gernot,
das MinGW habe ich von hier,
http://sourceforge.net/project/downloading.php?group_id=2435&use_mirror=jaist&filename=MinGW-5.1.3.exe&2597933

Im moment habe ich es zum laufen gebracht, für meine bedürfnisse halt.


MinGW nicht in den Standart Ordner installiert sonder in ..Basic\MinGW.
Die Systemvariablen auch so angepasst.

Dann Neuen Ordner im Root erstellt als C:\MinGW , hier habe ich nur die Ordner "Include" und "lib" hinein kopiert.
Keine ahnung warum, aber der Kompiller sucht die Header und Objekt files immer in c:\MinGW :(

Dann gibts da eine Datei die nicht so recht will, bzw. für die Fehlermeldung verantwortlich zu sein scheint.
Im Ordner "lib" gibts die "CRT2.O" datei.
Die habe ich um benannt.
Und nun geht alles :)
Ich kann GLB nutzen und Bmax auch.
I7 2600K; 8 GB RAM ; Win10 Pro x64 | NVidia GTX 750 TI 2048MB ; Realtec OnBoard Sound;
Lenovo ThinkPad T400: XP Pro
GLB Premium-immer Aktuell