BASIC

Author Topic: star 01  (Read 4932 times)

Bugman

  • Guest
star 01
« on: 2007-Nov-26 »
Hi
Das erste Spiel ist eigentlich schon fertig.
Ein kleiner Sidescroller.(Code liegt bei)
#http://www.zshare.net/download/51672397ffeaed/#
Bitte die neue version laden!!!!!( Jetzt weiter runter Scrollen)

Erwartet nicht zuviel hat auch nicht lange gedauert.(habe die Vollversion seit gestern)
Das meiste war eigentlich nur ausloten was alles funktioniert.
Jeder neue Level macht die Kometen schneller und zahlreicher.
 
P.S. Es scheint mir als ob unter OSX 10.5.1 keine bin's mehr laufen.
(mit 10.5.0 hat es noch funktioniert)

Offline D2O

  • Prof. Inline
  • *****
  • Posts: 1061
    • View Profile
    • http://www.deuteriumoxid.com
star 01
« Reply #1 on: 2007-Nov-26 »
Moin Bugman,

:) :) Sound von JBO :)  hab ich schon lange nicht mehr gehört, cool.
Game läuft gut, kleiner hinweis das im Splashscreen die Taste "Space" gedrückt werden muss, wär nicht schlecht.
Ich hab erstmal gewartet und gewartet ;)

Noch was zu GOTO, das funktioniert zwar, aber lass es weg, mit der zeit wird so ein Code unübersichtlich(Spagetticode)
Ansonsten Top für das erste Game.

Freu mich schon auf mehr.

Dann noch eine Frage:
Bei mir wird immer der Mouscursor angezeigt, habe schon probiert ihn mit "Systempointer" abzuschalten, geht aber nicht.
Bei mir ist es der Standart Cursor von Vista, und zwar der Ring der sich dreht wenn etws geladen wird?
I7 2600K; 8 GB RAM ; Win10 Pro x64 | NVidia GTX 750 TI 2048MB ; Realtec OnBoard Sound;
Lenovo ThinkPad T400: XP Pro
GLB Premium-immer Aktuell

Offline Quentin

  • Prof. Inline
  • *****
  • Posts: 915
    • View Profile
star 01
« Reply #2 on: 2007-Nov-26 »
hehe lustiger Sound, gefällt mir.
Unter XP wird der Ladecursor auch dargestellt.
Normalerweise kann man das mit SYSTEMPOINTER und einem Dummy-Aufruf von MOUSESTATE

Code: GLBasic [Select]
  SYSTEMPOINTER FALSE
  MOUSESTATE mx, my, b1,b2
abschalten, hat hier aber auch nicht geklappt. Hmmm

Bugman

  • Guest
star 01
« Reply #3 on: 2007-Nov-26 »
Moin
Ja das mit dem Cursor ist mir auch schon aufgefallen.
Seltsamerweise was der glaube ich nicht immer da.

Tiptiptip.....
  SYSTEMPOINTER FALSE
  MOUSESTATE mx, my, b1,b2

Danke hat funktioniert. ist vielleicht wichtig wo es eingebaut wird aber nur
 SYSTEMPOINTER FALSE
hat nicht funktioniert.
Werde heute vieleicht noch den überarbeiteten Code hochladen.

Offline Quentin

  • Prof. Inline
  • *****
  • Posts: 915
    • View Profile
star 01
« Reply #4 on: 2007-Nov-26 »
hat funktioniert? Bei mir nicht!
An welcher Stelle im Coding hast du es eingebaut?

Offline S.O.P.M.

  • Prof. Inline
  • *****
  • Posts: 529
    • View Profile
star 01
« Reply #5 on: 2007-Nov-26 »
Bei mir läuft das Game leider nicht. Ich kriege nur nen schwarzen Bildschirm und der Sound läuft. Mit Esc kann ich auch beenden aber mehr geht nicht.
Notebook PC Samsung E372 Core i5 @ 2,6 GHz; 4 GB RAM; Win 7 Home Premium

Bugman

  • Guest
star 01
« Reply #6 on: 2007-Nov-27 »
@ Quentin
Direkt nach dem Screenset Befehl.

// darstellung einstellen
  LIMITFPS 60
  SETSCREEN screen_x, screen_y, 1
// cursor abschalten
  SYSTEMPOINTER FALSE
  MOUSESTATE mx, my, b1,b2

@S.O.P.M.
Hört sich so an das die Media nicht gefunden werden.
(obwohl dann auch keine Musik kommen sollte)
Hmmmm??

Offline WPShadow

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1657
    • View Profile
    • http://lostrevenant.blogspot.com
star 01
« Reply #7 on: 2007-Nov-28 »
Bei mir war übrigens der selbe Fehler... =/
AMD X2 4600, 2 GB Ram, ATI X1950 XTX, XP PRO SP2: GLB Premium 10.beta_dingsi, <(´.´<) Kirby Dance (>`.`)>
http://lostrevenant.blogspot.com
alea iacta est

Bugman

  • Guest
star 01
« Reply #8 on: 2007-Nov-29 »
Hier noch eine euere Version.
Mit überarbeiteten Grafiken ...



http://www.zshare.net/download/52594377db678e/