BASIC

Author Topic: Mac/OSX/Lib*.a is out of date; rerun ranlib(1) (can't load from it)  (Read 495 times)

Offline r0ber7

  • Prof. Inline
  • *****
  • Posts: 528
    • View Profile
Does anyone know what this is? And why it is preventing me from compiling for Mac? I tried downloading the Mac.zip from both the v15 and v16 urls, but both give me this error.  :(

Running Windows 10.

Code: GLBasic [Select]
compile+link:
/cygdrive/q/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/Q/Compiler/platform/Mac/lib/libGLBasicMac.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/q/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/Q/Compiler/platform/Mac/OSX/Lib/libSDL_mixer.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/q/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/Q/Compiler/platform/Mac/OSX/Lib/libSDLmain.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/q/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/Q/Compiler/platform/Mac/lib/libCxImageMac.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/q/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/Q/Compiler/platform/Mac/OSX/Lib/libstdc++-static.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/q/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/Q/Compiler/platform/Mac/OSX/Lib/libstdc++.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/q/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/Q/Compiler/platform/Mac/OSX/Lib/libgcc.a is out of date; rerun ranlib(1) (can't load from it)
collect2: ld returned 1 exit status

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3669
    • View Profile
    • Space Fractal
You should try to move glbasic to a folder without spacebar in the foldername and try again.

Please note: This platform has been depreacted, due Apple choice to remove OpenGL, which is vital for glbasic (exept if we can find a OpenGL->Metal wrapper).

This platform should really been moved compeltly to xcode, but im do no longer have a Mac, nor a Iphone as well, and they has too been very pricy as well.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline Snoopy

  • Dr. Type
  • ****
  • Posts: 284
    • View Profile
Please note: This platform has been depreacted, due Apple choice to remove OpenGL, which is vital for glbasic (exept if we can find a OpenGL->Metal wrapper).
This platform should really been moved compeltly to xcode (...)

What you say is interesting (and a little sad too) and I wondered if it would not be a good idea to do a good interpreter for GLB ?
Yes, it's a bit difficult but I think it's the best solution, like AGK (but faster because the AGK interpreter is very slow).

Otherwise, a GLB version entirely in DirectX only for Windows would also be a good idea.
I will look at the source code as you advised me and see if I can help.

Note : r0ber7, I have a GLB foldername without a spacebar and it works, so Spacefractal is probably right.

Offline r0ber7

  • Prof. Inline
  • *****
  • Posts: 528
    • View Profile
Not helping.

Code: GLBasic [Select]
compile+link:
/cygdrive/c/GLBasic_v15/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/C/GLBasic_v15/Compiler/platform/Mac/lib/libGLBasicMac.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/c/GLBasic_v15/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/C/GLBasic_v15/Compiler/platform/Mac/OSX/Lib/libSDL_mixer.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/c/GLBasic_v15/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/C/GLBasic_v15/Compiler/platform/Mac/OSX/Lib/libSDLmain.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/c/GLBasic_v15/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/C/GLBasic_v15/Compiler/platform/Mac/lib/libCxImageMac.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/c/GLBasic_v15/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/C/GLBasic_v15/Compiler/platform/Mac/OSX/Lib/libstdc++-static.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/c/GLBasic_v15/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/C/GLBasic_v15/Compiler/platform/Mac/OSX/Lib/libstdc++.a is out of date; rerun ranlib(1) (can't load from it)
/cygdrive/c/GLBasic_v15/Compiler/platform/Mac/Bin/../libexec/gcc/i686-apple-darwin8/4.0.1/ld: table of contents for archive: /cygdrive/C/GLBasic_v15/Compiler/platform/Mac/OSX/Lib/libgcc.a is out of date; rerun ranlib(1) (can't load from it)
collect2: ld returned 1 exit status
*** FATAL ERROR - Please post this output in the forum
_______________________________________
*** Finished ***
Elapsed: 81.2 sec. Time: 20:15
Build: 0 succeeded.
*** 1 FAILED ***
 

I do not see any spaces in there. The multi-platform appeal of GLBasic is lessened in my opinion.  :doubt:

Offline Snoopy

  • Dr. Type
  • ****
  • Posts: 284
    • View Profile
It's strange and probably annoying  :rant:

Try to clean up your project and also try on Windows 7, to see if that comes from there (I have Windows 7 me).
For my part, I will try on Windows 10 with the same configuration as Windows 7, to see if I have this kind of problem.

Offline r0ber7

  • Prof. Inline
  • *****
  • Posts: 528
    • View Profile
It's strange and probably annoying  :rant:

Try to clean up your project and also try on Windows 7, to see if that comes from there (I have Windows 7 me).
For my part, I will try on Windows 10 with the same configuration as Windows 7, to see if I have this kind of problem.

I already had a Win7 build environment before. Didn't work on that either. I have given up trying to get this working for Mac, which is sad but yeah.