Author Topic: New fix for Playstore required  (Read 8732 times)

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3669
    • View Profile
    • Space Fractal
Re: New fix for Playstore required
« Reply #15 on: 2016-Jul-19 »
Gernot, can you email changes you have done for me? So im can make sure we are in sync? Im will also update the libPNG issue for AndroidExtras, so v12 also can been used in this week.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1519
    • View Profile
Re: New fix for Playstore required
« Reply #16 on: 2016-Jul-26 »
Any joy yet on this - I myself need the fix to work for v12 GLB - manual file copying a new update is fine if that will fix it :)
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1519
    • View Profile
Re: New fix for Playstore required
« Reply #17 on: 2016-Aug-10 »
If pointed in the right direction could I fix this myself? Is it complex to make the new libpng files?

Time is ticking on this as deadline is september after which NO updates or new apps will be allowed without this fix.

:)
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3669
    • View Profile
    • Space Fractal
Re: New fix for Playstore required
« Reply #18 on: 2016-Aug-11 »
Get your apps to get works with v14 instead. It's the way to go.

Actually I'm only so one source code base to compile.

V14 should been compatible with v12 as long you don't use new commands.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1519
    • View Profile
Re: New fix for Playstore required
« Reply #19 on: 2016-Aug-12 »
Hi SF,

So is the libpng issue fixed in v14 already then?

Are there any mobile-specific bugs still to be addressed in v14?

I may look at v14 when I have more time to transition my apps over...hopefully all will work first time.

Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
Re: New fix for Playstore required
« Reply #20 on: 2016-Aug-12 »
GLB v14 does not update libpng.

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3669
    • View Profile
    • Space Fractal
Re: New fix for Playstore required
« Reply #21 on: 2016-Aug-12 »
update it using web update. Gernot should have fixed it. Its just matter to update to the newest 1.4 version of it and then compile as its are. Im pretty sure its that Gernot did.

Im do need to wait to update mine, until im make sure me and Gernot is in sync.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline Paul Smith

  • Mr. Polyvector
  • ***
  • Posts: 109
    • View Profile
Re: New fix for Playstore required
« Reply #22 on: 2016-Aug-12 »
I think an auto-update on the IDE needs auto enabling.. I mentioned that this was fixed on the 16th of last month.People missing or not reading the whole post.
Amstrad CPC 6128, ATARI STE.
Acer  SW5-173 & AMD FX 8350/1050Ti

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
Re: New fix for Playstore required
« Reply #23 on: 2016-Aug-12 »
You're right, I had an outdated version. Later I will try if it has been fixed.

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3669
    • View Profile
    • Space Fractal
Re: New fix for Playstore required
« Reply #24 on: 2016-Aug-12 »
bot its different between glbasic 12 and 14. For Android its should not been a issue. Its same libraries used for both.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline msx

  • Prof. Inline
  • *****
  • Posts: 773
    • View Profile
Re: New fix for Playstore required
« Reply #25 on: 2016-Aug-13 »
The problem persists on GLB v14.329.

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3669
    • View Profile
    • Space Fractal
Re: New fix for Playstore required
« Reply #26 on: 2016-Aug-13 »
Im waiting to get Gernot email me, but there is some email issues yet. Then im will update Android Extras as well. Im want have me and Gernot have the same source code before im release new AE, which would been possible to remove the inapp purchase stuff (example on Amazon).

my email was changed, but im have pm him my email.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1519
    • View Profile
Re: New fix for Playstore required
« Reply #27 on: 2016-Aug-14 »
So would the fix for v14 work if the libpng related .h files were copied to v12??
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3669
    • View Profile
    • Space Fractal
Re: New fix for Playstore required
« Reply #28 on: 2016-Aug-14 »
v12 is begin to been old, so im can no longer garanti anything works. The issue is the file libpng_gf.a.

You might can copy the v14 version over to the v12 folder. There is no other changes than just updating the c code.

Here is the compiled version of it using v1.4.19, its a direct compiling with no other changes.

Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1519
    • View Profile
Re: New fix for Playstore required
« Reply #29 on: 2016-Aug-14 »
Thanks SF!

Excellent, I have recompiled one of my apps with the libpng new file in the compiler/android/libs folder

:)

Android devs, (verify libpng version)
To check for libpng version (post-compile) open glbasic-debug.zip > lib > armeabi > libmain.so (notepad.exe)
search for '1.4.19' to find libpng version if present it should be okay :)
« Last Edit: 2016-Aug-14 by MrPlow »
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs